Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SDavi16
Beginner
4,115 Views

Having WOL problems with an Intel 82567-LM3 adaptor on a Dell OptiPlex 760 motherboard using Windows 10 Pro 64

I've been trying to troubleshoot this issue now for months on and off and have gotten nowhere.

It seems that WOL is broken when using this hardware under Windows 10.

I've been using the Windows 10 driver that installs by default (version 12.155.22.6 dated 4/5/2016) and have not been able to find a different one (latest ProSet software doesn't contain a driver for this adaptor).

I've set everything up that various internet threads I've read have said to do, this includes:

BIOS:

Enable the adaptor (duh)

Enable Remote Wake Up

Disable Low Power Mode

Windows:

Disable Fast Startup

Make sure, under the Power Management tab, that all the boxes are checked.

There are no properties for "Waking" in Advanced Properties for the adaptor so I can't set them, nor is there a PME Event Property to check/change.

---

I know that WOL is possible for this machine because I popped in a PCI NIC and got WOL to work on that NIC, but this integrated adaptor just won't comply.

Lot's of threads out there saying it can be done, but I can't seem to do it on my hardware.

Here's a capture from BOOTUTIL showing that WOL is supposed to work...

---

C:\Intel22.4.0.1\APPS\BootUtil\Winx64>BOOTUTILW64E.EXE

Intel(R) Ethernet Flash Firmware Utility

 

BootUtil version 1.6.40.1

 

Copyright (C) 2003-2017 Intel Corporation

Port Network Address Location Series WOL Flash Firmware Version

 

==== =============== ======== ======= === ============================= =======

 

1 0024E819DC99 0:25.0 Gigabit YES FLASH Not Present

---

One suggestion I found was to update the boot agent (mine is 1.3.81) to the latest (1.5.something) and then throw a flag in the boot agent setup that supports WOL.

However, I do not think I can update the boot agent as BOOTUTIL says there's no flash firmware present to do so, or correct me if I'm wrong.

Ideas on how to update the boot agent?

Aside from that any other ideas?

===

Editing to add infomation

===

Well, I never thought I'd see the day that Linux supported old hardware better than Windows but that day is today.

Reference this thread: https://software.intel.com/en-us/forums/intel-business-client-software-development/topic/637955 Wake on Lan, Windows 10 Pro, integrated 82567LM-3

And see what the Fabrice person says.

The instructions in this referenced thread above were too generic to work verbatim, but they were enough for me to figure my own way to try out WOL under a Linux distro lickety-split.

In a nutshell this person suggests booting to Linux, turning on WOL, then booting back to Windows, as if that would permanently and magically enable WOL in Windows.

Well, nice try, that doesn't work because, I assume, Windows initializes the adapter when it gets back in control.

What DOES work is Linux. I was able to create a bootable Ubuntu USB stick and in under 5 minutes booted the machine into Ubuntu and tested WOL. It WORKED. Wow.

So what we have is a crappy Windows 10 driver that doesn't support WOL, at least not with ANY combination of windows settings I've tried.

There have got to be 10s of 1000s of OptiPlex 760s (and not to mention other models with this common adapter) out in the wilds of the business world, and Microsoft and/or Intel, with this stunted driver, has basically shat all over the owners with regards to the management of these computers with these adapters. If I was a IT guy for a company with 1000 of these and couldn't wake any up to do remote management, I'd be pretty damn grumpy. I'm grumpy now and I only have 10 of these.

Way to go WinTel.

So, back to the original problem...anyone have any ideas on how it might be gotten to work?

Custom Driver?

Hack current driver?

New driver not commonly known?

Some setting I've missed?

Anything...anything to make this work.

0 Kudos
13 Replies
idata
Community Manager
1,212 Views

Hi TheScottster,

 

 

Thank you for posting at Wired Communities. Unfortunately there is no Windows 10 driver nor the PROSet software with advance setting for 82567LM since this is consider a legacy ethernet controller. Please refer to website below:

 

https://downloadcenter.intel.com/product/32208/Intel-82567-Gigabit-Ethernet-Controller

 

 

Since this is an embedded NIC on Dell system, have you checked with Dell for customized driver as it is recommended to use the driver from the OEM system vendor which is more suitable for your system.

 

 

As mentioned in our bootagent update reference site https://www.intel.com/content/www/us/en/support/network-and-i-o/ethernet-products/000005992.html

 

 

"Contents of this archive are not intended for network connections that are built into the computer, such as the PRO/100 VE, PRO/100 VM or PRO/1000 CT Network Connection. For built-in network connections, the boot agent must be updated as part of a BIOS update. Contact your system vendor for information."

 

 

Hope this help.

 

 

regards,

 

sharon

 

 

 

 

idata
Community Manager
1,212 Views

Hi TheScottster,

 

 

Please feel free to update me if further assistance needed.

 

 

Regards,

 

sharon

 

SDavi16
Beginner
1,212 Views

I doubt Dell will have anything, but I'll look into it, and if they do, post here for the benefit of the myriad others who are screwed by this.

idata
Community Manager
1,212 Views

Hi TheScottster,

 

 

Thank you for the reply and hope to hear good news from you.

 

 

Regards,

 

sharon

 

SDavi16
Beginner
1,212 Views

Initial prognosis not good.

While I didn't speak with anyone from Dell, I wasn't able to find any driver at their site that was for this adapter and Windows 10; Windows 7 yes, but that one doesn't work for WOL.

Next step is to call them (oh joy) and also to look at other big vendors, like HP, who may have had a Windows 10 driver written for them.

But this is an Intel board...I'd think someone at Intel would know if this was the case or not.

idata
Community Manager
1,212 Views

Hi TheSCottster,

Thank you for the update. Here are some information you can try:

 

Option 1. Enable WOL in the BIOS

Option 2. Go into power management and uncheck "turn off this device to save power" for the NICs,

Option 3. Change the BIOS sleep setting from S3 (deep sleep) to S1 (restless sleep).

However, please contact Dell* support as you are using Dell* system, the system vendor have their customized design and feature which is beyond our supporting scope.

Checking on the Dell Optiplex specs at http://www.dell.com/downloads/emea/products/optix/Optiplex_brochure_760_isen.pdf http://www.dell.com/downloads/emea/products/optix/Optiplex_brochure_760_isen.pdf, the Windows 10 is not the supported OS, you might want to further check with Dell.

Thanks,

sharon

SDavi16
Beginner
1,212 Views

This will not work for the following reasons, but thank you for offering the idea.

1. I already tried unchecking the "turn off device" checkbox in prior experimentations and it did nothing.

2. There is no S1/S3 option in the BIOS. The closest thing is another checkbox called "Low power mode", which I normally have unchecked, and have tried experimenting with it checked as well.

SDavi16
Beginner
1,212 Views

Another update.

Just got off the phone with Dell technical support and got the standard line "The OptiPlex 760 is legacy and not tested or approved with Windows 10, therefore no Dell specific Windows 10 drivers exist for any of the hardware".

So, laziness all around on Microsoft, Intel, and Dell's part.

No one wants to take the time to mod the driver for the network adapter to include WOL functionality. End of story.

No wonder there are jillions of OptiPlex 760 computers on the aftermarket...big corporations can't use them under Windows 10 because remote wakeup is an absolute MUST.

So bottom line...NO SOLUTION other than USE LINUX, which for me is not an option.

Sad day.

I do have a workaround, thank goodness, but it's going to cost a bit. For about $15 a pop I can get a PCI network card that supports WOL. Not what I wanted to do, but it's the only thing I CAN do.

Please leave this thread open for a bit in case anyone discovers something new. I'm not going to implement the PCI network card workaround for a few months.

idata
Community Manager
1,212 Views

Hi Scottster,

 

 

Thank you for the update and I am sorry to hear that. In case any one has the suggestion, they can update the thread from here. Thanks.

 

 

regards,

 

sharon

 

SDavi16
Beginner
1,212 Views

I forced the adaptor driver to be a 82579LM, which is included in the latest ProSet for Windows 10.

This actually didn't crash horribly and basic networking functioned, but the WOL still did not.

Almost thought I pulled a rabbit out of the hat.

SDavi16
Beginner
1,212 Views

I might add that I missed one important setting in my original post and that is to set your active power profile to not allow Hybrid Sleep.

VDeFo1
Beginner
1,212 Views

Even though I know this is an old post, I figured I would share my experience since I was able to get this working today.

I have an HP dc7900 I was messing with this on - which seems to be pretty similar to the OPs hardware.

 

It has an Intel 82579LM-3. I'm running Windows 10 Pro 1909 and I was using the inbox Intel driver. I had WOL from Sleep / Hibernate working prior to doing anything, but WOL from Shutdown (S5) would not work. If I completely powered the computer off from BIOS, S5 would work, but not when the computer was shutdown from Windows.

 

Here are the steps I took:

1) Made sure Wake on S5 is enabled in BIOS

2) Disabled Fast Startup

3) Set a registry key that HP recommended: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NDIS\Parameters

DWORD - AllowWakeFromS5

Value - 1

This didn't work by itself and I haven't tried removing it to see if it is actaully required

4) Download the 22_10.zip file for "Intel Ethernet Adapter Complete Driver Pack" from:

https://downloadcenter.intel.com/download/27495/Intel-Ethernet-Adapter-Complete-Driver-Pack

5) Extract the zip file

6) Open up device manager

7) On the NIC, choose Update Driver / Have Disk Method - point to this folder: PRO1000\Winx64\NDIS65

8) The Intel 82579LM Gigabit Network Connection should be one of the options - choose that

9) When it says "Installing this device driver is not recommended" - just say Yes

10) It should install a driver version 12.15.31.4 from 7/25/2016

11) Make sure your Internet / Network are working

12) Go under the Power Management tab - ensure Allow device to wake the computer / only allow a magic packet are selected

13) *Important* - go under Advanced - you shoudl see "Enable PME" - make sure that is on Enabled

14) Also check "Wake on Magic Packet and Wake on Pattern Match" for Enabled

 

After doing all of this, shutdown the computer and try to use your wol utility. I was using WOL.exe 2.1 from www.gammadyne.com. I couldn't get it to work from Right-Click tools in SCCM (but I've never used those for WOL before), but it works great with the WOL utility. I was able to powerup the DC7900 from a complete shutdown state.

 

Hopefully this will help someone out there. More importantly, I hope Intel doesn't take down the 22.10 ProSet after I say that this works... The only thing I can think of is the driver might end up reverting during the next Windows feature update - for example going Post 1909 - but that remains to be seen. Good luck!

SDavi24
Beginner
1,212 Views

Appreciate your sharing VDeFo1, but no dice for me.

If you check out my 2 posts (the ones right before yours) you'll see that I already tried what you did - I tried to use the 82579LM driver instead of the 82579LM-3 one.

Just to check things though, I revisited the attempt, and followed your steps almost PRECISELY.

One thing couldn't be done: EnablePME was not an option in my Advanced tab, and therefore could not be set. That may well have been the difference between success and failure.

I started thinking why that option wasn't there for me and was for you. Perhaps the driver install does an inquiry to the hardware and determines my hardware isn't capable of that, or THINKS it isn't capable of that. Dunnow.

But in the end, still no WOL.

One last idea, in case you read this...

Maybe if you can export the settings in your registry for your setup that works, I can compare them to mine and manually add whatever flag (or flags) get set by this "EnablePME" option.

It's a Hail Mary, but that's all I have right now.

Thanks,

Scott

PS. Sorry it took so long to respond but the Intel support system rejected my original logon, and I had to open a support case with Intel just to get back here to the forums.