Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CZ
Novice
1,579 Views

Here we go again - I210 and Teaming = Fail

After Microsoft's last update was pushed out, it wiped all my Hyper-V switches, Teams , etc. I have followed the instructions I have found on Intel's site for manually removing the invisible, but still in the registry, adapters. After re installing 22.9, the NIC's (2 x I210) install fine. When trying to Team, the attached error is all I get. I have to go in to Device Mangler and uninstall the disabled adapter.

Before Attempting to Team:

During install:

After Install:

Top remove that disabled Ethernet 5 I have to go to Device Manager and Uninstall Intel(R) Advanced Network Services Virtual Adapter

Any help is greatly appreciated.

Happened with 22.7.1 also.

 

Z
0 Kudos
5 Replies
idata
Community Manager
104 Views

Hi Ffzeus,

 

 

Thank you for posting in Wired Communities. Please share additional information:

 

 

1) What is the Windows operating system used?

 

2) What is the server brand and model? Are these two I210 onboard NIC?

 

3) What is the teaming mode?

 

4) Was the teaming working prior the updates, what is the previous driver version that works fine?

 

 

Thanks,

 

Sharon
CZ
Novice
104 Views

Hi,

Sorry. Had to rush out the door as Inwas trying to get that up.

Windows 10 x64 latest MicroSoft Updates/Version.

On board I 210's ASUS P9X79E-WS

Was working prior to this last update from MS with version 22.3 of the driver. 22.3 also does not work now. Same results as 22.7.1 and 22.9.

I followed the Carl Wilson led thread the last time this happened, (thanks MicroSoft). It would seem whatever they hosed up that time around has come back again, or they changed something else in the tear down and build of the driver stack.

idata
Community Manager
104 Views

Hi Ffzeus,

 

 

Thank you for the prompt update. Understand now you are using Windows 10 FC 1709, just to double check if you have also post your inquiry in Microsoft since this issue occurred after the Windows* updates.

 

 

Is there any software or driver available from Asus* for the I210 on the system? Have you tried that out if there is? Please feel free to update me. Thank you.

 

 

Regards,

 

Sharon

 

 

CZ
Novice
104 Views

Hi Sharon,

ASUS releases an initial version of their drivers with their boards and very rarely updates them. They used to be better but really have started to suck as a company the last 4-5 years. Their last driver was Version 18.x.xx.02014/03/14.

I am providing the link to the previous discussion on this. Perhaps familiarize with the problem there and chat to Carl if he is still around. Microsoft does not support teaming on Windows 10 and Intel does their best to give us a work around. Unfortunately, that means every time MS messes with the network pieces of the OS, something tends to get wonky.

Z

CZ
Novice
104 Views

After multiple attempts to make this work, poof, it magically did.

Steps taken:

Uninstalled previous version of Intel Network Software.

Manually removed all instances of ghosted NICs.

Tried installing with no joy.

Uninstalled Intel adapters from Device Manager deleting drivers

Reinstalled Intel Network Software (22.9) no joy again

Rise and repeat above multiple times

After uninstalling and deleting software, drivers and NIC's for the umpteenth time reinstalled 22.9

Noticed NIC # 2 had the "Advanced" tabs but NIC # 1 did not

SOLUTION:

Uninstalled Intel Network Software and drivers.

Disabled NIC # 2

Installed 22.9 Intel Network Software and Drivers

Check configuration pages of both NIC's

Both now have Advanced tabs showing

Team NIC's succesfully

So, it seems the Intel software doesn't completely build out for NIC 1 but it does for NIC 2 if both are enabled when the install happens.

If one NIC is disabled then both build out correctly

At the risk of causing myself more frustration, I removed everything and tried this thought out 8 more times. It worked every time with one NICs enabled (4 times) and failed every time with both NIC's enabled (4 times)

Maybe this will help someone else.

Z

Reply