Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JWang113
Beginner
1,498 Views

How many MAC_VLAN filters can be added to a XL710 port

Hi,

I found a problem that when adding vlans to a XL710 port only 255 vlans can be configured.

Further configuration will return with error message as "ixl0: aq_add_macvlan err -53, aq_error 16"

-53 means admin queue error and 16 should be no space available or alloc fail.

This is found on FreeBSD OS and with driver 1.4.8 and latest NVM on chip.

Could you please help confirm what issue it is?

Thanks very much.

Regards,

Jingxun

0 Kudos
16 Replies
idata
Community Manager
263 Views

Hi Jingxun,

 

 

Thank you for contacting Intel. I'll have to further check on this.

 

 

Sincerely,

 

Sandy
idata
Community Manager
263 Views

Hi Jingxun,

 

 

Thank you for contacting Intel.

 

 

Please try the driver below:

 

https://downloadcenter.intel.com/download/25160/Intel-Network-Adapter-Driver-for-PCI-E-40-Gigabit-Et...

 

 

I hope this is able to fix the error.

 

 

Sincerely,

 

Sandy
idata
Community Manager
263 Views

Hi Jingxun,

 

 

I'm checking in to see if you were able to try the driver in my previous post. Hope this is helpful.

 

 

Sincerely,

 

Sandy
JWang113
Beginner
263 Views

Hi Sandy,

Just upgraded driver to v1.4.27 the lastest, the same issue still exists.

Prompt like:

aq_add_macvlan err -53, aq_error 16

Is it likely a hardware limitation? But VLAN is a common use, seems not reasonalbe...

Thanks for your help.

idata
Community Manager
263 Views

Hi Jingxun,

 

 

Thanks for sharing your test results. Did you still have 255 VLANs configured on the port? If you configure lesser VLANs, do you encounter the error? Please advise.

 

 

Sincerely,

 

Sandy
JWang113
Beginner
263 Views

Thanks for your quick response, Sandy.

The issue appears when adding the 256th VLANs on an XL710 port.

It is not related with VLAN ID but only with the number of VLANs.

There's no problem configuring less than 255 VLANs, thus I wonder if it reaches some hardware limitations, as the error prompt implies.

Regards,

Jingxun

idata
Community Manager
263 Views

Hi Jingxun,

 

 

The XL710 Adapter can support up to 512 VLAN tags. Please refer to datasheet:

 

http://www.intel.com/content/www/us/en/embedded/products/networking/xl710-10-40-controller-datasheet...

 

(Page 20)

 

 

To further isolate the issue, can you try using other network adapters? Try to configure as much VLAN with it. The issue may be caused by system resources or OS limitation.

 

 

Sincerely,

 

Sandy
JWang113
Beginner
263 Views

"Supports VLAN insertion and removal for up to 512 VLAN tags located anywhere in the 4K VLAN space"

I think you were saying about this introduction, right?

In my understanding this is related with HW tagging, an offload functionality. Does it also limit the VLAN_MAC filter number?

Can you help confirm the meaning of the 2 return errors (-53/16)?

I tried with 82599 NIC in the same box and 4094 VLAN can be configured successfully.

idata
Community Manager
263 Views

Hi JIngxun,

 

 

Thanks for your reply. Allow me to further check on your concerns.

 

 

Sincerely,

 

Sandy
idata
Community Manager
263 Views

Hi Jingxun,

 

 

We would like some more specific configuration information:

 

- which FVL device is in use?

 

- which NVM is loaded?

 

- how is the interface reacting after this failure?

 

- which BSD version is in use?

 

 

We look forward to your reply.

 

 

Sincerely,

 

Sandy
JWang113
Beginner
263 Views

Hi Sandy,

This is about the NIC info I can collect:

>> 2 port 40G NIC

>> Part number as XL710-QDA2 932587.

>> Firmware info: f5.0 a1.5 n05.02 e80002285

When VLAN 1-255 can be configured and traffic with tag 1-255 can be received, packets with other tags cannot be received by the driver. Suspect dropped by VLAN filter since adding operation failed.

Our OS is based on FreeBSD 10.1.

Thank you very much for your help.

Regards,

Jingxun

JWang113
Beginner
263 Views

I also tried it in Linux (CentOS) with driver 1.4.25, failed also.

AVX# devinfo

-bash: devinfo: command not found

AVX# modinfo i40e

filename: /lib/modules/3.10.0-123.6.3.6.el7.x86_64/kernel/drivers/net/ethernet/intel/i40e/i40e.ko

version: 1.4.25

license: GPL

description: Intel(R) Ethernet Connection XL710 Network Driver

author: Intel Corporation, <<a href="mailto:e1000-devel@lists.sourceforge.net">e1000-devel@lists.sourceforge.net>

srcversion: 9DEBFC820DDB282C7A4A5FF

alias: pci:v00008086d00001588sv*sd*bc*sc*i*

alias: pci:v00008086d00001587sv*sd*bc*sc*i*

alias: pci:v00008086d00001589sv*sd*bc*sc*i*

alias: pci:v00008086d00001586sv*sd*bc*sc*i*

alias: pci:v00008086d00001585sv*sd*bc*sc*i*

alias: pci:v00008086d00001584sv*sd*bc*sc*i*

alias: pci:v00008086d00001583sv*sd*bc*sc*i*

alias: pci:v00008086d00001581sv*sd*bc*sc*i*

alias: pci:v00008086d00001580sv*sd*bc*sc*i*

alias: pci:v00008086d00001574sv*sd*bc*sc*i*

alias: pci:v00008086d00001572sv*sd*bc*sc*i*

depends: ptp,vxlan

vermagic: 3.10.0-123.6.3.4.el7.x86_64 SMP mod_unload modversions

parm: debug:Debug level (0=none,...,16=all) (int)

[275193.765380] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=248

[275193.794063] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=249

[275193.808022] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=250

[275193.822039] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=251

[275193.835389] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=252

[275193.851719] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=253

[275193.866715] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=254

[275193.880206] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=255

[275193.894271] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=256

[275194.475980] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=257

[275194.739057] i40e 0000:03:00.0: add filter failed, err I40E_ERR_ADMIN_QUEUE_ERROR aq_err I40E_AQ_RC_ENOSPC

[275199.197986] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=258

[275199.217393] i40e 0000:03:00.0: add filter failed, err I40E_ERR_ADMIN_QUEUE_ERROR aq_err I40E_AQ_RC_ENOSPC

[275201.212187] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=259

[275201.230049] i40e 0000:03:00.0: add filter failed, err I40E_ERR_ADMIN_QUEUE_ERROR aq_err I40E_AQ_RC_ENOSPC

[275203.578316] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=260

[275203.594539] i40e 0000:03:00.0: add filter failed, err I40E_ERR_ADMIN_QUEUE_ERROR aq_err I40E_AQ_RC_ENOSPC

[275206.215948] i40e 0000:03:00.0 enp3s0f0: adding 00:0c:bd:08:7d:e8 vid=261

[275206.231784] i40e 0000:03:00.0: add filter failed, err I40E_ERR_ADMIN_QUEUE_ERROR aq_err I40E_AQ_RC_ENOSPC

Regards,

Jingxun

idata
Community Manager
263 Views

Hi Jingxun,

 

 

After further checking internally, this issue will be fixed in the future driver release.

 

 

regards,

 

Vince
idata
Community Manager
263 Views

Hi Jingxun,

 

 

AS mentioned, a future driver will be released and this will be available in few weeks time but we do not have the exact timeline.

 

 

Hope this clarified.

 

 

thanks,

 

wb

 

idata
Community Manager
263 Views

Hi Jingxun,

 

 

Please refer to the link below and try the newer version 1.6.8

 

https://downloadcenter.intel.com/product/82945/Intel-Ethernet-Controller-XL710-AM1

 

 

Hope this helps.

 

Thanks,

 

wb

 

idata
Community Manager
263 Views

Hi JingXun,

 

 

Please feel free to update me the test result if you have tried the driver link I shared on the previous post

 

https://downloadcenter.intel.com/product/82945/Intel-Ethernet-Controller-XL710-AM1 https://downloadcenter.intel.com/product/82945/Intel-Ethernet-Controller-XL710-AM1

 

 

thanks

 

wb

 

Reply