Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,248 Views

How to overcome ixgbe unsupported sfp issue (Linux)

Trying to use this SFP: https://store.supermicro.com/aom-aqs-107-b0c2-cx.html

 

in this motherboard: https://www.supermicro.com/products/system/Mini-ITX/SYS-E300-9A.cfm

 

I have tried to set the ixgbe driver to allow unsupported SFPs but still I get:

 

sudo dmesg | grep ixgbe

[  0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-8-amd64 root=UUID=f3b7c672-caa2-44b2-84fc-9a7f6290a0e6 ro ixgbe.allow_unsupported_sfp=1,1,1,1 quiet

[  0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-8-amd64 root=UUID=f3b7c672-caa2-44b2-84fc-9a7f6290a0e6 ro ixgbe.allow_unsupported_sfp=1,1,1,1 quiet

[  2.129003] ixgbe: loading out-of-tree module taints kernel.

[  2.140872] ixgbe: allow_unsupported_sfp Enabled

[  3.256324] ixgbe 0000:07:00.0: Multiqueue Enabled: Rx Queue count = 12, Tx Queue count = 12

[  3.352333] ixgbe 0000:07:00.0 eth0: MAC: 6, PHY: 7, PBA No: 030000-000

[  3.352337] ixgbe 0000:07:00.0: ac:1f:6b:57:56:ce

[  3.352340] ixgbe 0000:07:00.0 eth0: Enabled Features: RxQ: 12 TxQ: 12 FdirHash vxlan_rx 

[  3.358429] ixgbe 0000:07:00.0 eth0: Intel(R) 10 Gigabit Network Connection

[  3.368803] ixgbe: allow_unsupported_sfp Enabled

[  4.968381] ixgbe 0000:07:00.1: Multiqueue Enabled: Rx Queue count = 12, Tx Queue count = 12

[  5.064596] ixgbe 0000:07:00.1 eth1: MAC: 6, PHY: 7, PBA No: 030000-000

[  5.064600] ixgbe 0000:07:00.1: ac:1f:6b:57:56:cf

[  5.064603] ixgbe 0000:07:00.1 eth1: Enabled Features: RxQ: 12 TxQ: 12 FdirHash vxlan_rx 

[  5.070708] ixgbe 0000:07:00.1 eth1: Intel(R) 10 Gigabit Network Connection

[  5.081043] ixgbe: allow_unsupported_sfp Enabled

[  5.596286] ixgbe 0000:08:00.0: Multiqueue Enabled: Rx Queue count = 12, Tx Queue count = 12

[  5.665648] ixgbe 0000:08:00.0 eth2: MAC: 6, PHY: 0, PBA No: 030000-000

[  5.665652] ixgbe 0000:08:00.0: ac:1f:6b:57:56:d0

[  5.665655] ixgbe 0000:08:00.0 eth2: Enabled Features: RxQ: 12 TxQ: 12 FdirHash vxlan_rx 

[  5.671760] ixgbe 0000:08:00.0 eth2: Intel(R) 10 Gigabit Network Connection

[  5.682057] ixgbe: allow_unsupported_sfp Enabled

[  5.738332] ixgbe 0000:08:00.1: failed to load because an unsupported SFP+ or QSFP module type was detected.

[  5.738635] ixgbe 0000:08:00.1: Reload the driver after installing a supported module.

[  5.740291] ixgbe 0000:07:00.0 eno5: renamed from eth0

[  5.769480] ixgbe 0000:07:00.1 eno6: renamed from eth1

[  5.809047] ixgbe 0000:08:00.0 eno7: renamed from eth2

 

Supermicro support has been limited but they have told me they tested that specific SFP in that specific motherboard successfully.

 

How can I solve this problem?

Tags (1)
0 Kudos
3 Replies
Highlighted
221 Views

Hello SPont1, Thank you for posting in Intel Ethernet Communities. Kindly provide the details below as this would help us to investigate the problem. 1.) ixgbe driver version installed on your system 2.) Linux version 3.) Just to double check, we'd like to know if you are using the SFP for Intel® i350-AM4 or Intel® C3000 SoC? 4.) You've mentioned that supermicro have tested that specific SFP in that specific motherboard successfully, can you share if you tried to check on what they did that they were able to test that specific SFP successfully? Looking forward to your response. Best regards, Crisselle C Intel Customer Support Under Contract to Intel Corporation
0 Kudos
Highlighted
221 Views

Hello SPont1, Please provide the requested information for us to check the problem. Looking forward to your response. Best regards, Crisselle C Intel Customer Support Under Contract to Intel Corporation
0 Kudos
Highlighted
221 Views

Hello SPont1, Kindly provide the details that we require for us to check on your query. We look forward to hear from you. Best regards, Crisselle C Intel Customer Support Under Contract to Intel Corporation
0 Kudos