Ethernet Products
Intel® Ethernet products and technologies
3890 Discussions

I-219V + 26.2 driver = failed Hardware Test/Interrupt Status

MDib
New Contributor I
16,884 Views

Hello,

The latest ethernet driver fails the Interrupt Status Hardware Test. Returning to 26.1 fixes it (as seen in the second image). Functionality seems normal, it's just that self test that fails consistently.

Motherboard is a Z370 Gaming Plus from MSI with a 8700K.

Screenshot 2021-04-01 222902.png

Screenshot 2021-04-01 223558.png

  

0 Kudos
40 Replies
Mike_Intel
Moderator
13,417 Views

Hello MDib,


Thank you for posting in Intel Ethernet Communities. 


For us to further check the issue, please provide the following details.


  1. what is your OS?
  2. Are you using an onboard I219-V?
  3. Can you share the link of your latest driver?
  4. Did you try to remove or uninstall the old driver before installing the latest driver? If not yet, can you try by following the steps below:


https://www.intel.com/content/www/us/en/support/articles/000058304/network-and-io/ethernet-products....


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support Technician


MDib
New Contributor I
13,410 Views

Hello,

- Win 10 Pro 20H2 19042.906

- yes the I219-V is onboard, it is a MSI Z370 Gaming Plus motherboard, with a 8700K, latest BIOS from MSI

- 26.2 driver downloaded from here:

https://downloadcenter.intel.com/download/22283/Intel-Ethernet-Adapter-Complete-Driver-Pack

Typically I use the x64 download as it's smaller, but it was not yet available.

I'll try the clean install on that article later on when I get home. For now I reverted to the older driver which doesn't result in that error.

I'll return with another post after.

Josie
Beginner
11,863 Views

Hi, I also downloaded driver 26.2 from here https://downloadcenter.intel.com/employee monitoring/22283/Intel-Ethernet-Adapter-Complete-Driver-Pack Can you tell me if it is better to download another driver?

MDib
New Contributor I
13,395 Views

Alright, did some more testing.

- clean install 26.2 as per the guide in the link provided, problem persists

- installed 26.1, and used "Update driver" from the Device Manager to update to the new driver in the 26.2 package (12.19.1.32) - without installing the PROSet app in its entirety. The Interrupt Status test passes just fine

- the Interrupt Test also fails with the new PROSet app after I rolled back to the old Windows 10 default driver, 12.17.10.8.

It might be the new PROSet application? As the drivers seems fine when used in the old PROSet app, but they all (I tried 3 driver versions) fail that test within the new PROSet app. 

I am putting in the image the PROSet app version in 26.2 which fails this test.

Screenshot 2021-04-02 204315.png

GregH22
Beginner
13,378 Views

I receive the same on the test, same update link! What really drove me to that test even is the random network connectivity.  

Seemingly random but when pinging the same particular machine on my own network I get a destination host unreachable and arp is invalid: see attached. Flat network and other machines on network have no issue getting reply.

If I physically disconnect and reconnect this destination machine it can then see it (at least temporarily).

I then try to boot to WinPE USB stick and same results.

 

Note mine is a Intel i219-LM as part of an HP Elitedesk.

I just obtained this machine, so I don't have any history to go back to

Mike_Intel
Moderator
13,353 Views

Hello MDib,


Thank you for the very detailed update. Can you tell us the driver version that you are using right now that has no issues?


And also, please help generate the SSU for your system for us to further investigate:

Kindly download the SSU here:


https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?wapkw=ssu


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support Technician


MDib
New Contributor I
13,334 Views

Hello Michael, 

At this moment I settled on the 26.1 PROSet package and the manually installed 12.19.1.32 driver from the 26.2 package. The PROSet app is 26.1.0.4, and that seems to be the culprit (its 26.2 version, more exactly, which fails with earlier drivers too).

Screenshot 2021-04-05 153532.png

 I'll try to send the SSU info in a PM. 

Edit: PM with the logs sent!

GregH22
Beginner
13,305 Views

Regarding mine post, I think we eliminate the part about arp and IP address, that I found to be caused by blocking of broadcasts except by approved MAC,  but I still get the Failed interrupt status.

Mike_Intel
Moderator
13,280 Views

Hello MDib,


Thank you so much for providing the information and the SSU logs that we requested. Let me further check this issue and kindly give us 2 to 3 working days to provide an update.


Hello GregH22,


For us to further assist you and gathered the necessary details to analyze your system. kindly create a separate post.


Best regards,

Michael L.

Intel® Customer Support Technician


Mike_Intel
Moderator
13,241 Views

Hello MDib,


We just want to inform you that we are now checking this issue and we are placing this one as high priority inquiry.

While doing this, we also want to make sure that everything is working fine. Aside from failed Hardware Test/Interrupt Status. Are you also having other issues on driver version 26.2 or just the Interrupt status?


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support Technician


MDib
New Contributor I
13,228 Views

I haven't noticed any issues. From my end, the "bug" looked completely cosmetic and related to the PROSet app, not the driver itself.

I've been using the latest driver with the old app for days now and all seems quite normal. Of course, that's just what I can perceive from day to day use and a short look at the Event Viewer log. The download and upload speeds are fine, there are no connection drops, no errors in the logs, all good.

Mike_Intel
Moderator
13,184 Views

Hello MDib,


Thank you for a very detailed reply to our question. This will definitely help us in our investigation with the driver issue that you reported. Please give us 2 to 3 working days to provide an update on this one.


Best regards,

Michael L.

Intel® Customer Support Technician


Mike_Intel
Moderator
13,115 Views

Hello MDib,


I hope you're having a wonderful day. I just want to update you that we are still currently checking the issue or bug that you reported. While in the process of checking this issue, we want to clarify and kindly confirm you downloaded and installed both the Wired_driver_26.2_x64.zip and the Wired_PROSet_26.2_x64.zip packages. 


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support Technician


MDib
New Contributor I
13,095 Views

Hello, 

I see the smaller packages are online, instead of the large package that's for all the OSs. I installed from those you indicated, and the problem persists indeed.

Screenshot 2021-04-12 163245.png

Mike_Intel
Moderator
13,068 Views

Hello MDib,


Thank you for trying and for the quick update. Let me document this for our investigation and provide an update once we have one. Please give us 2 to 3 working days to provide an update on this one.


Best regards,

Michael L.

Intel® Customer Support Technician


Mike_Intel
Moderator
13,033 Views

Hello MDib,


I hope you are having a good day. By the way, while documenting the information that you provided. We just want to clarify if you install first the Wired_driver_26.2_x64.zip prior installing the Wired_PROSet_26.2_x64.zip? Because it is important to install first the driver to be detected and properly synced up with the PROset utility.


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support Technician


MDib
New Contributor I
13,027 Views

Yes the driver was installed first.

Mike_Intel
Moderator
12,999 Views

Hello MDib,


Thank you for the quick reply and please be patient as we try to further check the issue the you reported. Please give us 2 to 3 working days to provide an update.


Best regards,

Michael L.

Intel® Customer Support Technician


Gabogabo04
Beginner
12,974 Views
Hello I'm having the same issue and it is bricking my network.
toorang
Beginner
12,682 Views

hi

I have the same problem
My device : Asrock z87 extreme 4 __ Intel I217-V
MY driver : 12.19.1.32
What should I do to solve the problem?
Reply