Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4630 Discussions

I210 Gigabit Network can not receive ethernet frame more than 126 bytes on DELL system - Windows



I emailed Intel Customer Support before(case ID # 05178450), Intel advised me contact Dell to get support causing it is an embedded device (I210) on Dell system.

But Dell said that I has no 'service tag' or 'serial number', so can not service for me. I tried to tell them,  Product:"0K8Y0N" and Serial Number:"..CNFCP0081U01ID." which I got from ssu.exe out put information, but Dell support said that he can not find any product releted these information.

So I have to try post information here again, maybe smart people here can help me.

A hosting company - provide a server named 'DSS5100' which has C2338 CPU and onboard I210 Gigabit Network - This server works find when installed Linux OS. But if intalled Windows(like Windows 10 or Windows Server 2019 etc), I210 can sent packages, but can not receive/process packages which is larger than 126 bytes. One example is ping server-ip with -l 85(ping ip-address -l 85) will time out, but ping with default or less than 85 bytes, it is okay.

I tried to contact hosting company for help, but said that Windows is not support. I tried to contract Dell company for help, but Dell require 'service tag' which is labeled on device, I can not touch device, and refused to tell me Dell dvice's 'service tag' or 'serial number'.

I am a newbie, have to do more test. Server can login via VNC remotely, but Windows RDP can not, maybe it is caused RDP package is larger than 126 bytes. I tried to set MTU to 112 bytes on Windows, but failed. The Minimum MTU on Windows is 352 bytes - . I tried to setup a Debian Linux box as a proxy, and set Debian MTU to 112 bytes (ip link set enp0s3 mtu 112),  Then I can RDP to server from my computer via this Debian proxy.

As Windows and Intel website, I210 Gigabit Network should be full working on Windows - and  I do not know why I210 can full works fine on Linux, but Windows can sent but can not receive more than 126 bytes ethernet frame in this case.

Thank you.

Labels (1)
0 Kudos
1 Reply

Hello liujia3,

Thank you for posting in Intel Ethernet Communities. 

I have reviewed your case 05178450, it is still open and you can still provide an update to your local support Technical team. Kindly continue coordinating with them for further assistance. And to avoid duplicate request, I need to close this thread.

If you you need assistance again in the future, please post a new question or log a new case.

Thank you.

Best regards,

Michael L.

Intel® Customer Support Technician

0 Kudos