Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DRay1
Beginner
1,925 Views

I210 Network Teaming SFT Failover 12 Second Delay

Teaming failover takes ~12 seconds using I210 adapters on Windows 10. Teaming failover with previous system configurations occurred under 1 second. The Wireshark capture is attached showing the data transfer from PC2 (192.168.28.72) to PC1 (192.168.28.71). The failover was induced after packet 368. Transfer resumes at packet 392 after ~12.6 seconds. Is it possible to reduce the failover time?

System Specs: ANS 22.10 driver, SFT teamed I210 adapters with default power management and default advanced settings, Windows 10.1.0 Enterprise Build 1607

0 Kudos
12 Replies
idata
Community Manager
174 Views

Hi David_ray,

 

 

Thank you for posting in Wired Communities. The failover probe is disabled by default, you may refer to this website for reference:

 

https://www.intel.com/content/www/us/en/support/articles/000007536/network-and-i-o/ethernet-products...

 

 

Please try go the the Setting of the Team property ->Advance , change the available Setting:

 

Activation Delay

 

Allow Failback-please enable this option

 

Check time

 

Connection Monitor

 

 

 

Feel free to update me. Thanks.

 

 

Regards,

 

Sharon

 

DRay1
Beginner
174 Views

Hello Sharon,

Thank you for your response. I made the changes listed below to the PC1 and PC2 teamed adapters.

 

Check Time – 1

 

Connection Monitor Interval – 2

 

Activation Delay – 5

 

Connection Monitoring – Disabled

 

Allow Failback – Enabled

 

The failback to the primary adapter worked, but had no effect on the 12 second delay when failover occurred. Next, I set up connection monitoring against a third computer, PC3. This had no effect on the failover delay.

 

Respectfully,

David

idata
Community Manager
174 Views

Hi David_Ray,

 

 

Thank you for the update. Can you adjust the "Activation Delay" to a smaller value see if this will make any difference?

 

 

Thanks,

 

Sharon T

 

DRay1
Beginner
174 Views

Sharon,

The Activation Delay was reduced from 5 to 1. The failover delay remains at 12 seconds.

Respectfully,

David

idata
Community Manager
174 Views

 

Hi David_Ray,

 

 

Thank you for the updates. Is your I210 standalone network adapters or onboard NIC embedded on the system?

 

 

Regards,

 

Sharon T
DRay1
Beginner
174 Views

Sharon,

The adapters are embedded on a VECOW ECS-7700-GD motherboard.

Respectfully,

David

idata
Community Manager
174 Views

Hi David_Ray,

 

 

Thank you for the information. Just to double check as mentioned "the previous system configurations occurred under 1 second.", are you referring using this same system VECO ECS-7700-GB but different OS? OR using another different system with different network adapter?

 

 

Have you check with the system vendor Vecow regarding this?

 

 

Feel free to update me.

 

 

Thanks,

 

Sharon T
DRay1
Beginner
174 Views

Hi Sharon,

I need to correct my previous post. The adapter isn't embedded. The two I210 adapters are on a Vecow LMX-200 Mini PCIe card.

The current system specs with the 12-second delay are ANS 22.10 driver, SFT teamed I210 adapters with default power management and default advanced settings, discrete dual I210 Vecow LMX-200 Mini PCIe card, Windows 10.1.0 Enterprise Build 1607.

The previous system configuration has a 360-millisecond delay during teaming failover. Its specs are Intel Network Connections 19.3.14.1.0 driver, embedded Intel 82583V network adapters SFT teamed with default power management and default advanced settings on Vecow ECS-7710-610Q-RMS motherboard, Windows 7 SP1.

I haven't checked with Vecow, but I will today. Thank you for your assistance.

Respectfully,

David

idata
Community Manager
174 Views

HI David_Ray,

 

 

Thank you for the clarification. Since this is an OEM network card, please contact Vecow to further check the best driver to use or any other setting to configure. Hope to hear good news from you.

 

 

Regards,

 

 

Sharon T
idata
Community Manager
174 Views

Hi David_Ray,

 

 

Please feel free to update me if further assistance needed.

 

 

Thanks,

 

Sharon T
DRay1
Beginner
174 Views

It's been a few months since my last post. We've been waiting on hardware to try and further isolate the issue.

Since the last post, the teaming failover delay was reported to Vecow. Vecow performed their own teaming failover test using their dual I210 LMX-200 Mini PCIe card and experienced 3 to 5 second delays compared to our 12 second delays. One difference between the two tests was Vecow used pings. Whereas, we used 1.5 MB transfers. Vecow was unable to provide a solution to the problem.

Next, the Vecow I210 LMX-200s were replaced with Jetway dual I350 JADMPEIDLB Mini PCIe cards. Our teaming failover test resulted in ~750 millisecond delays. Unfortunately, the JADMPEIDLB is not available in extended temperature. It also had problems interfacing with a device in our system that is known to only act nice with certain network adapter models. Although the Jetway adapter failover delay is acceptable, it isn't a good candidate.

For the next hardware change, we replaced the Vecow I210 LMX-200s with Innodisk dual I210 EMPL-G202-W1 Mini PCIe cards. Our teaming failover test resulted in 12 second delays, similar to the Vecow I210s.

In summary, on the same system, changing only the Ethernet adapters, the I350 based adapter model had a 750 millisecond delay compared to the 12 second delay of the two I210 based adapter models.

Respectfully,

David

idata
Community Manager
174 Views

Hi David_Ray,

 

 

Thank you for sharing the information, please continue to work with Vecows and hopefully there will be good news. If Vecows system permits, you may try to use Intel retail network adapter to test but make sure you have to check with Vecows first for any compatibility before you venture into this.

 

https://www.intel.com/content/www/us/en/support/articles/000005612/network-and-i-o/ethernet-products...

 

 

It is best to work with Vecows still for the components installed and running on their system. Thank you for sharing the information.

 

 

Regards,

 

Sharon T
Reply