Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4867 Discussions

I210-T1: Wake on LAN not available

flobernd
Novice
2,681 Views

Hi there,

 

my mainboard (ASUS Pro WS W790E-SAGE SE) has an Intel X710 10G network adapter which does not support WoL.

For this reason I bought a I210-T1 PCIe card.

 

Sadly, I can't manage to get WoL working. Windows 11 dialog screenshot attached. The WoL option is greyed out no matter what I try.

 

Intel SSU shows this for the mainboard:

- Power Management Capabilities Not Available
- Power Management Supported Not Available

 

and this for the network adapter:

- Power Management (Low Power) Active: Yes, Enable: Yes
- Power Management (Wake On LAN) Not Available
- Power Management (Wake on Magic Packet) Not Available
- Power Management Capabilities Not Available
- Power Management Supported No

 

The question is why!? According to the product information, this I210-T1 card supports WoL.

 

In BIOS I found 2 settings "APM -> Allow wake by PICe" and "I210 -> Wake on LAN" which I both turned on.

9 Replies
B_Y
Employee
2,642 Views

Hello Florian,


Thank you for posting in Intel Ethernet Communities. We have received your request under case #05822013.

Here are a few troubleshooting steps you can work on:

1) You may need to disable the onboard Intel X710 from device manager for the mainboard to use full functionality of I210-T1 PCIe card. Once disable, verify again the settings in Bios.


2) What state of system you wish to wake from (S3, S4, S5)?

S3: Hybrid sleep, used on desktops, is where a system uses a hibernation file with S1-S3. The hibernation file saves the system state in case the system loses power while in sleep.

Note: SoC systems that support Modern Standby don't use S1-S3.

S4: Fast startup is where the user is logged off before the hibernation file is created. This allows for a smaller hibernation file, more appropriate for systems with less storage capabilities.

S5: The system appears to be off. This state is comprised of a full shutdown and boot cycle.


3) Please consider to update your mainboard bios to the latest, and as well the Intel I210-T1. Intel I210-T1's latest driver from this link: 

https://www.intel.com/content/www/us/en/download/727998/intel-network-adapter-driver-for-microsoft-windows-11.html


4) So, you may need to disable fast startup and try again.

Steps:

Select Start > Go to Control Panel > Hardware and Sound > Power Option > select "Choose what the power buttons do"

At the bottom of the window is a Shutdown settings section. In this section, there is an option labeled Turn on fast startup. Turn off fast startup, deselect the box.

If the option is grayed out, scroll up and click Change settings that are currently unavailable. You may be prompted to confirm your choice by a User Account Control (UAC) pop-up window -> click Yes. You should now be able to adjust this setting.

This FAQ explain the steps with some example: https://www.asus.com/support/FAQ/1045950/


Should you need any further information, please do not hesitate to replay this thread.


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
flobernd
Novice
2,635 Views

Hi @B_Y,

 

thanks for your answer. Unfortunately these steps do not help me.

 

1) This is not an option as I'm primarily using the X710 for networking. I bought the I210-T1 especially (and exclusively) for WoL.

2) Wake up from S3 and S4 is the desired usecase. My system does not use the Modern Standby:


C:\Users\Florian>powercfg a
The following sleep states are available on this system:
Standby (S3)
Hibernate
Hybrid Sleep
Fast Startup

The following sleep states are not available on this system:
Standby (S1)
The system firmware does not support this standby state.

Standby (S2)
The system firmware does not support this standby state.

Standby (S0 Low Power Idle)
The system firmware does not support this standby state.


3) BIOS and I210 network driver is on the latest available version already.

4) This has been tested, but the option remains  greyed out after a reboot. As I'm not aiming to wake up from S5, I don't think this is relevant anyways.

 

Do you have other ideas?

0 Kudos
B_Y
Employee
2,610 Views

Hello Florian,


Thank you for the information. We understood that you need the networking for Intel X710 and I210-T1 PCIe card for WOL.

1. Do you see the difference if a LAN or RJ-45 cable connected to I210-T1? At least do you have network connectivity?

2. We believe, I210-T1 PCIe would need WoL connector cable that connects it to the motherboard. Was the connection secured? May I suggest to you to consider to reach out Asus tech support to verify all the configuration with motherboard is good? The Wake-on-LAN (WoL) functionality dependent on the motherboard.

3. Does your system have or you are using elevated permission such as administrator to ensure you are able to make changes on power management and others?

- From power options, were the "Turn on fast startup (recommended)" is not ticked?

- Did you Turn Off Link State Power Management ? Following article for your reference: https://thegeekpage.com/wake-on-lan-not-working/

4. Please share the PBA of the adapter. You may refer to the link below on where to find the PBA number. Providing photos of the adapter focusing on the markings (white sticker) found on the physical card will be highly appreciated for us to double check on it. The PBA consists 6-3 digit number located at the last part of the serial number. This would help us identify if you are using an Original Equipment Manufacturer(OEM) or retail version of Intel Ethernet Adapter.

Identify Your Intel® Network Adapter Model Using PBA Number

https://www.intel.com/content/www/us/en/support/articles/000007022/network-and-i-o/ethernet-products.html


Awaiting to your reply. 


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
flobernd
Novice
2,499 Views

Anything else I can try?

0 Kudos
flobernd
Novice
2,588 Views

1. Yes, I have network connectivity on the l210-T1

2. BIOS settings are good, more about this later...

3. Yes (I have admin privileges, Fast Startup is disabled and Link State Power Management is Off)

4. For this I have to remove the card. Will do when I have time to open the workstation again

---

I made an interesting observation:

After putting the system in Hibernation (S4) mode, I noticed that the LED on the l210-T1 turned off (which is not good, but I don't understand why).

I unplugged the power cable and replugged it.

Suddenly the LED on the NIC started blinking...

... and after sending another magic packet, the PC actually turned on!!!

This tells me WoL seems to work in general, but Windows seems to power off the NIC when entering S3 or S4 state. Any ideas here?

0 Kudos
flobernd
Novice
2,584 Views

Wow, it even works when I completely shut down the computer (S5). I guess the mainboard takes control over the power management in this case and keeps the NIC enabled.

Could it be that the Intel driver does not correctly report some capabilities to Windows? I think "Allow this device to wake the computer" is greyed out, because the Intel driver does not report this capability to Windows. And Windows shuts down the PCIe card when entering S3/S4 because this option is not checked.

What can we do here?

0 Kudos
B_Y
Employee
2,421 Views

Hello Florian,


My apologies on delay. From some investigation as following:

APM is enabled in the BIOS - "APM -> Allow wake by PICe"


We think we missed out ACPI.


APM (Advanced Power Management) works via BIOS and adapter firmware (not the software driver), and works from S5 (power off). This explains why WoL works from S5 (computer shut down).


In order for WoL to work from S3/S4, the motherboard needs to support and enable ACPI (Advanced Configuration and Power Interface). ACPI interfaces with the software driver WoL settings. In addition, all other ACPI compliant devices in the system must have ACPI compliant drivers installed. If one ACPI device doesn't have an ACPI compliant driver, it affects the other ACPI devices (like the I210 adapter). For example, we have seen when the video driver is not ACPI compliant it can cause the I210 driver WoL settings to be grayed out. This is a Microsoft OS limitation.


So, the two things need your help to check are:


ACPI supported by the motherboard and enabled in BIOS

All other ACPI devices in the system have ACPI compliant drivers installed


Hope this help.


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
B_Y
Employee
2,380 Views

Hello Florian,


I hope this message finds you well. I am just sending a follow up if you have any questions from the previous post. If so, please let us know. Thank you.


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
B_Y
Employee
2,326 Views

Hi @flobernd ,

 

Please be informed that we will now close this request since we haven't received any response from our previous follow ups. Just feel free to post a new question if you may have any other inquiry in the future as this thread will no longer be monitored.

 

Best regards,

BY_Intel

Intel Customer Support

0 Kudos
Reply