Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4525 Discussions

I219-V driver installation: a nightmare for everybody


Hey there,

I just want to share my experience with the drivers for the I219-V chip. To make this work I just wasted serval hours and I'm really angry about it.

I build up my new system (i5 7600k, ASUS Z270 board and ASUS PCE-AC55BT) and installed win 10 on my ssd. After the first start I installed the chipset drivers and wanted to continue with the driver for the I219-V. An easy task I thought ... but I got the message that the installation failed because there is no intel network connecter in my PC. What the hell? The installation menu just told me that the drivers for the I219-V will be installed.

In the device manager I found an unknown device. I tried the windows function to install this device. As a result I got another error message. Windows told me that there was an error by installing the drivers for the I219-V. Great to know that the chip does exist despite the intel driver telling me something else.

So I googled "i219-v problem". Next to several threads I found this one where the starter had the same problem:

And luckily there was a genius guy with a solution: "First boot into your BIOS setting, go to boot, CSM, and set ignore with boot from network option."

Despite the fact that I would never figured that out, I was happy because for the starter of the thread that worked. But unfortunately I did not work for me. I was so frustrated and so I had to keep on trying.

So since windows automatically installed the drivers for the WIFI card, I gave it a try and removed the card from the pc. Still the installation failed. My last hope was to delete the intel ac7260 in the device manager and hell yeah after this step it finally it worked. But common this was a nightmare and nobody should deal which such problems.

I'm so disappointed. Installing this driver is a thing everybody has to do and so I cannot understand that this problem exists.

0 Kudos
2 Replies

I have a Z270 MoBo too, however built by MSI, with the I219-V NIC chipset, and I too got a wireless PCIe card built by Gigabyte, however with an AC 8260. I had zero issues during setup or utilization for the past month or so, with any drivers, until I updated the Intel ME drivers (which has absolutely nothing to do with network), and this new driver broke the ANS feature of the NIC. Was I not using VLANs, I would not even notice the problem.

I usually download all drivers for my system and save them anywhere I can have access to, then install the chipset, RST storage, wired Ethernet, wireless Ethernet, Bluetooth, onboard graphics, discrete graphics, audio drivers, then a round or two (or three) of Windows Updates, to finally start with the programs. So far, never had any troubles using this order.

I would report your findings back to Asus, even if only as a link to this topic. However after almost 20 years of using Asus products, I can tell their product quality dropped significantly (from MoBos to VGAs and laptops, to name a few). I would still purchase from them, but not as my first or second choices.

0 Kudos

Hi Patrick171,



Thank you sharing your experience and good to know eventually it works.







0 Kudos