Ethernet Products
Intel® Ethernet products and technologies
3880 Discussions

I225-v and ROG STRIX B550-I GAMING. Speed issue

Tom555
Beginner
825 Views

Hello.

I have ROG STRIX B550-I GAMING and integrated network card is not working at 1 Gbps speed.

 

Speed test and SSU data in attach.

0 Kudos
7 Replies
Mike_Intel
Moderator
803 Views

Hello Tom555,


Thank you for posting in Intel Ethernet Communities. 


I am really sorry to hear that. We have a link that may help you with the issue. Please open this link below:


https://www.intel.com/content/www/us/en/support/articles/000057261/ethernet-products/gigabit-etherne...


For the NVM file and how to update the NVM, please coordinate with your board manufacturer because they have their own NVM file and steps on how to update the NVM.


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support Technician


Tom555
Beginner
763 Views
Mike_Intel
Moderator
752 Views

Hello Tom555,


Thank you for the quick update. Just to clarify, can you tell us the steps that you tried for me to document.

And also, have you tried discussing the issue with the board manufacturer since the network card is embedded?


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support Technician


ddulude95
Beginner
747 Views

Michael,

 

Are you or anyone else from Intel able to give the latest status updates from Intel Engineering about this specific NIC? The latest driver version released, which is 1.0.2.8 is majorly unstable, and the current "fix" is to rollback to 1.0.1.4

 

Will there be a new driver version coming out to address these issues, so that way we don't have to mess around with an unstable NVM firmware update script and rolling back to 1.0.1.4?

 

Thanks

Mike_Intel
Moderator
690 Views

Hello Tom555,


Hope this message finds you well. I am just making a follow up on the information that we requested and also, have you tried checking the issue with the manufacturer of the board?


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days.


Thank you


Hello ddulude95,


Regarding your concern, please create a new post for us to assist you regarding your inquiry.


Thank you


Best regards,

Michael L.

Intel® Customer Support Technician


Tom555
Beginner
679 Views

 

 

I got a response from Asus. They ask to take the MB to the service center for checking.

I found a lot of information on the net about similar problems. 

Eg: 

https://www.reddit.com/r/intel/comments/lqb4km/for_people_having_i225v_connection_issues/

https://www.reddit.com/r/ASUS/comments/kppyoi/psa_asus_motherboards_with_intel_i225v_25gb_nic/

 

Mike_Intel
Moderator
656 Views

Hello Tom555,


Thank you so much for the update and I am glad that the you are now talking to the manufacturer of the board.

Since you are now talking to them, we will close this thread.


If you need further assistance, please post a new question. 


Thank you and stay safe.


Best regards,

Michael L.

Intel® Customer Support Technician


Reply