Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
4736 Discussions

Intel 82578DM Windows 10 latency


I have a machine on Windows 10 that according to device manager is using the Intel(R) 82578DM Gigabit Network Connection.

The problem I have is that according to LatencyMon the ndis.sys and tcpip.sys drives are showing extremely large amounts of latency. This means everytime I refresh a web page my machine locks up for a split second and any audio or video currently playing stutters really heavily.

I've tried updating the drivers to no avail. At present device manager is showing the driver version as provided by Microsoft.

I've tried downloading some drivers from the Intel website but those get to the "Copying drivers" stage and then fails stating that there were no Intel adapters found. This has confused me a lttile since device manager lists it as an Intel adapter.

Would massively appreciate it if someone could assist in resolving this issue.


0 Kudos
3 Replies
New Contributor III

Hi Jibber4568,

Thank you for the post. Checking on our download driver site, there is no Wind 10 driver for 82578DM Downloads for Intel® 82578DM Gigabit Ethernet PHY.

Since this is an onboard NIC, I would recommend you to contact the board vendor for customized drivers.



0 Kudos

I am experiencing a similar problem with the Intel drivers posted at Download Intel® Network Adapter Driver for Windows Server 2012*

I would like to update the current Windows Server 2012 drivers for the Intel 82578DM-based Ethernet NIC in my server. The Server 2012 drivers available at the link above claim support for the 82578DM; however, attempts to install these drivers result in the message "Copying driver files" followed by "No Intel(R) Adapter."

I am certain that I have an 82578DM-based NIC in my Server which is running Windows Server 2012 (Driver Version dated 3/28/13).

Any help or assistance that you can offer would be appreciated. Thank you.

0 Kudos

I was able to get the latest Server 2012 drivers to work after realizing my mistake - I'm running Server 2012 R2, not Server 2012. It turns out that the .inf file in the latest Intel driver does not have the section for Server 2012 R2. I added the [Intel.NTamd64.6.3.1] section to the e1k63x64.inf file and manually installed the driver (from the Server 2012 R2 Device Manager). New advanced features / diagnostics are now fully functional.

0 Kudos