Ethernet Products
Intel® Ethernet products and technologies
4024 Discussions

Intel Gigabit CT Desktop Adapter slows down system

Community Manager


I just bought an Intel Gigabit CT Desktop Adapter (PCIe) because I wanted more performance than my onboard Realtek chip offers.

First of all my hardware specs:

  • AMD A6-3650 APU on a Gigabyte A75-D3H mainboard
  • 8 GB DDR3 Ram
  • OCZ Vertex 2 SSD (128 GB)
  • Windows 8 Pro (64 bit)

Of course all my drivers are up to date.

My problem:

When I start a file transfer from my NAS to the SSD (or one of my HDDs), the system instantly slows down. The image constantly freezes for a second or so. The mouse curser stutters while moving on the screen.

I think it has to do with "Interrupt Moderation", which was activated and set to "adaptive" by default. Changing these settings made the problem worse. I tried all available settings without getting rid of the problem and never exeeding 80 MB/s (much less most of the time).

With my onboard Realtek NIC I only experience this problem if I disable "Interrupt Moderation". When it's enabled it works well (except for the fact that I only get a maximum of about 80 MB/s throughput).

My NAS is obviously fast enough, because using the same cables and switches I get about 105 MB/s on my Lenovo Thinkpad with the onboard "Intel 82579LM" adapter. (also on Windows 8 Pro)

Last thing I tried was to set the Windows energy settings to "High Power" (don't know the exact translation for the english Windows version), which didn't help either.

I tried these driver versions for the Intel CT Desktop Adapter:

  • (via Windows Update)
  • (latest driver from Intel Download Center)

What can I try to solve or at least find the cause of this problem?

Thanks a lot in advane,


0 Kudos
6 Replies
Community Manager


this is what I tested so far:

  • Same hardware: booted into Ubuntu Live System (USB Flash Drive). Mounted NAS. "pv /nas/file > /dev/null" also gets me 105 MB/s. Same result with a ramdisk. No problems at all.
  • Took the NIC and put it into an older computer running Windows 7: Works perfectly. 105 MB/s

So that obviously leaves these conclusions:

  • The NIC is not defective.
  • The hardware of the system (running Win8) is not defective.
  • The problem must be a software issue.

I guess I'll have to test the NIC with a clean install of Win8 and/or with a clean install of Win7.

Community Manager

Today I tried enabling "Jumbo Frames". I enabled a frame size of 9014 bytes both in the settings of the Intel NIC and the network interface of my NAS.

The problem of lag is gone. But at the same time the speed isn't really what I was looking for. And it's not really constant:

This is what it looks like on my notebook using the exact same setup (cables, switches, NAS):

Community Manager

Next test: Ramdisk

Ok, obviously my OCZ SSD performs much worse than my Samsung 830 SSD in the notebook. So I tried using a ramdisk to check the network throughput.

Ramdisk, jumbo frames disabled: heavy lags...frozen screen for seconds, slow througput:

Ramdisk, jumbo frames enabled (9014 bytes): no lag, perfect speed:

So, I guess this is a solution I can live with. But in the end I still don't understand why the NIC works perfectly with Windows 7 on another machine and with Ubuntu on the same machine but causes so much trouble on Windows 8.


Hi Manu,

Thank you for taking the time to run these tests and sharing your results. We are close to releasing an updated driver for your adapter. If everything goes well, I should get an updated Intel® Ethernet Connections CD posted by next week at If you click on the link before the file is posted you will get a page not found message. I plan to come back here and post something when the link is live, but I wanted to include the link in case I don't get this thread updated right away.

I don't know if the updated driver will help with your issue or not. Let me know if the new driver helps or not. If not, I will look into the issue in more detail.

Mark H

Message was edited by: Mark H @ Intel&# 13; The CD link in this message with the new software and drivers is now live.

Community Manager

Thank you very much for your answer. I really appreciate it.

Of course I will come back here and report any new results.

Community Manager


I just installed the latest driver ( and the lags seem to be gone.

But there still seems to be a big difference between jumbo frames on/off. Basically I get the same results as seen in the latest images I posted, just without lags.

So, for me it's ok, because I have no problem using jumbo frames.

Thanks a lot.