Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
949 Views

Intel I210-T1 driver issue

Hi,

i am an IT student at a german university. Currently i am working on my bachelor´s thesis about the PTP protocol. For this reason i got a Intel network adapter I210-T1, which has support for the IEEE 1588 (=PTP) protocol.

On Linux Ubuntu works everything pretty fine. The card is working as expected. The first time i wanted to use it on Windows, my system frezzed. And still after rebooting the OS, the network card can not be used.

First of all my HW specifications:

- MB: Asus P7H55-M Pro

- CPU: Intel Core I5 650 @ 3.20GHz

- RAM: 16.0GB DDR3

- Graphic: Intel HD Graphics

- Storage: 223GB OCZ-VERTEX3 (SSD)

The SW specifications for Linux (everything is fine here):

- OS: Ubuntu 16.04 LTS

- Driver: igb-5.3.5.4

- Other: linuxptp package

And for Windows (with the issue):

- OS: Windows 7 Pro 64-bit SP1

- Driver: Intel Network Adapter Driver for Windows 7 (Version 21.1, 64-bit)

Problem:

The main problem in Windows is located in the device manager. Here it says on my adapter, that the error code 31 appeared. See the attachment. This means, that i absolutely can not use the card. The first time after installing the card, Windows tried to search and install the driver by itself. Then, as i said, the whole system frezzed. I had to power it off with the switch. After rebooting Windows, it said, that it was not able to install the driver. I tried to do that manually with the driver of the support website, but with no success. Only the error code 31 appears.

What i already have done:

- Let Windows try to install the driver by itself -> No success

- Install driver manually -> No success

- Make sure Windows Update is up to date -> No success

- Reinstall and/or update the asus driver for the motherboard (also the chipset driver etc...) -> No success

- Update BIOS to newest version -> No success

- Testing the card on an other pc -> Success

- Testing the card under Ubuntu -> Success

- Tried to execute this solution -> http://www.tomshardware.co.uk/answers/id-1750879/code-error-network-adapter.html http://www.tomshardware.co.uk/answers/id-1750879/code-error-network-adapter.htm -> No success

I know that there is always the possible solution for a reinstall of Windows, but this current installed OS is actually only a month old, so pretty new. What else can i do besides this?

Thank you,

doritsep

Update

Found an old post of another forum with the exact same problem, but with no solution. -> https://forums.freenas.org/index.php?threads/i210-driver-installation-freezes-windows-7-x64.21589/ i210 driver installation freezes Windows 7 x64 | FreeNAS Community

Tags (1)
0 Kudos
4 Replies
Highlighted
Community Manager
13 Views

Hi doritsep,

 

 

Thank you for posting your query in Wired Ethernet Communities.

 

 

Please try the following steps to resolve your error code 31 error.

 

 

1. Uninstall the driver from device manager, please check delete the driver software for this device.

 

2. Go to control panel, uninstall Intel Proset software

 

3. Go to registry and backup your settings prior to proceeding steps to remove network adapter-related registry mentioned in the site below.

 

http://www.intel.com/content/www/us/en/support/network-and-i-o/ethernet-products/000005781.html

 

4. Reinstall drivers and check if issue still persist

 

 

regards,

 

Vince
0 Kudos
Highlighted
Community Manager
13 Views

Hi doritsep,

 

 

We'd like to check if you still need assistance regarding I210-T1.

 

 

regards,

 

Vince
0 Kudos
Highlighted
Community Manager
13 Views

Sorry for not answering.

I think i figured out the problem. The I210 needs a PCIe 2.1 slot, but my motherboard only provides 2.0.

For the moment i continued to work under Ubuntu where everythink works fine. For working with Windows i will buy a new motherboard with a PCIe 2.1 slot.

Thanks for your help.

0 Kudos
Highlighted
Community Manager
13 Views

I also tried what you said at "Nov 16, 2016 5:02 PM"´, but most of the registry keys weren´t present. So this did not work. As i said, i think it is the PCIe combatibility.

0 Kudos