Ethernet Products
Intel® Ethernet products and technologies
4161 Discussions

Intel I211 Gigabit Network Connection driver v13.0.9.0 - large files copy problem

Truphane
Beginner
2,784 Views

[Windows 10 Pro x64 / Ryzen 3900X CPU / Synology NAS connected at 1GB/s]

After using Intel I211 Gigabit Network Connection driver v12.18.12.1 for more than a year, I updated to v13.0.9.0.  I immediately began having problems with large file backups from PC to NAS.  Reverting to v12.18.12.1 fixed that.  A week later I tried v13 again which brought the same problems.  Reverting to v12 again fixed it.

So Intel I211 Gigabit Network Connection driver v13.0.9.0 has a problem, at least on my system.  For such archiving I use the excellent "Bvckup2" app which is crafted to make maximum use of resources and may stress driver operation more than Intel tests for.   Again - the earlier driver and those before it always worked fine.

0 Kudos
14 Replies
Mike_Intel
Moderator
2,764 Views

Hello Truphane,


Thank you for posting in Intel Ethernet Communities. 


For us to further check the issue, please provide the following details.


  1. Are you using an onboard/embedded I211 network card?
  2. Can you provide the brand and model of you board or system?
  3. Please provide the download link of the version v12.18.12.1
  4. Please provide the download link of the version v13.0.9.0
  5. Do you have a screenshot of the issue? if you do, please send it us.


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support


Mike_Intel
Moderator
2,752 Views

Hello Truphane,

 

I hope you're having a wonderful day. I am just making a follow up on the information that we requested for us to further check the issue that you reported.

 

If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.

 

Best regards,

Michael L.

Intel® Customer Support


Truphane
Beginner
2,735 Views

Thank you Michael.

My network hardware is embedded in an MSI "Creation" AMD x570 motherboard.

I don't have the download links for the Intel drivers I mentioned because I use Driver Easy (website drivereasy.com) to check and update them.  They _might_ get a bogus link but I know for a fact that they work hard to find the proper ones.  You can ask them; their support is excellent and they'll certainly work with you.

I should be more clear about the situation.  The job that works with I211 driver v12 but fails with v13 is a large transfer from my Synology NAS to an external hard drive attached to a USB3 port on that Synology box.  This was being done by Bvckup2 running on the PC.  So of course all that data had to go over the network into and out of the PC - the Synology was not transferring directly to the external drive even though it might look like that.  I attach a screenshot of Bvckup2 simply hung at 28%, which was repeatable.

Truphane
Beginner
2,734 Views

Another detail (can't edit posts here...):   from the screenshot Bvckup2 appears to have hung while writing one of its snapshots to an SSD in my PC.   But I'm sure there was no problem writing to that drive; these snapshots are ~32MB files and there are many gigs of free space on that SSD which incidentally works fine every day.  And again driver v12 works fine.   I think the hang with driver v13 was because the network had stopped and Bvckup2 was waiting on more snapshot data to write;  those snapshots are of the target USB external drive attached to the NAS.

Thanks

Mike_Intel
Moderator
2,724 Views

Hello Truphane,

 

Thank you so much for a very detailed update. Before we proceed, let me also ask if you already tried to raise this issue to MSI since the network card is onboard. They may have a custom driver and firmware on their website to address this issue and they are the one who can advise if the OS is validated.


I am checking the support site of your board and they have available drivers:


https://www.msi.com/Motherboard/PRESTIGE-X570-CREATION/support#down-driver&Win10%2064

 

If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.

 

Best regards,

Michael L.

Intel® Customer Support


Mike_Intel
Moderator
2,695 Views

Hello Truphane,

 

How are you today? I am just making a follow up regarding my question in my previous post if you have tried contacting MSI. Please send us a reply so that we can also start checking the issue further.

 

If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.

 

Best regards,

Michael L.

Intel® Customer Support


Truphane
Beginner
2,682 Views

I did go to the MSI site and downloaded the drivers from there but am not sure that I should trust them beyond what Driver Easy found.  Over the years we hear contradictory things about eg. mobo vendor drivers.  Theoretically they'd be best, but they may not be kept up-to-date.

If you think they are definitely a better choice then I will have to change my mind on that.

In that case I may install the MSI LAN drivers and repeat my test, this coming Saturday.  Can't promise that (what I have now works) but in the interest of knowledge.

Mike_Intel
Moderator
2,674 Views

Hello Truphane,

 

Appreciate the update and I understand your concern about the drivers being not updated. However, there is an explanation to that. Board manufacturer purchase the network chip to us and embed the chip to their board. When they do that, they can alter the chip because the board's BIOS is now controlling the chip and uses the resources of the system. So every time we release a generic driver, they may need to release a customer version of the driver that will work on the card and board. And the changes that they may have made is unknown to us, that is base on the design. Having said that, I will wait if the driver's from the board manufacturer will work or not and then we will further check the issue from there.

 

If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.

 

Best regards,

Michael L.

Intel® Customer Support


ricecrispy1984
Beginner
2,644 Views

hi truphane can you post a link for the 13.0.9.0 driver as i cant seem to find it anywhere???

 

or if anyone else has a link to the i211 ethernet driver v13.0.9.0 that would me appreciated 

 

im looking for windows 10 x64 version

 

thanks

Truphane
Beginner
2,640 Views

To Ricecrispy:    I didn't find the v13.0.9.0 driver myself.  It was found and offered by the Driver Easy utility I use.  Same story for the earlier v12 driver that DE had installed.   Based on my experience you should avoid v13 even if you do find it.

 

That said, this is the first time DE has offered a driver that caused any problems, in two years of use.  But it is a lesson that "updating" drivers just to have the latest may not make sense either.

AlHill
Super User
2,636 Views

Please do yourself a favor and NOT use 3rd party driver sites like driver easy. You never know what information from your machine they are uploading (and to what country it is going), and you never know what payload is in the packages they are downloading.

Doc (not an Intel employee or contractor)
[Waiting for Windows 12]

Truphane
Beginner
2,633 Views

Al Hill:  That's a reasonable point.  Of course MSI could be capturing all the same info via their drivers.  Hard to judge the risks; but I'll consider what you said.

Mike_Intel
Moderator
2,627 Views

Hello Truphane,

 

I have to agree, please get your drivers from a reputable source or manufacturer of your hardware to avoid some issues. I am just checking you are now going to contact the manufacturer of the board for further assistance.

 

If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.

 

Best regards,

Michael L.

Intel® Customer Support


Mike_Intel
Moderator
2,562 Views

Hello Truphane,

 

I hope you're having a wonderful day. I am just sending another follow up to check if you still have clarifications and hoping that you are now talking to MSI regarding the issue.

Since we have not heard back from you, I need to close this inquiry. If you need any additional information, please submit a new question as this thread will no longer be monitored.


Thank you and stay safe.

 

Best regards,

Michael L.

Intel® Customer Support


Reply