Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
4365 Discussions

Intel I218-V - slow transfers FROM gigabit capable devices


I have a desktop (1) PC with a Asus z97 Pro (wifi ac) motherboard and Intel I218-V NIC running Windows 8.1 Pro. I've been using it over Wifi, but recently ran a cable to it to get better transfer to/from my gigabit-capable Synology ds213j NAS. The transfers from NAS for some reason averaged 150 KB/s, but transfers to NAS are reasonable 70 MB/s. After troubleshooting I've identified that issue appears only in transfers FROM gigabit capable devices. Would be nice if anyone could help identify the reason and solve it.

Just updated to Intel PROSet driver version, but that didn't help. The link status was set to auto negotiation and speed was 1 Gbps/Full Duplex. Pinging any of the devices had minimal 1-5 ms latency.

Below I summary of troubleshooting with various connected devices to identify the problem and everything seems to point to I218-V adapter. I sent this information to Asus already about 2 months ago, but so far have not gotten back anything more than "yes, it'looks like a driver issue, we are investigating". It's getting annoying, I am considering to return the board and buy another, but I see that most of Z97 based boards are using same NIC. I got this board after returning two Gigabyte GA-Z87X-UD5 TH boards with faulty RAM slots, those boards used Intel I217V adapter and didn't have any transfer speed problems.

When I did troubleshooting I used driver (if I remember correctly, basically latest of 19.x). At that point transfers to desktop (1) averaged out at 5 MB/s instead of 150 KB/s as currently. Not sure when and why it dropped, but it happened before I updated drivers, I haven't had any notable changes in hardware/infrastructure, might be caused somehow by to Windows Update (it didn't install network drivers, but did install Intel Management Engine Interface update). I also have OSX installed on this machine (I know it's not officially supported) and it still receives data at 5 MB/s from NAS.

TROUBLESHOOTING data sent to Asus

For comparison I started up my old desktop (2) PC running Windows 8 Pro on Gigabyte x58A-UD3R motherboard with Realtek RTL8111E 1Gbit NIC to see how it behaves. I tested copying files of size 1.5 GB. It transfers from NAS with ~100 MB/s, but transfers to with 40 MB/s (not sure why so low, but that is not an issue at the moment).

More interestingly desktop (1) transfers to desktop (2) with ~100 MB/s, but transfer from (2) to (1) is terribly slow ~500KB/s (jumping 0-100). It doesn't matter if they are connected via switch or directly with 1m CAT5e cable. Also I saw transfers from (1) to (2) sometimes drop or even start at ~ 20 MB/s, even when connected directly.

Additionally I tested transfers from my Dell n5110 laptop with 100 Mbit NIC and for it both, uploads and downloads, maxed out at 11 MB/s with all devices.

My friend's laptop with gigabit NIC experienced also had slow 500 KB/s (jumping 0-100) transfer to desktop (1), but in all other cases (transfer from (1) or to/from desktop (2)) it was stable at ~100 MB/s.

Summary of devices:

  • Desktop1 - Windows 8.1 Pro on Asus z97 Pro (wifi ac) motherboard with Intel I218-V NIC
  • Desktop2 - Windows 8 Pro on Gigabyte X58A-UD3R motherboard with Realtek
  • NAS - Synology ds213j
  • Laptop - Dell n5110, Windows 8.1, RTL8105E-VB 100 Mbit NIC
  • FriendsLaptop - Dell, Windows 8, Broadcom NetLink Gigabit Ethernet NIC

Below is summary of transfer speeds between devices. In most case they were connected via D-Link DGS-105/E gigabit switch. I also tried direct connections to Desktop1, but that didn't have any positive effect. Desktop1 also has Linux Min 17.1 and OS X 10.10 installed and they had similar issues with transfers. I know they are not officially supported, just pointing out as additional information.

Transfer speeds ( arrow indicates direction )

Desktop1 < NAS = 5 MB/s ( sometimes around

Desktop1 < Desktop2 = 500 KB/s (unstable, jumps 0-1000)

Desktop1 < FriendsLaptop = 500 KB/s (unstable, jumps 0-1000)

Desktop2 < Desktop1 = 100 MB/s (in some cases just 20 MB/s)

Desktop2 < NAS = 100 MB/s

Desktop2 < FriendsLaptop = 100 MB/s

NAS < Desktop1 = 70 MB/s

NAS < Desktop2 = 40 MB/s

NAS < FriendsLaptop = (forgot make a note, but it was high)

Laptop [All devices] = 11 MB/s

FriendsLaptop < Desktop1 = 100 MB/s

FriendsLaptop < Desktop2 = 100 MB/s

FriendsLaptop < NAS = (forgot make a note, but it was high)

Transfer speeds with Desktop1 booted into Linux Mint 17.1 and OS X 10.10

Desktop1_Linux < NAS = 700 KB/s

Desktop1_Linux < Desktop2 = 70 KB/s

Desktop1_OSX < NAS = 5 MB/s

Desktop1_OSX < Desktop2 = 100 KB/s

Desktop2 < Desktop1_Linux = 43 MB/s

Desktop2 < Desktop1_OSX = 40 MB/s

NAS < Desktop1_Linux = 40 MB/s

NAS < Desktop1_OSX = 5 MB/s

This all seems to suggest an issue with the Intel I218-V NIC on Desktop 1 receiving data from gigabit capable devices. The fact that I had similar issues in Linux and OS X points to either a hardware problem or some generic problem within driver in code that is shared among platforms. Can it be a hardware problem?

Here's the list of things I tried in attempt to solve the issue:

  • update to update to latest drivers installed with Intel PROSet software version 19.5.303.0 (version shown in device manager)
  • downgrade to version listed on Asus web site (version shown in device manager)
  • unplugging all Fast Ethernet devices (TV, SetTopBox, Laptop) from network based on some forum suggestion.
  • updated UEFI firmware to latest version 2012
  • Verified that [Adapter Properties\Link Speed] section shows 1 Gbps\Full Duplex link status.
  • Tried to force to "1 Gbps Full Duplex" mode instead of "Auto Negotiation"
  • Ran Cable and Hardware tests via [Adapter Properties\LinkSpeed\Diagnostics]. I used 3 CAT5e cables, one 15m connected desktop 1 to switch, two 1m cables (one at the time) were used to connect switch to desktop 2 or desktops 1 to desktop 2 directly. As you see in posted test results they are contradicting. First it says no problems detected and then reports bad connection and ridiculous distance to problem of 65535 = 2^16 (suggests a default initial value in a program). However, using the 1m cable without any reported issues to directly connect both desktops still produced same transfer results.
  • Tried to change Gigabit Master Slave Mode in Advanced Adapter settings to "Forced Master Mode" instead of auto detect


----------- 1 m cable_1 test

No cable problems detected.

Test details

Polarity : Normal

Local Receiver Status : Passed

Remote Receiver Status : Passed

Cable Offline Test

Poor quality cable detected

Possible causes: Faulty cable, faulty connector, or a speed/duplex mismatch. Verify that the speed/duplex setting on the switch/hub is configured for auto-negotiation.

Test details

Cable Quality

The test detected a bad connection.

Distance to problem: 65535 meters.

----------- 15 m cable test

No cable problems detected.

Test details

Cable Length : 21 Meters

Polarity : Normal

Local Receiver Status : Passed

Remote Receiver Status : Passed

Cable Offline Test

Poor quality cable detected

Possible causes: Faulty cable, faulty connector, or a speed/duplex mismatch. Verify that the spee...

24 Replies

Was a solution ever found for this? I have the exact same issue with the intel i218-v built into my ASUS Maximus VII Formula. ASUS wants me to RMA the motherboard but i highly doubt this will help. I do not want to upgrade to Windows 10 until it is finally released.

New Contributor III

Hi Ry,

You may further check with Asus.




Same issues here with the Asus Z170 Pro Gaming and the Intel I219-V.

I tried all drivers i found and tried all provided settings. In Windows i am getting the same cable error with the 65536 meters message . It's shown as gigabit adapter with 1GB speed, but i end up with 9 MB / sec. Its definately not an hardware issue! If i boot to linux (arch linux x64, latest) i am getting solid 70-80 Mb / sec while beeing in Windows (freshly installed) with the exact same configuration i am getting up to 9 MB/sec. The issue must be driver and / or os related. At the same place with an older Asus-Board i was getting solid >80 Mb /sec, too.

I also buyed a brand new cat-6 cable to be sure that is not the issue, but didnt helped either.


I tried Arch Linux and Ubuntu, both are getting fine speeds, just Windows is the issue.

Btw. That cable 65536 meters message in the diagnostics not always appears.

It seems that it displays 1Gb speed and internally it slows down to 100 Mbit which is very stupid nowadays with large files.


Are there any fixes or beta drivers available yet?

This computer is connected to a fritzbox 3390 which is forced to gigabit, because the other mode is 100 Mbit only.

I also tried to connect it to one of my three gigabit switches TP-Link SG1005D with the same results.

In Linux i am running the 4.3.3 kernel which works like a charm.

I can exclude my hdd speed as well, because my two Samsung 950 PRO NVME driver offer > 2500 mb / sec.


My rig:

Asus Z170 Pro Gaming

Intel I7 6700K

Samsung 950 Pro NVME SSD 2500MB/sec (Archlinux x64_86)

Samsung 950 Pro NVME SSD 2500MB/sec (Windows 10 Pro x64_86)

1X Crucial M4 512GB SSD (data)

1X Crucial M4 256GB SSD (data)

Nvidia Geforce GTX-980, 4GB

Logitech G27 Racing Wheel

Acer XB270H 28" 1920x1080@144Hz

Samsung U28D590D 29" 3840x2160@60Hz

LG W3000H S-IPS 30" 2560x1600@60Hz

Roccat Ryos MK Glow Mechanical Keyboard

Logitech G500s Mouse

ISP 25000/5000


Hey guys I have exact same problem and have a simple fix to get at least 100Mbps. Change the adapter speed/duplex from "auto" to 100Mbps ! If you change to 1Gbps it doesn't fix but 100Mbps does.