Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bobaganusche
Beginner
2,388 Views

Intel I219-V Slow Internet Speeds

I have a system built on an Asus Z390-E motherboard, which is equipped with an Intel I219-V ethernet adapter.  I have 1000/1000 internet speeds, but this ethernet adapter caps me to between 100-400 down and 10-20 up.  I have tried bypassing the router, using the same cable on a different pc which yielded gigabit results, and uninstalling and reinstalling the device.  My network settings show the connection as 1000/1000.

I have also installed a TP-Link Gigabit PCI Express Adapter, and can consistently get gigabit speeds with that.

0 Kudos
5 Replies
Michael_L_Intel2
Moderator
2,363 Views

Hello Bobaganusche,


Thank you for posting in Intel Ethernet Communities. 


For us to further check the issue, please provide the following details.


  1. Is it working before?
  2. Can you provide the link where you downloaded the latest driver?
  3. Are you using on-board I219-V?


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel Customer Support Technicians


Bobaganusche
Beginner
2,357 Views

Hello,

In response to your questions:

1. Yes, it was working when the computer was built, up until about a month ago.

2. I don't know about a link to the latest driver. I update drivers through Asus's Armory Crate when they are available.  The version that the application says is installed matches the Asus support page for my motherboard.

3. Yes, the I219-V port is the on-board ethernet port for my Asus Z390-E motherboard.  I was using that port until it gave me the slow connection speeds, but have since installed a temporary TP-Link PCIe gigabit ethernet card in order to maintain my connection speeds.

Michael_L_Intel2
Moderator
2,350 Views

Hello Bobaganusche,


Thank you for the quick reply.


You may try our generic driver below, just choose your OS and download the driver.


https://downloadcenter.intel.com/product/82186/Intel-Ethernet-Connection-I219-V


If still the same, I suggest that you contact Asus for further troubleshooting since the card is embedded on the board. It may require to change BIOS settings or update from them. They are the best person who can further assist you with this issue.


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel Customer Support Technicians


Michael_L_Intel2
Moderator
2,326 Views

Hello Bobaganusche,


I hope you are having a good day. I just want to check if you tried our driver and also, to check if you are now talking to the manufacturer of the board.


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel Customer Support Technicians


Michael_L_Intel2
Moderator
2,313 Views

Hello Bobaganusche,


I am just sending another follow up to check and hoping that you are already talking to the manufacturer of the board. 


Since we have not heard back from you, I need to close this inquiry. 


If you need further assistance, please post a new question. 


Best regards,

Michael L.

Intel Customer Support Technicians


Reply