Ethernet Products
Intel® Ethernet products and technologies
3882 Discussions

Intel Network Connections/Proset (DxSetup.exe) - Progress stalls at start of install wizard?

Kris78
Novice
1,068 Views

Hi All,

I'm trying to install Intel network drivers (26.0) from the complete ethernet driver download. I'm trying to install them on Windows 10 Pro x64 (OS build 19042.867). The intel adapters are I211 and I217-V.

The wizard launches, asking for admin privileges (which I approve) but after that it just sits there waiting at the welcome screen, with both the Back and Next buttons greyed out and unclickable. If I click Cancel, I do get the prompt asking if I wish to cancel (so the process hasn't actually frozen), but if I approve that, it just continues to sit there and won't even cancel the installation. I have to actually kill the Windows Installer process via task manager to even get out of it.

I have previously (for many years) been running Intel Proset and VLANs+Teams on this same PC without issue, the problem came whilst attempting to update the intel drivers after a windows update (that wiped all the vlans - again - love windows updates....)

I have enabled the built in windows logging for the installer, but it's meaningless information to me. Is there someone at Intel I can pass that to in order to see how to resolve the issue, or has anyone else experience this and found a solution?

Thanks, Kris.

Labels (1)
0 Kudos
9 Replies
Kris78
Novice
1,028 Views

I take it that no one has ever seen this problem before, nor does anyone have any ideas as to what information might be helpful when it comes to diagnosing this problem?

Crisselle_Intel
Moderator
1,022 Views

Hello Kris,


Thank you for posting in Intel Ethernet Communities. 


Please provide the following information that would help in checking your query.


1. Where was the driver downloaded from? Is it from Intel website?

2. What is the current and previous version of your Operating System prior to update ? 

3. Have you tried performing clean driver installation? Refer to link below for Clean Driver Installation Guide for Intel® Ethernet Connections

https://www.intel.com/content/www/us/en/support/articles/000058304/network-and-io/ethernet-products....

4. Model of the motherboard

5. Please provide the System Support Utility log of your system. This will allow us to check your Adapter details and configuration. Kindly refer to the steps from link below. We will send an email for you to attach the logs. Please be reminded not to post the logs on this thread to avoid exposing confidential information.

Help Guide for the Intel® System Support Utility

https://www.intel.com/content/www/us/en/support/articles/000008563/software/software-applications.ht...


Awaiting to hear from you. 


Should there be no response from you, I’ll make sure to reach out after 3 business 


Best regards,

Crisselle C.

Intel® Customer Support


Kris78
Novice
1,018 Views

1. Where was the driver downloaded from? Is it from Intel website?

Yes.

https://downloadcenter.intel.com/downloads/eula/22283/Intel-Ethernet-Adapter-Complete-Driver-Pack?ht...

2. What is the current and previous version of your Operating System prior to update ?

Not sure on the version\build number prior to update, but Win 10 Pro (prob H120 update at a guess). It is now: 
OS Name Microsoft Windows 10 Pro
Version 10.0.19042 Build 19042

3. Have you tried performing clean driver installation? Refer to link below for Clean Driver Installation Guide for Intel® Ethernet Connections

https://www.intel.com/content/www/us/en/support/articles/000058304/network-and-io/ethernet-products....

Yes, tried this twice. No change, it still stalls at the start of the driver installation wizard:

Kris78_0-1616121713946.png

4. Model of the motherboard

ASRock Z87 Extreme9/ac

5. Please provide the System Support Utility log of your system. This will allow us to check your Adapter details and configuration. Kindly refer to the steps from link below. We will send an email for you to attach the logs. Please be reminded not to post the logs on this thread to avoid exposing confidential information.

I have replied to the email. Thanks.

 

Crisselle_Intel
Moderator
1,009 Views

Hello Kris,


Thank you for sharing the requested information.


We hope you don't mind sharing additional details below that would help in resolving the issue.

1. Have you tried older version from Intel website or driver from your manufacturer (ASRock)? We'd also like to set your expectations about our support for Original Equipment Manufacturer(OEM) Ethernet controller. The software drivers linked from our page are generic versions, and can be used for general purposes. For OEM on-board Ethernet controller, it would be best if you can also get in touch with ASRock for assistance since they might have customized drivers and software to enable or alter features on your system. They are in best position where you can seek assistance so you don’t lose features or customizations of the Ethernet controller.

https://www.asrock.com/MB/Intel/Z87%20Extreme9ac/index.asp#Download

2. Have you tried installing the driver manually?

You may refer to link below for How to Manually Install Intel® Network Adapter Drivers in Windows*

https://www.intel.com/content/www/us/en/support/articles/000022174/network-and-io.html


Awaiting to hear from you soon.


Should there be no response from you, I’ll make sure to follow up after 3 business 


Best regards,

Crisselle C.

Intel® Customer Support


Kris78
Novice
1,007 Views

1. Have you tried older version from Intel website or driver from your manufacturer (ASRock)?

I can appreciate Intel's position on this, however; the driver support from ASRock is essentially useless. This is the last version they provide:

Intel Lan driver ver:20.2
Windows® 10 64bit
118.91MB 2015/7/29

This fails hopelessly when it comes to running VLANs and/or teaming adaptors on Windows 10 (for about the last three or so years anyway).

2. Have you tried installing the driver manually?

It appears I can manually install the drivers for the adaptors from 26.0. After completing, it shows the following versions:

I217-V - Driver Version: 12.19.1.32

Kris78_1-1616143055472.png

 

I211 - Driver Version: 12.15.0.1

Kris78_0-1616143031581.png

The problem is, after this appears to be successful, I still can't get the PROSet/ANS to install in order to configure the required Team + VLANs. I'm happy to do that via the powershell applets, but it appears those are no longer available that I could locate, it appears this can now only be done via the PROSet/ANS GUI. Is the PROSet download available here (https://www.intel.com/content/www/us/en/search.html?ws=text#t=Downloads&sort=%40docdatetime%20descen...) the same as that which is bundled with the ethernet drivers and includes ANS?

Thinking back, this device was running 25.4 prior to the Windows update and then trying to install 26.0.0.2. As such and per your suggestion, I have downloaded and successfully installed the 25.6 driver bundle:
https://downloadcenter.intel.com/downloads/eula/30210/Intel-Network-Adapter-Driver-for-Windows-10?ht...

That seems to have installed equal or newer drivers to those that were manually installed from the 26.0 zip....25.6 installed the following drivers, :

I217-V - Driver Version: 12.19.1.32

I211 - Driver Version: 12.18.11.1

PROSet/ANS also installed successfully from that bundle.

I then tried installing 26.0 over the top just to see if it produced a different result but:
1. Manually installing drivers from 26.0 over those from 25.6, Windows suggests the drivers installed from 25.6 are equal or newer in version.
2. PROSet/ANS still hangs, no change there.

As such, I've just gone to a clean install using the 25.6 driver bundle. I'll see how this goes and whether or not the VLAN/Team config works.

Would you like a copy of the Windows Install log from attempting to install 26.0 (which might have some hint as to why it's failing, for someone smarter than me anyway!), I can email that as part of the case number if you would like?

Thanks.

Crisselle_Intel
Moderator
975 Views

Hello Kris,


Thank you for the detailed reply.


Can you confirm if you have successfully import the module as per the instructions below? If no, please share the exact error encountered so we can further check on it. 

Intel® PROSet for Windows PowerShell* Software

https://www.intel.com/content/www/us/en/support/articles/000023545/network-and-i-o.html


We will also patiently wait for your update regarding your statement below. Please feel free to post a comment if there is any update.

As such, I've just gone to a clean install using the 25.6 driver bundle. I'll see how this goes and whether or not the VLAN/Team config works.


We would highly appreciate if you can share the Install log on attempting to install 26.0 as per your statement below. We will check with engineers as to why the issue only happens on 26.0. This might be a compatibility issue with new version of OS since the issue only happens after Windows update.

Would you like a copy of the Windows Install log from attempting to install 26.0 (which might have some hint as to why it's failing, for someone smarter than me anyway!), I can email that as part of the case number if you would like?


Looking forward to your reply.


We will follow up after 3 business days in case we don't hear from you.


Best regards,

Crisselle C.

Intel® Customer Support


Crisselle_Intel
Moderator
953 Views

Hello Kris,


Good day!


This is just a follow up for the additional information requested for us to continue checking your request. Should you need more time with this, feel free to let us know and we will be glad to adjust our follow up date.


Looking forward to your reply.


We will follow up after 3 business days in case we don't hear from you. 


Best regards,

Crisselle C.

Intel® Customer Support


Crisselle_Intel
Moderator
922 Views

Hello Kris,


How are you doing?


Please be informed that we will now close this request since we haven't received any response from our previous follow ups. Just feel free to post a new question if you may have any other inquiry in the future as this thread will no longer be monitored.


Best regards,

Crisselle C.

Intel® Customer Support


Kris78
Novice
914 Views

Hi Crisselle,

Thanks, you can close this, as the issue this specifically addressed (installation) was resolved with the older driver setup program.

I believe there are ongoing stability issues associated with a driver (intermittent BSOD for Kmode_Exception_Not_Handled in spaceport.sys). I'm not sure this is related to the Intel network driver though, but the timing does correlate with the changes made there. I'll open a seperate issue if need be.

Thanks

Reply