Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
200 Views

Intel PROSet Adapter multi VLAN and Site to Site VPN issue

Intel Adapter: Intel(R) Ethernet Connection (2) I219-LM

 

Have two physical locations connected via a site to site VPN

Location 1 - Subnet A

Location 2 - Subnet B

 

Location 2 has two subnets across two VLAN's

Location 2 - Subnet B (VLAN 1)

Location 2 - Subnet C (VLAN 10)

 

I have a machine using Intel PROSet Configuration Utility to create two virtual adapters, one for VLAN 1 (untagged), and one for VLAN 10. When both adapters are enabled, they are connecting to their respective subnets via DHCP just fine, but the Site to Site VPN with Subnet A and B between the two physical locations stops working on this machine only.

 

If I disable the virtual network adapter for VLAN 10, the Site to Site VPN resumes normally, so it makes me suspect the issue is with PROSet. Any thoughts on what I should do to correct this if possible?

0 Kudos
6 Replies
Highlighted
29 Views

Hello SGlin,

 

Thank you for posting in Intel Ethernet Communities. 

 

Please provide the following details for us to check on your query.

 

1.) You've mentioned that you created untagged VLAN. Did you use VLAN ID 1 on this?

2.) Please share the driver version installed on your system.

3.) If I disable the virtual network adapter for VLAN 10, the Site to Site VPN resumes normally 

Regarding this statement, have you tried disabling VLAN 1 as well? If yes does it have the same behavior?

4.) Do you have any other machine having the same setup? If yes, does it encounter the same issue?

 

Looking forward to your response.

 

Best regards,

Crisselle C

Intel® Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
Beginner
29 Views

Hey Crisselle,

 

Not a problem. See answers below:

 

1.) You've mentioned that you created untagged VLAN. Did you use VLAN ID 1 on this?

It just says "Untagged" in the ProSet Wireless Configuration Utility, and would likely accept whatever packet was untagged (PVID), reglardless of the VLAN.

2.) Please share the driver version installed on your system.

Driver version 12.18.9.10

3.) If I disable the virtual network adapter for VLAN 10, the Site to Site VPN resumes normally 

Regarding this statement, have you tried disabling VLAN 1 as well? If yes does it have the same behavior?

If I disabled the virtual adapter for VLAN 1, it'd stop working because that is the VLAN that the Site to Site subnet for the other location is configured for, so yes.

4.) Do you have any other machine having the same setup? If yes, does it encounter the same issue?

No other machines have the same setup, but I surmise they'd have the same problem.

 

Let me know if you need anything else.

0 Kudos
Highlighted
29 Views

Hello SGlin,

 

Thank you for the reply.

 

Regarding your answer on item number 1, did you use the ProSet Wireless Configuration Utility? Can you share the steps you've done in creating VLANs.

 

Awaiting to your reply.

 

Best regards,

Crisselle C

Intel® Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
29 Views

Hello SGlin,

 

Good day!

 

Apart from the questions above, please also share the additional details below for us to further check your query.

 

1.) Regarding this statement, "but the Site to Site VPN with Subnet A and B between the two physical locations stops working on this machine only. "

What do you mean by stop working on this machine only? Please elaborate more of this statement.

2.) System Support Utility log of your system. This will allow us to check your system details and configuration. Kindly refer to the steps below.

a- Go to https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91... and download the software.

b- Open SSU.exe

c- Mark the box "Everything" and then click "Scan".

d- When finished scanning, click "Next".

e- Click on "Save" and attach the file to a post.

 

Looking forward to your reply.

 

Best regards,

Crisselle C

Intel® Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
29 Views

Hello SGlin,

 

Please provide the requested information above for us to check on your query.

 

We look forward to your reply.

 

In case we don't hear from you, we'll follow up on Thursday, January 30. 

 

Best regards,

Crisselle C

Intel® Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
29 Views

Hello SGlin,

 

Good day!

 

We'd like to inform you that we will now proceed in closing this request since we haven't received any response from our follow up. Feel free to post a new question in case you have any other assistance needed in the future.

 

Best regards,

Crisselle C

Intel® Customer Support

A Contingent Worker at Intel

0 Kudos