Ethernet Products
Intel® Ethernet products and technologies
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
3970 Discussions

Intel Pro 1000, Hyper-V Teaming and VLAN Problem

idata
Community Manager
2,315 Views

Hi,

I'm migrating a Hyper-V R1 Cluster to R2. In this case I'm restructuring the old Network Setup.

 

the scenario is like this:

- 4 Cluster Nodes

 

- connected to 2 Switches with an 8 Port LACP-Team

 

- 1 untagged and 4 additional tagged VLANs

The problem I'm having is, that i can use the tagging of Hyper-V without Teaming, but when i use Teaming and Setup VLANs on the Trunk, i cannot use them in Hyper-V.

 

I tried the following things:

 

- using the Hyper-V Tagging feature for the VM directly on the Trunk-NIC

 

- using the Intel driver to setup NICs for the VLANs and use them directly in Hyper-V

 

- enabled and disabled the VlanFiltering via Registry on the Intel NICs

The problem is, that the tagging is working on the parent partition. Even the parent partition an the VM can communicate.

 

The strange thing is, i can not ping both, VM nor parent partition from another host in the tagged vlan. But I sometimes can ping the host from the VM.

I believe it's some strange tagfiltering behaviour of the Intel driver or the Hyper-V switch.

does anyone have an idea how to get this setup working?

Thanks

 

Olaf
0 Kudos
4 Replies
Patrick_K_Intel1
Employee
268 Views

Teaming under Hyper-V is a tricky thing :-)

We had several issues with our drivers under a teaming environment. Our latest drivers however fix them :-) If you go to support.intel.com and wade through the menu's, you will be albe to get to our latest drivers and things should magically start working for you.

I would have waded through the menu's for you, howver I don't know which Pro 1000 nor which version of Hyper-V you are running (32/64 bit).

Patrick_K_Intel1
Employee
268 Views

There appears to be another entry regarding similar problem here: /message/11319# 11319 http://communities.intel.com/message/11319# 11319

This may also provide you with a solution.

idata
Community Manager
268 Views

Hi Patrick,

thanks for your help.

I think I've got the problem. I made a fresh install of the System, disabled the Broadcom protocol-bindings for all NICs, created the team with ProSet and disabled VLANFiltering in the registry.

 

I use the primary, untagged VLAN for the parent and sometimes in the VMs, and make the tagging for the VMs in the Hyper-V config.

Now it seems to be working like a charme.

Olaf

Patrick_K_Intel1
Employee
268 Views

Glad it is working! I'm not overly familar with teaming and most of what you said was gibberish to me (though it could be because I need significantly more coffee yet today).

I will make a note of this for future reference, thanx much for the follow-up.

Reply