Ethernet Products
Intel® Ethernet products and technologies
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
3701 Discussions

Intel X550-T2 Card not compatible to HP 1950-24G-2SFP+-2XGT-PoE+ Switch

idata
Community Manager
2,471 Views

Hi,i have the following issue. i am using a workstation equipped with Intel X550-T2 card and connected both 10Gbase-T ports with a cat7 cable to switch-port 27/28. switch-port 27/28 are also 10Gbase-T capable.

 

only one port on the intel card will connect at full speed (10Gbps). the second port will run with 1Gbps. I tried these things:

 

- build up a lan-team on workstation-side in windows server 2012

- forced card- and switch-ports to 10Gbase

- build a aggregation with both switch-ports

nothing really helped. is there a compatibility problem between card and switch ?

i tried also to active and deactivate stp. i dont understand why only one port run with full speed.

i got a supermicro-mainboard based server in my office as well, two intel x550 onboard ports and the same problem occur. one port is at full speed the second port is at 100Mbps.

0 Kudos
42 Replies
idata
Community Manager
271 Views

Hi Nebulaner,

 

 

Thank you for contacting Intel.

 

 

We would like to request for additional information. Please provide details below:

 

1. What are the speeds of the adapters without teaming configuration?

 

2. Which teaming mode did you configure?

 

3. Do you have link aggregation configured on the switch ports where the adapters are connected?

 

4. Driver Version:

 

5. System/Motherboard Model:

 

 

We look forward to your reply.

 

 

Sincerely,

 

Sandy
idata
Community Manager
271 Views

1. What are the speeds of the adapters without teaming configuration?

Without and with teaming both adapters work at the same speed at 1Gbps, autonegotation is on.

2. Which teaming mode did you configure?

i am using the windows server 2012 r2 default

3. Do you have link aggregation configured on the switch ports where the adapters are connected?

link aggregation is activated

4. Driver Version:

3.12.11.1

5. System/Motherboard Model:

Supermicro X11SSZ-TLN-4F

idata
Community Manager
271 Views

Hi Nebulaner,

 

 

Thank you for your information.

 

 

Please see below:

 

With regards to the adapter speed, are you trying to connect at 1Gbps or 10Gbps?

 

If you are teaming switch fault tolerance (SFT) mode, you don't have to configure link aggregation on the switch ports. Here what you need to configure on the switch:
  • Do not put clients on the SFT team link partner switches, because they do not pass traffic to the partner switch at fail.
  • Spanning Tree (STP) must be running on the network to make sure that loops are eliminated.
  • Turn off STP on the incoming ports of the switches directly connected to the adapters in the team, or configure ports for PortFast.
  • Only 802.3ad DYNAMIC mode allows failover between teams.
More information on Intel Adapter Teaming (ANS):

 

http://www.intel.com/content/www/us/en/support/network-and-i-o/ethernet-products/000005667.html

 

 

I hope this help fix your teaming issue.

 

 

 

Sincerely,

 

Sandy
idata
Community Manager
271 Views

Hi Sandy,

i dont get it to work. i configured all my settings like shown in your guide and i get the lan-team only working with 1Gbps, thats what autonegotiation want. When i try to force both adapter to full speed (10Gbps) only one team-member will hold his link. the second team-member get disconected. the 1Gbps lan-team works perfectly.

Is there anybody out there with the same card + switch ? i contacted hp, and they said "we cant help you with configuration-problems...." i dont think this is a configuration-problem. i think the switch and the network-card wont work with the full speed because of an incompatibility-issue.

Michael

idata
Community Manager
271 Views

Hi Michael,

 

 

I see that you are using Windows* Server 2012. As of the moment, we didn't have driver for this operating system yet. However, allow me to further check on this.

 

https://downloadcenter.intel.com/product/88209/Intel-Ethernet-Converged-Network-Adapter-X550-T2

 

 

For troubleshooting purposes, can you try on supported Windows* system (Windows* 7 or 8) so you may install the drivers. We look forward to your test results.

 

 

Sincerely,

 

Sandy
idata
Community Manager
271 Views

Hi Michael,

 

 

Please check if you have the "legacy switch compatibility" settings in Adapter's Advanced Settings. if you have this, try enabling this feature.

 

 

We look forward to your test results.

 

 

Sincerely,

 

Sandy
idata
Community Manager
271 Views

Hi Michael,

 

 

I would like to check if you are able to resolve the network connection problem.

 

 

Please let us know if you need further assistance. We suggest to also check with switch support for any recommendations for switch port configuration.

 

 

Sincerely,

 

Sandy
idata
Community Manager
271 Views

Hello Sandy,

i can´t find the setting "legacy switch compatibility". i got a new eeprom from supermicro support i contacted before. i will try this and can you tell me when i can expect a full windows server 2012 driver-support ?

진JinS
Beginner
223 Views

Supermicro motherboards have BMC IPMI with dedicated LAN.

After connecting to IPMI using web browser, change that LAN settings to dedicated.

Configuration -> Network Network Settings

LAN Interface: Change default Share to Dedicated

I guess this may solve your problem.

idata
Community Manager
223 Views

Hello JinSoo.Suh,

thank you for the tip, i will try it and give feedback. the next thing is that the problem is also shown with the pci-express x550 solution:

http://www.heise.de/preisvergleich/intel-x550-t2-x550t2-a1427968.html heise online Preisvergleich

i don´t think that it is a supermicro only problem

Michael

rschi5
Beginner
223 Views

I've been using the IPMI in dedicated mode since the beginning.

Guys, the NETGEAT XS712T is a WIN! All the ports stay at 10GbE and i was also able to change the MTU without any issues.

CRing2
Beginner
223 Views

i also changed my settings at once like you described.

But thank you for your idea ! Sadly it did not help.

I still have the hp switch as suspect, but hp do not care when a little customer is saying something.

Thanks to Intel for any help.

Und Danke Michael für Deine Mühe

진JinS
Beginner
223 Views

Dear Christain_H,

In my Linux case with Supermicro X10SDV-4C-TLN4F and HPE 1950 24G 2SFP+ 2XGT Switch,

following two methods make both intefaces are up with 10Gbps.

= Increase the interface MTU value to 9216(HP 1950 series default and maximum value)

# ifconfig eno3 mtu 9216

# ifconfig eno4 mtu 9216

= Set the interface to advertise only 10000baseT Full in autonegotiation.

# ethtool -s eno3 advertise 0x1000

# ethtool -s eno4 advertise 0x1000

CRing2
Beginner
223 Views

Thank you for your help!

I tried this again, and i can force them to work at this speed, but sadly

the connection gets very unstable when i do this in this case

In my case it is an hyperv server with 6 vms - maybe here he is more sensitive

because of the suggested configuration of the driver....

CRing2
Beginner
271 Views

Hello Michael, Hello Sandy,

i have exactly the same issue.

 

Only difference is the used system Windows 2008 R2 Server and we have the 48 port version of the hp switch

The two adapters run both with 1Gbit/s - but not with 10Gbit/s

I am curious about a solution!

Best regards

Christian

idata
Community Manager
271 Views

Hello Christian,

thank you for your input. are you using a onboard nic or a dedicated nic ?

Michael

CRing2
Beginner
271 Views

i am using the two onboard nic

idata
Community Manager
271 Views

Hi Christian,

what model of mainboard do you use ?

Michael

idata
Community Manager
271 Views

Hi Michael and Christian,

 

 

Please find my replies below:

 

 

 

Hello Sandy,

 

i can´t find the setting "legacy switch compatibility". i got a new eeprom from supermicro support i contacted before. i will try this and can you tell me when i can expect a full windows server 2012 driver-support ?

 

 

 

Not all systems have this setting. You can find this in Device Manager -> Adapter Properties -> Advanced tab

 

 

 

***************

 

 

Please try to install the driver for this adapter. The latest version is 3.12.11.1. This version has support for Windows* 2008 and 2012. However, it would be best if you can request and isntall the tested driver from your respective system manufacturers to avoid any compatibility problem.

 

 

If you choose to try out our driver, you may download it here:

 

https://downloadcenter.intel.com/product/84329/Intel-Ethernet-Controller-X550-AT2

 

Filename: 21_0_cd.zip

 

Version: 21.0

 

 

We look forward to your test results.

 

 

 

Sincerely,

 

Sandy
CRing2
Beginner
271 Views

its a Supermicro X10SRM-TF with this chip onboard and two ports

Reply