Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
3,612 Views

Intel dp55wb NIC problems after waking from Windows sleep mode (win7 64-bit)

I have the intel dp55wb motherboard with integrated NIC and am expericing a problem in Windows 7 64-bit. When the computer is idle and goes into power saving sleep mode, I experience a network problem upon waking the computer. The network connection that was previously working just fine before entering sleep mode will now be dead after waking Windows. I have to disable the NIC or shutdown and restart Windows in order for it to start working again. I have updated my BIOS to the most recent version which was released in early January 2010 and the problem persists. The only work-around I have found is just to disable power saver/sleep mode in the Windows 7 power settings in the control panel.

0 Kudos
12 Replies
FvanD
New Contributor I
288 Views

I have the same board, same OS, using intgrated NIC. I also use sleep/wake a lot (multiple times a day). It always works, reliably. In fact, I use WOL a lot as well, waking the computer from a remote location.

So the good news is: it can be made to work. Now we have just to figure out the cause of your problems. I think it must be driver related, or else the power settings of the driver.

I use 14.7, driver only (device manager shows 11.2.19.0). Wake on magic packet, and wake on magic packet from power off state are enabled. Otherwise the driver has all settings at default.

idata
Community Manager
288 Views

First off, thanks very much for the response. I also figured it was software/driver related but after updating my BIOS and installing the latest NIC driver as well as all my Windows Updates, I began to run out of ideas.

I have tried updating the NIC driver and there is even a 14.8 version available now which was released 12/16/2009. I will check the settings you mentioned this evening. I would agree that it has to be something related to this, I just don't know what yet.

Thanks again for your input.

idata
Community Manager
288 Views

Check your bios: Boot to network = disable. Right click your screen and select personalize. Click screen saver. Click change power settings. Select balanced. Click change plan settings. Click Restore default settings for this plan. Restart the computer. See if it solves your problem.

idata
Community Manager
288 Views

Unfortunately neither of these suggestions fixed the problem. NIC works like a charm when I tell Windows to never go to sleep -- however when sleeping is enabled it kills the NIC upon waking up. Strangest thing, I've updated everything I can think of.

idata
Community Manager
288 Views

When you update the NIC driver, did you also select (put a check mark) Network Connection SNMP Agent?

idata
Community Manager
288 Views

Here are some information that might be of interest:

The version 14.8 driver is titled and described by support as: Intel Pro Network Connections Driver for Intel Desktop boards for windows 7 - installs the Lan driver version 14.8 for Intel Desktop Boards with the intel Pro Network Connections for Desktop.

I have installed the said driver yesterday and verify the actual driver in the device manager before and after the supposed update as version 11.5.10.0. It is not version 14.8. This version 14.8 is shown only in the uninstall program for network connection.

Mine is working perfectly.

TGwin
Novice
288 Views

14.8 is the version of the whole driver download package. The specific driver which gets installed shows in Device Manager is 11.5.10.0. Same as yours.

TGwin
Novice
288 Views

We have only two DP55WB systems on our LAN and both are experiencing somewhat similar problems -- no other systems exhibit these symptoms. Both are Win7x64 Enterprise and 14.8 LAN drivers. Using latest BIOS (as of this posting date). The symptom is that after power-on or reboot or sleep the NIC may not connect and the so the user receives "There are currently no logon servers available" when attempting to log into the domain.

Workaround is to login as local administrator and disable/enable NIC, or put system to sleep for 10 sec and wake it up, or unplug/replug NIC cable, or speak sacred incantations three times while doing all of the above.

Once the NIC is successfully connected, it runs flawlessly until the next power-down,reboot or sleep, when the problem may or may not recur.

It is quite annoying. I am going to play with some of the settings in the Win7 driver (Advanced and Link speed tab) using the hypothesis that some auto-detect or auto-negotiation is failing, and try to force some of those settings to fixed values.

idata
Community Manager
288 Views

Please let me know if you find a solution or if a fix is released, I would really appreciate it. My hunch is it's going to be fixed in a NIC driver update or a BIOS update at some point. I'm surprised other people have the same motherboard/OS/driver with no problems. Everything was working fine in Windows Vista 32-bit with my old Asus motherboard. I guess this is what I get for being a early adopter and upgrading to the Core i5 with Windows 7 64-bit last year.

TGwin
Novice
288 Views

Correction to my previous post. I had BIOS version 0165 and thought that was the latest. I just checked and found version 0190 and installed that. I will report if that makes any difference.

I will report that when I was testing with the 0165 version, I did not find that forcing Link Speed to 1GB FDX, forcing Master/Slave to Slave, and forcing Wait for Link to Off made any difference.

TGwin
Novice
288 Views

So far, BIOS version 0190 appears to possibly have lessened our symptoms on our two DP55WB PCs, but it has not solved the issue completely.

idata
Community Manager
288 Views

A similar problem as yours has been discussed in another forum. You might like to take a look at it. http://www.tomshardware.com/forum/27782-42-computer-causing-internet-down http://www.tomshardware.com/forum/27782-42-computer-causing-internet-down. Several solutions are presented.

Reply