Ethernet Products
Intel® Ethernet products and technologies
4155 Discussions

Intel i225 v3 crashes on heavy load

Comrade21
Beginner
732 Views

When I host a Minecraft server, the Intel i225 network adapter crashes.

This happens CONSTANTLY when there are many NPCs in the same region, and the player from the EXTERNAL IP stands in that region.
After the internet crashes, Windows Troubleshoot hangs on "Reseting Ethernet adapter", and i225 status is "No drivers are installed for this device".

When I try to restart the computer, Windows turns off, and then the computer freezes forever on a black screen, only a complete shutdown by holding the power button helps.

Also, this happens when I have many parallel downloads. I even replaced Windows 10 with Windows 11.
I found reports of the same problem on the internet, updated the BIOS, tried different versions of the drivers (1.0.2.14, 1.0.2.13, and 1.0.2.8) but the problem stays, how to fix it?

This problem is very easy to repeat, so I even managed to record it:

https://youtu.be/5ONGYBJNLiw

0 Kudos
8 Replies
Achilles_Intel
Moderator
650 Views

Hello Comrade21,


Thank you for posting in Intel Ethernet Communities.


We are sorry to hear about this issue you encountered. For us to further check this issue, can you confirm the following details for us?


  1. Are you using a LAN on Motherboard (LOM)? If yes, may we ask what is the brand and model of your motherboard?
  2. Where did you download the drivers? Can you provide us a link so we can further validate?
  3. Kindly provide the SSU of your system. For reference, attached is the link below.


https://www.intel.com/content/www/us/en/support/articles/000008563/ethernet-products.html


Let us know if you have further questions. If we do not receive an update from you, we will make sure to reach out after 3 business days.



Thank you and have a nice day.



Best regards,

Achilles M.

Intel Customer Support


Comrade21
Beginner
642 Views

1. Gigabyte B560M AORUS PRO

2. I downloaded the driver from the official Gigabyte site. I also tried the Windows drivers and drivers from the Intel website. https://www.gigabyte.com/Motherboard/B560M-AORUS-PRO-rev-1x/support#support-dl-driver-lan

3. Attached SSU scan results

Achilles_Intel
Moderator
615 Views

Hello Comrade21,


Thank you for the quick update.


Please be informed that since you are using an onboard I225-V, we have limited support for Original Equipment Manufacturer (OEM) controllers. As such, you may have to reach out to Gigabyte later on for further support since they have customized drivers and software to enable or alter features on your system. They are in best position for you to seek assistance so you do not lose features or customizations of the Ethernet controller.


In any case, we will help you with this matter as best as we could. Please allow us some time to further check this. We will provide you with an update within 3 business days.


Thank you for your cooperation.



Best regards,

Achilles M.

Intel Customer Support


Achilles_Intel
Moderator
599 Views

Hello Comrade21,


Hope you are doing well.


Can you try and change the Power Management settings of the LOM by disabling all options? Let us know if this helps resolve the issue.


Also, based on the SSU logs you provided, we noticed that you are using a generic Intel driver. We would recommend to try the driver provided by your motherboard manufacturer, Gigabyte to test.


We have also found this article below that you may find useful in this issue. However, we recommend for you to get in touch with Gigabyte for the NVM file and update procedure for this one.


https://www.intel.com/content/www/us/en/support/articles/000057261/ethernet-products/gigabit-etherne...


Let us know if you have further questions or need clarifications. If we do not receive an update from you, we will reach out again after 3 business days.


Thank you and have a nice day.



Best regards,

Achilles M.

Intel Customer Support


Comrade21
Beginner
592 Views

The current drivers are from the Gigabyte site, so they offer a generic driver.

Disabling power-saving options did nothing.

The firmware update link is for old revisions of i225. I have the 3rd revision so my firmware version is 16.87, and I have not seen the newer one on the Internet

Achilles_Intel
Moderator
562 Views

Hello Comrade21,


We are sorry to hear that our suggestions were not able to help you with your issue. As we have mentioned before, since this is an embedded LAN, your best source of support would still be the motherboard manufacturer, Gigabyte. You can reach out to them for further support through this link below.


https://www.gigabyte.com/Support


Kindly let us know if you have further questions. We will make sure to reach out again after 3 business days if we do not receive an update from you.


Thank you and have a nice day.



Best regards,

Achilles M.

Intel Customer Support


Achilles_Intel
Moderator
497 Views

Hello Comrade21,


Good day.


We are just checking if you need further assistance or have questions regarding your inquiry for this thread. Feel free to let us know if you need clarifications. If we do not receive an update from you, we will reach out again after 3 business days.


Thank you and have a nice day.



Best regards,

Achilles M.

Intel Customer Support


Achilles_Intel
Moderator
481 Views

Hello Comrade21,


Good day.


We are following up on your inquiry on this thread. Since we haven't heard from you for a few days, we will now be closing this thread. Feel free to post a new question in the forums if you have additional questions as this thread will no longer be monitored.


Thank you and have a nice day.



Best regards,

Achilles M.

Intel Customer Support


Reply