Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
5033 Discussions

Intel network adapter 82567LM connection dropping


We have an issue with both the Dell E4200 & E5400 laptops where the network connection keeps dropping. The network adapter is an Intel 82567LM.

The connection seems to drop randomly, however I can force it to drop by copying a large (5 GB) file to another machine (it fails at a random point during the copy). When it drops the Media State still shows as enabled, but you lose all network access. 'Windows Network Diagnostics' returns "The default gateway is not available" and can't fix the problem; when you try to reboot the machine it just sits at "Shutting down" so you have to hold down the power button to switch it off.

The issue only occurs on Windows 7 32-bit. Installing 64-bit resolves the issue, but this is not an option for us as we run software which is only 32-bit compatible.

I've read through endless posts regarding this issue, and have tried various solutions, none of which have fixed the problem. I've tried these versions of the driver:

(These versions are the drivers that come with Windows 7, the drivers from the Dell web site, and the latest drivers from the Intel web site).

I've also tried disabling the various power saving options in the network settings (this is described as a solution on lots of forums), but this has not helped either. We've contacted Dell support but they have not been any help.

Lots of sites suggest using the driver version (provided with Windows), however this seems to be for the 82567LM-3 adapter, and is not compatible with the 82567LM.

Any suggestions would be much appreciated!

0 Kudos
1 Reply

A connection drop like you describe is not a known issue with the 82567LM. As you already found out, at least some of what you were reading had to do with the driver used with the 82567LM-3, which is a different driver. I do not know of a specific solution, but I have some ideas that might help track down the source of the issue. You may have already thought of some of these things.You already tried multiple driver versions, so I would look at other possible causes.

Are you using a prepared image or installing the 32-bit Windows 7 from install media? If you have a prepared image, you might try a fresh install to see if that makes any difference just in case some Windows file or registry setting is causing an issue.

Do you have Service Pack 1 installed or not? Does SP1 have any affect on the issue?

Try running the diagnostics available from the Link Speed tab in Windows device manager. Is there any difference in the results of the diagnostics when the network connection is acting normally versus when no traffic is flowing? Are there any indications in the diagnostics that anything is failing?

How are your speed and duplex settings configured? Auto? What about on the link partner? Does forcing the speed and duplex to a different setting on both ends of the connection cause the connection drops to disappear?

Are you running the latest BIOS version on the laptops? Does upgrading the BIOS make any difference?

Have you tried running without any security software (e.g. antivirus, firewall, intrusion detection) installed?

Let me know what you find.

Mark H