Ethernet Products
Intel® Ethernet products and technologies
4157 Discussions

Intel x520 DA2 connection to Tofino not working

Goshi
Novice
188 Views

Hi all,

I am trying to connect a PC with an Intel x520 DA2 NIC to a Tofino-1 switch which is running stratum and controlled by ONOS.

I am having a problem as the NIC shows "Link detected: no" and while the Tofino ports are enabled I cannot send any traffic.

 

I read in this stratum and barefoot page that  "We only support DAC cables at the moment, and autoneg must be forced "on" for every port". On the other hand, using ethtool I saw that x520 does not support autonegotiation. I tried disabling it in the chassis_config.pb.txt file but the situation persisted. 

 

So I am trying to understand if the only option I have is to get another card that supports autonegotiation since stratum forces this option for every port. 

Can someone help me in resolving this issue, or at least understand what options I have now to successfully connect the devices?

Thanks in advance!

0 Kudos
1 Solution
Goshi
Novice
119 Views

Hi Mike,

 

Thanks again for your help.

I managed to fix the issue by connecting the PC and Tofino with an optical cable instead of the copper one used in the beginning. This allowed for the autonegotiation feature to be turned ON in the X520 NIC. 

 

Additionally, if it can help someone else having issues with it, using the bf-sde shell I changed the low-power mode settings for the given port.

qsfp
set-lpmode <port-nr> 0

We can now close this issue.

 

Best regards,
E. Goshi

View solution in original post

5 Replies
Mike_Intel
Moderator
171 Views

Hello Goshi,


Thank you for posting in Intel Ethernet Communities. 


For us to further check the issue, please provide the following details.


  1. Are you designing a system/board with embedded X520 card?
  2. Or are you using PCIe X520 card?
  3. What is the brand and model of your board/system?
  4. What is your OS?
  5. Kindly share the link of your the driver that you are using?


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support


Goshi
Novice
163 Views

Hi Mike,

 

Thanks for your help.

Below you can find the details you are asking for.

  1. Are you designing a system/board with embedded X520 card?
    •  No.
  2. Or are you using PCIe X520 card? 
    • Yes, the NIC is installed in one of the PCs I am using and it is connected to the Tofino switch.
  3. What is the brand and model of your board/system?
    • IMG_8308.png

  4. What is your OS?
    • Ubuntu 18.04.6 LTS
  5. Kindly share the link of your the driver that you are using?
    • From the output of the command below:
      lshw -class network

      I get the following information: driver=ixgbe driverversion=5.1.0-k firmware=0x00012b2c, 1.1197.0

Is there anything else I can provide?

 

Best regards,
E. Goshi

Mike_Intel
Moderator
136 Views

Hello Goshi,


Thank you for the prompt reply. For me to also check if the network card is not an OEM. Please send photos of the unit on both sides with clear markings.


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support


Goshi
Novice
120 Views

Hi Mike,

 

Thanks again for your help.

I managed to fix the issue by connecting the PC and Tofino with an optical cable instead of the copper one used in the beginning. This allowed for the autonegotiation feature to be turned ON in the X520 NIC. 

 

Additionally, if it can help someone else having issues with it, using the bf-sde shell I changed the low-power mode settings for the given port.

qsfp
set-lpmode <port-nr> 0

We can now close this issue.

 

Best regards,
E. Goshi

Mike_Intel
Moderator
113 Views

Hello Goshi,


Thank you so much for the update and we are glad that the issue is now fixed. Thank you also for sharing the fix that may help other forum users. We will now close the case that we created for you and if you need assistance again in the future, please post a new question.


Thank you and stay safe.


Best regards,

Michael L.

Intel® Customer Support


Reply