Community
cancel
Showing results for 
Search instead for 
Did you mean: 
vMish5
Beginner
2,184 Views

Ixgbe driver support for X552 controller and external phy

Hi

I am using X552 controller(ADLINK com-ex7) with external phy (AQR107).

Just wanted to know if this configuration is supported in ixgbe driver or not. If not is there any patch available to support this configuration.

currently i am getting following error:

[ 0.748518] pci 0000:03:00.1: [8086:15ad] type 00 class 0x020000

[ 0.748532] pci 0000:03:00.1: reg 0x10: [mem 0xfb200000-0xfb3fffff 64bit pref]

[ 0.748553] pci 0000:03:00.1: reg 0x20: [mem 0xfb600000-0xfb603fff 64bit pref]

[ 0.748560] pci 0000:03:00.1: reg 0x30: [mem 0xfb800000-0xfb87ffff pref]

[ 0.748606] pci 0000:03:00.1: PME# supported from D0 D3hot D3cold

[ 0.748623] pci 0000:03:00.1: reg 0x184: [mem 0xfba00000-0xfba03fff 64bit]

[ 0.748625] pci 0000:03:00.1: VF(n) BAR0 space: [mem 0xfba00000-0xfbafffff 64bit] (contains BAR0 for 64 VFs)

[ 0.749006] pci 0000:03:00.1: reg 0x190: [mem 0xfb900000-0xfb903fff 64bit]

[ 0.749008] pci 0000:03:00.1: VF(n) BAR3 space: [mem 0xfb900000-0xfb9fffff 64bit] (contains BAR3 for 64 VFs)

[ 14.380732] ixgbe 0000:03:00.1: HW Init failed: -17

[ 14.382261] ixgbe: probe of 0000:03:00.1 failed with error -17

Thanks

0 Kudos
9 Replies
idata
Community Manager
459 Views

Hi vijaym,

 

 

Thank you for posting in Wired Ethernet Community.

 

 

We'd like to clarify some information in order for us to provide solution or support route for your query.

 

 

Is the X552 Ethernet controller integrated into the AQR107 and you'd like to know if this is a supported configuration?

 

 

Best regards,

 

Vince
idata
Community Manager
459 Views

Hi vijaym,

 

 

We'd like to follow-up the requested information. Thanks.

 

 

Best regards,

 

Vince
vMish5
Beginner
459 Views

Hi Vince,

Thanks for looking into this thread. Sorry for the delay in reply

Please find my replies below:

>> Is the X552 Ethernet controller integrated into the AQR107 and you'd like to know if this is a supported configuration?

X552 controller is part of Xeon-D processor in ADLINK COMEX module while AQR107 phy module is connected to X552 via:

- 10G_PHY_MDIO_SDA0/SCL0 lines (Programming interface)

- 10G_KR (Data interface)

Please check block diagram below

Current status:

===========

After applying following change i am able to probe the phy on appropriate phy_address and read the device ID.

========================================================================

[comex@localhost linux-stable]$ git diff drivers/net/ethernet/intel/ixgbe/ixgbe_phy.c

diff --git a/drivers/net/ethernet/intel/ixgbe/ixgbe_phy.c b/drivers/net/ethernet

index 3b83620..5725b86 100644

--- a/drivers/net/ethernet/intel/ixgbe/ixgbe_phy.c

+++ b/drivers/net/ethernet/intel/ixgbe/ixgbe_phy.c

@@ -298,7 +298,7 @@ s32 ixgbe_identify_phy_generic(struct ixgbe_hw *hw)

if (hw->phy.type != ixgbe_phy_unknown)

return 0;

-

+# if 0

if (hw->phy.nw_mng_if_sel) {

phy_addr = (hw->phy.nw_mng_if_sel &

IXGBE_NW_MNG_IF_SEL_MDIO_PHY_ADD) >>

@@ -308,7 +308,7 @@ s32 ixgbe_identify_phy_generic(struct ixgbe_hw *hw)

else

return IXGBE_ERR_PHY_ADDR_INVALID;

}

-

+# endif

for (phy_addr = 0; phy_addr < IXGBE_MAX_PHY_ADDR; phy_addr++) {

if (ixgbe_probe_phy(hw, phy_addr)) {

status = 0;

@@ -373,6 +373,7 @@ static s32 ixgbe_get_phy_id(struct ixgbe_hw *hw)

hw->phy.id |= (u32)(phy_id_low & IXGBE_PHY_REVISION_MASK);

hw->phy.revision = (u32)(phy_id_low & ~IXGBE_PHY_REVISION_MASK);

}

+ printk(KERN_ALERT " hw->phy.id = %x hw->phy.revision= %x\n", hw->

return status;

}

==========================================================

But i am observing unstable link logs as below:

[comex@localhost linux-stable]$ sudo insmod ixgbe.ko

[ 116.279158] ixgbe: module verification failed: signature and/or required key missing - tainting kernel

[ 116.291716] ixgbe: Intel(R) 10 Gigabit PCI Express Network Driver - version 4.4.0-k

[ 116.299379] ixgbe: Copyright (c) 1999-2016 Intel Corporation.

[ 116.798013] hw->phy.id = 3a1b4e0 hw->phy.revision= 2

[ 117.339565] ixgbe 0000:03:00.0: Multiqueue Enabled: Rx Queue count = 32, Tx Queue count = 32

[ 117.477789] ixgbe 0000:03:00.0: MAC: 5, PHY: 7, PBA No: 000200-000

[ 117.483983] ixgbe 0000:03:00.0: 00:30:64:1a:65:cc

[ 117.546288] ixgbe 0000:03:00.0 enp3s0f0: renamed from eth0

[ 117.555985] ixgbe 0000:03:00.0: Intel(R) 10 Gigabit Network Connection

[ 117.570357] IPv6: ADDRCONF(NETDEV_UP): enp3s0f0: link is not ready

[ 117.713350] ixgbe 0000:03:00.0: registered PHC device on enp3s0f0

[ 117.854938] IPv6: ADDRCONF(NETDEV_UP): enp3...

vMish5
Beginner
459 Views

Hi Vince,

I am waiting for your reply.

More info about setup:

AQR107 FW is provisioned as below:

- 10G_KR mode for 10G speed.

- 10G_KX mode for 1G speed.

I see link up down events only when remote partner is 1G with 10G link is not coming up at all.

I checked the driver again observed that driver configures the MAC interface based on phy_type and since AQR 107 phy (PhyID: 03A1B4E2) is not there in driver's phy supported list so its getting detected as ixgbe_phy_unknown.

Please let me know how i can set the X55x controller's MAC interface ( with device ID 0x15AD) to 10G_KR with PHY AQR 107 (PhyID: 0x03A1B4E2).

Thanks in advance.

-Vijay

idata
Community Manager
459 Views

Hi VijayM,

 

 

Have you had the chance to check with ADLINK support as this is onboard NIC embedded on their system.

 

 

Where did you avail of the ixgbe driver version ? Please provide the link. Thank you.

 

 

Thanks,

 

Sharon

 

vMish5
Beginner
459 Views

Hi Sharon,

>> Have you had the chance to check with ADLINK support as this is onboard NIC embedded on their system.

I checked with them. Initial response was to check with intel for SW support.

>> Where did you avail of the ixgbe driver version ? Please provide the link. Thank you.

I am using centos 7 with mainline stable kernel version 4.10.

Thanks,

Vijay

 

idata
Community Manager
459 Views

Hi VijayM,

 

 

Thank you for the information. I will check on this.

 

 

Regards,

 

Sharon

 

idata
Community Manager
459 Views

Hi VijayM,

 

 

Just to double check if you are using the latest driver version. You may check on the sourceforge site for new driver https://sourceforge.net/projects/e1000/, (this is the site where Linux driver are available).

 

 

Please feel free to update me.

 

 

Thanks,

 

Sharon

 

 

 

 

 

idata
Community Manager
459 Views

Hi VijayM,

 

 

Please feel free to update me if you have tried the driver available at Sourceforge.

 

 

Thanks,

 

Sharon T
Reply