Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4973 Discussions

Killer Intelligence Center "Service Not Running"

SunSet
Novice
11,029 Views

When I launch the Killer Intelligence Center application, I get a "Service is Not Working" error. I download the updated Killer Performance Package from Intel's "Download Center" section and install it without any problems. I made a new installation, but I still get the same error when I open the application. I've been getting this error for the last 1 month, I've never had a problem like this before.

 

https://www.intel.com/content/www/us/en/download/19779/intel-killer-performance-suite.html 

 

SunSet_0-1676378290893.png

SunSet_1-1676378369713.png 

SunSet_2-1676378404675.png

SunSet_3-1676378434392.png

 

 

 

0 Kudos
1 Solution
SunSet
Novice
10,965 Views

I installed it on the previous version, 33.22.1142, and my problem was solved. I am having problems after installing this version 34.22.1156. Could you please tell this to the engineers? Does the latest version not have E2600 support?

 

SunSet_0-1676504049380.png

 

View solution in original post

9 Replies
Irwan_Intel
Moderator
11,001 Views

Hello Sunset,

 

Thank you for posting in Intel Ethernet Communities.

 

For us to further check and investigate the issue, please provide the following details.

 

1) Is this a laptop or desktop?

2) Could you please verify your killer adapter model.

3) Is this the original adapter that came pre-installed in your system

 

 

Please try clean-installing the latest release instruction articles below. You may already updated to the newest Intel Killer Control Center for your adapter, but the service did not register correctly.

 

How to do clean installing https://www.intel.com/content/www/us/en/support/articles/000058906/wireless/wireless-software.html

 

You may refer to this article : https://www.intel.com/content/www/us/en/support/articles/000058954/ethernet-products.html


Looking forward to hear from you soon.

 

Best regards,

 

Irwan_Intel

Intel® Customer Support


0 Kudos
SunSet
Novice
10,987 Views

1. Laptop. Acer Nitro 5 AN515-44.

2. Killer E2600 Gigabit Ethernet Controller and Intel(R) Wi-Fİ 6 AX200 160MHz

3. Original.

 

I have done what you said many times, my problem has not improved.

0 Kudos
Irwan_Intel
Moderator
10,976 Views

Hi SunSet,


Thank you for the informations.


Since you model is an Acer Nitro 5, Have you tried contacting Acer support for the troubleshooting steps that you can perform? You may consider checking with them the latest BIOS as well as drivers to see if it will help in resolving the issue.


Acer link: https://www.acer.com/us-en


Acer will have different instructions since they have customized drivers, firmware and software to enable or alter features on your card. 


To avoid any potential installation incompatibilities on your OEM card, Intel recommends that you check with your OEM and use the software they provide so you don’t lose features or customizations of the Ethernet adapter.



Best Regards,


Irwan_Intel

Intel Customer Support.


0 Kudos
SunSet
Novice
10,969 Views

I'm sorry you didn't help me. i was using it without problems 1 month ago, I sent my computer for maintenance, I couldn't use the driver when it arrived, but I think a new update has arrived. I think it's due to your update. My BIOS version is up to date.

0 Kudos
SunSet
Novice
10,966 Views

I installed it on the previous version, 33.22.1142, and my problem was solved. I am having problems after installing this version 34.22.1156. Could you please tell this to the engineers? Does the latest version not have E2600 support?

 

SunSet_0-1676504049380.png

 

Touriste44
Beginner
5,706 Views

Hi

I've got the same problem, and I have the same ACER NITRO PC

Could you sent me the link for the 33.22.1142 version ok Killer suite.

Best regards

 

0 Kudos
Irwan_Intel
Moderator
10,902 Views

Hi Sunset,


Sorry for the late posting, At this point, I recommend you to check with Acer directly to confirm the right steps to perform a clean installation of the driver for the wireless card and also to confirm the correct installation of the Intel® Killer™ Software.


Please contact directly with the manufacturer of the device, in this case Asus, to report this scenario, so if necessary, they can work a new driver release that will be updated that complies with the features and functions advertised for your machine.


The Intel® Graphics drivers are generic, meaning they might or might not work with your system or having compatibility issues with your laptop.



Best regards,


Irwan_Intel

Intel® Customer Support


0 Kudos
righthandman41
Beginner
3,101 Views

I'm having the same issue on an Alienware box. New update - launch the software, get "Service Not Running." I go into services.msc and turn on the service (it's already set to auto and should be running). I then tell it to start, it starts, I can even see the GUI start to load then it ticks of again. I am running Windows Defender and no other 3rd Party Antivirus.

 

So... since we've proved that it's not Acer... what now?

0 Kudos
Derek12b
Beginner
2,799 Views

Same thing is happening to me on my Alienware aurora r10 pc i looked through the properties and went through the log it first started on march 29 2024 i just noticed in april 22 2024 after realizing killer intel center gui won’t show i did the same thing and went to services and started it and the gui shows for a brief glimpse then it goes back to service not running i uninstalled updated the killer intel center i even rebooted my network and went through all types of ways i found on youtube to get it up again i even tried going back a update to see if the previous version worked nothing
Hope a update to it in the future fixes it this came preinstalled on my pc since i got it and has worked for a year and half since i have had the pc and i try to keep everything up to date i even made sure all the software on ny pc is up to date and it is even the bios nothing is corrupted i hope they release a update that fixes this or i find someone who has the solution for fixing this but i still haven’t found the solution to fix it yet

0 Kudos
Reply