Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
4737 Discussions

Lost internet connection with on board ethernet 1218-V


Hi Community,

I recently updated my new PC from Win 8.1 to Win 10. All was working well for 5 or so days...then...came home to find internet would not connect.

Tried updating to Win10 drivers - no difference. 3 other older PC's on same network updated to Win 10, no problems.

MSI board - X99A SLI Plus.

I notice that despite uninstalling and reinstalling the adapter that network connection number stays at (2). In the past when I have done this the connection number increases. Makes me wonder if it is actually fully uninstalling?

The driver properties shows the newly installed driver, is shown as working and normal LAN access is working OK.

Would editing the registry for this device help with a full uninstall. If so, does anyone have a reference I should be looking for in the registry?

Any help on this very frustrating problem would be really appreciated.

0 Kudos
2 Replies

Hi gdoutch,

Sharing the link on where you can find registry location of network adapter parameters Network Connectivity — Unable to Uninstall Intel® Network Connections, Intel® PROSet, or Teams

If one of the 3 other PC's have dual LAN ports, you may want to try out Internet connection sharing to further isolate the problem.

Internet router <--- LAN 1 --- PC --- LAN 2 <--- Win10 PC

Hope this help.




Hi Vince,

Thank you so much for getting back to me and my apologies for the time it has taken me to get back to you, I have been interstate.

I tried the Registry editing (twice) per the article in the link, unfortunately I was unsuccessful in getting an internet connection. Also, the same network connection number came back, so perhaps I didn't follow the instructions exactly. I am cautious when editing the registry. The second article (within the above article) mentioned another approach on removing the installation PROSET.MSI. using msizap? I haven't tried this as I wonder if it applies in my case? and I don't want to create a larger problem.

All the other PC's only have single Ethernet ports so sharing isn't possible (great tip though!).

The final suggestion in the original article was to reinstall Win 10, that I guess is my next step. Do you have any other suggestions?

Thank you so much for your help.


0 Kudos