Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
5027 Discussions

NIC settings for low latency gaming?

N1K
Beginner
23,654 Views

Hello, what are the best settings for my Intel I219-V network adapter for low latency gaming? With the default settings, my shots don´t connect and my game is "delayed", people in the game can shoot me before i see them and i die behind walls. I´m playing with a very low ping on a separet internet connection just for gaming with only 1 pc connected. I don´t have packetloss or high jitter but i feels like packets are getting dropped or delayed.

0 Kudos
7 Replies
Irwan_Intel
Moderator
23,619 Views

Hi N1K


Thank you for posting in Intel Ethernet Communities.


After reviewing the information provided, you may find some useful articles below for i219-v network adapter.


https://www.intel.com/content/www/us/en/support/articles/000093547/ethernet-products/gigabit-ethernet-controllers-up-to-2-5gbe.html

https://www.intel.com/content/www/us/en/support/articles/000056817/ethernet-products/gigabit-ethernet-controllers-up-to-2-5gbe.html


Please let me know if you have further questions or concerns.


Regards,

Irwan_Intel


0 Kudos
N1K
Beginner
23,605 Views

Hello Irwan,

 

thanks for your answer, but my problem is not low bandwith. Are there any settings i can change to lower the latency. 

I found this on a very old website:

 

Optimized for quick response and low latency (Gaming):

  • Disable Interrupt Moderation Rate
  • Disable Flow Control
  • Disable Offload TCP Segmentation
  • Increase Transmit Descriptors
  • Increase Receive Descriptors
  • Increase RSS Queues

https://www.speedguide.net/articles/gaming-tweaks-5812

0 Kudos
Irwan_Intel
Moderator
23,605 Views

Hi N1K,


You could try the following steps and see if there's any differences in the latency.


1)Jumbo Frame Size: Enabling Jumbo Frames can increase the size of data packets and reduce latency. Go to the Device Manager, select Ethernet adapter, right-click and select "Properties," then go to the "Advanced" tab, select "Jumbo Packet," and change the value to "9014" or "16128".


2)Energy Efficient Ethernet (EEE): Disabling EEE can reduce latency by disabling a feature that puts the Ethernet adapter into a low-power state when there is no network activity. Go to the Device Manager, select Ethernet adapter, right-click and select "Properties," then go to the "Advanced" tab, select "Energy Efficient Ethernet," and change the value to "Off/Disabled."


3)Interrupt Moderation: Disabling Interrupt Moderation can reduce latency by reducing the amount of time it takes to process network interrupts. Go to the Device Manager, select Ethernet adapter, right-click and select "Properties," then go to the "Advanced" tab, select "Interrupt Moderation," and change the value to "Disabled."


Please let me know if you have further questions or concerns.


Thanks,

Irwan_Intel


0 Kudos
N1K
Beginner
23,588 Views

unfortunately there was no difference

0 Kudos
Irwan_Intel
Moderator
23,561 Views

Hello N1K,


In order to assist you with troubleshooting, could you please provide us with the following information:


1)What is the model of your system/motherboard?

2)What is your operating system and its version?

3)How is your system connected to the internet?

4)What are the models of your routers or switches?

5)What is the current version of your ethernet driver?


Additionally, please run the SSU utility and provides SSU logs. You may refer to the instructions here: https://www.intel.com/content/www/us/en/support/articles/000057926/memory-and-storage.html


Please let us know if you have further questions or concerns.


Regards,

Irwan_Intel


0 Kudos
Irwan_Intel
Moderator
23,476 Views

Dear N1K,


I hope this message finds you well. I am writing to follow up on the information requested in my previous post. Have you had the opportunity to gather the necessary information?


Please let me know if you have any updates or require further assistance.


Best regards,

Irwan_Intel


0 Kudos
Irwan_Intel
Moderator
23,354 Views

Hi N1K,


I hope you're doing well. Unfortunately, we haven't received any response or activity on the thread for quite some time. As a result, we have decided to close the thread and it will no longer be monitored.


We understand that circumstances may have prevented you from providing further information or participating in the discussion. If you have any questions or concerns related to the topic, please feel free to create a new thread or reach out to us directly. We are here to assist you.


Regards,

Irwan_Intel


0 Kudos
Reply