Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MMart32
Beginner
1,162 Views

No network connection with l218-V with Link Speed over 100mbit/half duplex.

Motherboard: Maximus VII Ranger

Bios: 3003

Driver version: 12.12.218.0

PROset version: 20.1.1022

Windows 10 64-bit (currently, problem started in windows 7)

Yesterday, in preparation of upgrading to windows 10, I decided to upgrade to the latest BIOS as well (version 3003). Everything seemed fine, until this morning when I discovered I had no network connection.

After some searching on the internet, I changed the link speed from auto negotiation to 100Mbps Half Duplex. This at least gave me the ability to download the files for windows 10, hoping that a clean install with the latest drivers would fix the issue, I proceeded to upgrade to windows 10.

Sadly I still have the same issue, any setting lower than 100Mbps Half Duplex works, anything over it wont let me me connect to the network (auto negotiation sets it to 1.0 Gbps Full Duplex and doesn't work either).

Running a speedtest gives me about 75Mbps, which is half my actual internet speed, so keeping it at this is unacceptable for me.

Attempted fixes:

- Tried several BIOS versions including the latest 3 and a version of around the time of purchase of my motherboard (mid 2014).

- Installed several driver versions including the one listed above (currently installed), the latest driver from the intel website and the one currently in the windows 10 driver section on the asus M7R support page.

- Reset TCP/IP

- Reverted to older firmware on my router (Netgear R7000), currently installed: 1.0.4.28

- Different cable and port on the router.

- Used a laptop to test the wired connection, worked without issues and gave me my full 150Mbps in a speedtest. (stable)

The only change I could think of was the BIOS update, but seeing as none of the other versions seem to fix it, I decided to post here because I have no clue where to look anymore.

I have not had any network issues prior to this.

If I do set the Link Speed to anything higher than 100Mbps Half Duplex and run diagnostics this is the error message:

Connection Status : Failed

This test relies on a response from a

gateway, DNS, DHCP, or WINS server and

no such response was received. Any such

server for this connection may be unavailable

or misconfigured.

This adapter is configured

to obtain an IP address automatically

but no DHCP server is present on the network.

Windows selected an IP address using Alternate

Private IP Addressing.

None of the other diagnostics result in error messages.

0 Kudos
5 Replies
idata
Community Manager
83 Views

Hi M.Bekmann,

 

 

Thank you for contacting Intel.

 

 

I see that you have tried different drivers to address this connection problem. We recommend to use the version supplied to you by Asus*. We are seeing network connectivity issues on Windows* 10 and there are hot fixes released to resolve these issues. In order for us further investigate your issue, please provide us your Windows* 10 version and built.

 

 

We look forward to your reply.

 

 

Sincerely,

 

 

Sandy
MMart32
Beginner
83 Views

I have installed the drivers provided by Asus now, which means I currently have the following versions installed.

- PROSet: 20.1.2019.0

- Driver: 12.12.218.0

I would like to reiterate that the issue was also present while I was still using Windows 7.

Currently using:

Windows 10 Home (64-bit)

Version 1511

OS Build 10586.218

I have also tried manually setting the IPv4 address and disabling IPv6 which lead to no changes.

idata
Community Manager
83 Views

Hi M.Bekmann,

 

 

Thanks for updating us on your test results.

 

 

Please refer to our driver download link below:

 

https://downloadcenter.intel.com/download/22283/Intel-Ethernet-Adapters-Connections-CD?product=71305 https://downloadcenter.intel.com/download/22283/Intel-Ethernet-Adapters-Connections-CD?product=71305

 

 

Here, you can find the hotfixes available for Windows* 10:

 

Windows® 10 Updates May Cause Driver Installation Issues

 

This issue is resolved in Microsoft Hot Fix available after March 8, 2016.

 

https://support.microsoft.com/en-us/kb/3140745 https://support.microsoft.com/en-us/kb/3140745

 

https://support.microsoft.com/en-us/kb/3140743 https://support.microsoft.com/en-us/kb/3140743

 

 

If you continue to encounter limited speed problem, please contact Asus* support. Because you may need to update BIOS or firmware to fix the network adapter problem since you were experiencing the issue also on Windows* 7.

 

 

We'll wait for your further test results.

 

 

 

Sincerely,

 

Sandy
MMart32
Beginner
83 Views

Sorry for my late response, I wanted to see if I could find a solution with asus support/elsewhere.

In case anyone has a similar issue and finds this, I have sadly NOT been able to fix it through software.

What I ended up doing was buying a reasonably cheap Windows 10 compatible USB 3.0 ethernet adapter. It just seemed like the easiest (and cheapest if time/effort is taken into consideration) solution, and I've been enjoying my full internet speed ever since.

idata
Community Manager
83 Views

Hi M.Bekmann,

 

 

Glad to know that you are able to enjoy your internet connection at full speed with the new adapter. Thank you for sharing your workaround here. Have a great day.

 

 

 

Sincerely,

 

Sandy
Reply