Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
4359 Discussions

Poor 1G network performance on 82579V


I have seen multiple posts on the performance of the 82579V chip found on among other the Gigabyte GA-X79-UD3.

I run Win8x64, have 16GB of DDR3 and an intel X25 G2 160GB SSD. I have a Netgear WNDR4500 router that provides 1G, 100M and 10M speeds on 4 ports, Before replacing my motherboard with the UD3 I had an older Nvidia 780i that provided full 1G throughput using its Marvell onboard NIC, now with the UD3 and its 82579V chip my transfer speeds are as low as 200-300KB, while if I only change to 100M in the network driver settings I get the full 100M, well about 98-99Mbps.

I have read about fw update to resolve event 10 errors, no problem I have that fw. Still no change on performance.

I have also read that update to latest fw on the motherboard, I have F11, no change on performance.

I have also read on disabling TCP offloading, EEE etc. All to no avail, same poor performance.

Some even suggested to have a dedicated power Cable and not share a extension plug, well I have a dedicated power cable. No change on performance.

I have installed, tested, rebooted and repeated the driver versions 16, 17, 17.4 and now latest 18.0. No change on slow performance.

Apparently the remedy is to purchase a Realtek chip PCI card, disable the onboard Intel 82579V, and enjoy full 1G throughput. Any other advise before following suite and purchasing a Realtek NIC?

0 Kudos
3 Replies

The only other thing I can think of that might be worth trying is a new Ethernet cable. Have you tried running the cable test in diagnostics to see if the network connection thinks the cable is good or not? If the test shows poor cable quality replacing it might be worth a try even if the old/existing cable worked fine with a previous setup.

Mark H


I have tested two different cables, both Cat5e and not Cat6, however the same cable worked with the Nvidia 780i motherboard. I did however check the cables using the built-in check in the Intel driver and both cables pass the frequency test and score "green" on the test.

As some earlier posts referred to an F7 Gigabyte firmware to have had an impact I wonder how much does the firmware of the mb actually have an affect to network problems vs the quality of the NIC manufacturer's drivers?

Just trying to understand if the issue here is the capability of Gigabyte to keep the NIC stable, or if the NIC drivers are fundamental to the stability/performance, and, sorry to say, I should be looking for another chipset in my next NIC as hinted above?


In an unexpected turn of events Gigabyte support Contacted me suggesting me to upgrade to beta BIOS F12p. I then removed the Realtek NIC, upgraded the BIOS, reconfigured my old BIOS customization (like enabling VT for my virtual environment) etc and restarted. Lo and behold, now I have my full gigabit speed back. So my apologies to Intel for questioning the driver or device capabilities, the issue was actually motherboard BIOS deficiencies corrected in the latest beta BIOS for the GA-X79-UD3 mb.