Ethernet Products
Intel® Ethernet products and technologies
4017 Discussions

Pro 1000GT hardware problem

Community Manager

Hi ! I have a lot of old Dell Optiplex GX1 PIII, BIOS A10 - 500 hz pc's used as routers under linux. This old PC's has one onboard 3C nic and I want to use Pro 1000GT cards as secondsary NIC for the router function. In the bios "everything" not needed is disabled. The problem is that the old Dell PC is not able to detect the Pro 1000GT nic (Part no 098208-007) and the NIC is not detected by Intel Diags v when used in the old optiplex. If I Try these cards in another PC , the cards works ok. I has tried all avalable PCI slots with the same result. There is no other PCI or addin cards. Also different BIOS versions and clearing of BIOS is tried.

I has tried with a Pro 1000MT card ( RC82540EM) (part no 78408-008) in the old Dell and it works perfect and passes all test's with the Diags v

I'm pretty shure the problem is due to compatibility problem with the old Optiplex GX1 computer and the Pro 1000GT card, but I really want to be able to use the Pro 1000GT cards with the old GX1 since I has many of them and they works ok for the job. Is there any way or any utility that can be used to change the IRQ etc etc of the 1000GT card so it can be used with the old Optiplex ??

The Pro 1000MT card when installed in the old optiplex uses there resoures (Diags v (tis works perfect)

IRQ 11

PCI bs no 0

PCI device no 13

Memory address : FF020000

The Pro 1000GT card is not possible to detect in the Optiplex, but when inserted in antother Pc resources are (Diags v

ORQ 11

PCI bus no 2

PCI device no 6

Memory address: FEBE0000

0 Kudos
3 Replies


My best guess is that you are correct about the system compatibility being an issue. However, the MT and GT adapters are similar, so I am a little surprised that one would work and the other does not work.

I don't know what BIOS options you have available that might help you with different system resource allocations. Check might check for a plug and play OS option and try changing the setting. Sometimes you can change the setting for the speed on the PCI or PCI-x bus. You could experiment with different speeds to see if the adapter is detected.

Mark H

Community Manager

Thx for your reply Mark. The bios of the old optiplex is wery limited and has not to many options - there is no plug & play option in the bios. I'm pretty shure that I has tried all bios options :-(

The Pro1000MT card that is working is pretty old and the Pro1000GT card is new ones ( I has tried 10 different new cards of the pro1000gt in four different optiplex GX1 with the same problem)

Maybe it has somthing to do with the PCI bus specification of the cards, old pci 2.0 compared to newer 2.2 ?. From what I can see on the diags report for the two types of cards when used in another pc is the memory resources that the cards claim.

I thought it could be worth a try to flash the bios with a COOREBOOT bios and see if that works but coorebot is new to me and I has not yet got the time to try. coorebot shouls support the old GX1. If there is no utility that makes it possible to change the resources beeing claimed by a pro1000gt card, coreboot will be the last option to try. /Petter

Community Manager

Can the EEUpdate.exe utility be used to try to modify the adapter to act the same way as the MT adapter ?. I found a quite interesting article: It seems to me that it should be possible to do some research and sort out this problem ??