Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
308 Views

Problem in configuring pfc by dcbtool

Hi, I meet two problem when I follow the steps in GitHub project intel/openlldp.

(1) The result of `dcbtool sc enp1s0 dcb on` shows success, but the result of `dcbtool gc enp1s0 dcb` still shows "dcb status: off".

(2) The result of `dcbtool gc enp1s0 pfc` shows "num TC's: 0" instead of "num TC's: 8".

I still find no solution. Please help me fix these problems. Thank you very much!

 

My problems is quite similar to another posted question , which is still unsolved.

https://forums.intel.com/s/question/0D50P0000490QYaSAM/intel-x520t2-dcb-problem

 

Here is debug output of lldpad. It may give some clue.

Screenshot from 2020-02-18 15-40-14.png

0 Kudos
11 Replies
Highlighted
Moderator
36 Views

Hi User15818237624438657467,

Thank you for posting on our Intel® Ethernet Communities page.

We would like to ask if you have posted the same question in the "issues" section of the github openlldp site, which can be found here, https://github.com/intel/openlldp/issues.

Looking forward to your reply. Should we not get your reply, we will follow up after 3 business days.

Best Regards,

Alfred S

Intel® Customer Support

0 Kudos
Highlighted
36 Views

Hi AlfredS,

 

I had posted the same question in the "issues" section of the github openlldp site, but having no response too.

https://github.com/intel/openlldp/issues/42

 

In debug output of lldpad, it does say "Adapter enp1s0 support DCB".

However, next line shows "Error set_hw_state: set_linkmode dcbstate 1". What does it mean and how to fix it?

 

If you need more info, like kernel configuration options, please tell me.

0 Kudos
Highlighted
Moderator
36 Views

Hi User15818237624438657467,

 

Thank you for posting in Intel Ethernet Communities.

 

Please allow us 3 business days to further check on this one.

 

 

Best regards,

Alfred S

Intel Customer Support 

0 Kudos
Highlighted
Moderator
36 Views

Hi User15818237624438657467,

We are still investigating your case.

To aid us, please provide the following information:

  1. Intel network adapter product model, please provide the PBA# if it is a discrete adapter.
  2. Ethtool -i output
  3. Linux OS name and output of uname -r

Looking forward to your reply, Should we not get your reply, we will reach out to you after 3 business days.

 

 

 

Best Regards,

Alfred S

Intel® Customer Support

0 Kudos
Highlighted
36 Views

Hi AlfredS,

 

1.Intel network adapter product model, please provide the PBA# if it is a discrete adapter.

Intel ® 82599 10 GbE Controller

2. Ethtool -i output

Screenshot from 2020-02-20 16-02-12.png

3. Linux OS name and output of uname -r

Screenshot from 2020-02-20 16-05-11.png

Screenshot from 2020-02-20 16-06-02.png

 

0 Kudos
Highlighted
Moderator
36 Views

Hi User15818237624438657467,

We appreciate the time that you took out of your busy schedule to share that information.

We will continue investigating your concern, and we will give you an update no later than 3 business days from now.

We may need to ask for more information during the investigation process.

 

 

Best Regards,

Alfred S

Intel® Customer Support

0 Kudos
Highlighted
36 Views

Hi AlfredS,

It seems that other feature settings, like ` dcbtool sc enp1s0 pfc pfcup:00010000`, is successfully set and only `dcbtool sc enp1s0 dcb on` fails.

This info may provide you more clues.​

0 Kudos
Highlighted
Moderator
36 Views

Hi User15818237624438657467,

Thank you for the additional information that you have shared.

We are still looking at your concern, and we will give you an update no later than 3 business days from now.

 

 

Best Regards,

Alfred S

Intel® Customer Support 

0 Kudos
Highlighted
36 Views

Hi AlfredS,

 

The problem is solved by the contributor of openllpd project.

The solution can be found in the issue section of it.

https://github.com/intel/openlldp/issues/42

0 Kudos
Highlighted
36 Views

Hi User15818237624438657467,

 

Thank you for the update and we highly appreciate your effort in sharing the issue resolution.

 

Since the problem was now solved, please be advised that we will now close this request. If you may have any other inquiry in the future, feel free to post a new question and we will be glad to be of help.

 

May you have a lovely day!

 

Best Regards,

Crisselle C

Intel® Customer Support 

0 Kudos
Highlighted
36 Views

OK, this request could be closed.

0 Kudos