Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JClem4
Beginner
1,061 Views

Problems with newly installed Intel Gigabit CT Desktop Adapter

I recently purchased and installed an Intel Gigabit CT Desktop Adapter (PCI-E, 1x channel) in my desktop machine. The problem I'm having is with downloading files of any substantial size (say, above 2 MB). For example, when using IE11, the download message says "download was interrupted" or "file was interrupted" - and multiple retries never succeeds.

When I temporarily enable a wireless adapter (and disable the intel CT connection) on the desktop, the file downloads just fine. For other reasons, the wireless adapter is not a long term solution - which is why I purchased the wired CT desktop adapter.

Drivers are up-to-date: (Intel, 5/26/2015, 12.7.28.0) - In fact, I had to download the driver package from Intel using the wireless connection because of the problems mentioned above with using the CT adapter.

Also - when running the hardware diagnostics, the loopback test fails - all others pass.

Is this a hardware issue?

Thanks!

Tags (1)
0 Kudos
9 Replies
JClem4
Beginner
93 Views

Ah - should have mentioned - running Windows 7 Pro 64-bit

AP16
Valued Contributor III
93 Views

From elevated command line (run as administrator) enter netsh int tcp show global , show us result

JClem4
Beginner
93 Views

Here's what I get:

D:\Windows\system32>netsh int tcp show global

 

Querying active state...

TCP Global Parameters

 

----------------------------------------------

 

Receive-Side Scaling State : enabled

 

Chimney Offload State : automatic

 

NetDMA State : enabled

 

Direct Cache Acess (DCA) : disabled

 

Receive Window Auto-Tuning Level : normal

 

Add-On Congestion Control Provider : none

 

ECN Capability : disabled

 

RFC 1323 Timestamps : enabled

 

** The above autotuninglevel setting is the result of Windows Scaling heuristics

 

overriding any local/policy configuration on at least one profile.
AP16
Valued Contributor III
93 Views

netsh int tcp set global rss=disabled

netsh int tcp set global chimney=disabled

netsh int tcp set global netdma=disabled

Then reboot PC and try.

JClem4
Beginner
93 Views

Unfortunately, same behavior.

Just to verify, here are the settings after the recommended changes and a reboot:

D:\Windows\system32>netsh int tcp show global

 

Querying active state...

TCP Global Parameters

 

----------------------------------------------

 

Receive-Side Scaling State : disabled

 

Chimney Offload State : disabled

 

NetDMA State : disabled

 

Direct Cache Acess (DCA) : disabled

 

Receive Window Auto-Tuning Level : normal

 

Add-On Congestion Control Provider : none

 

ECN Capability : disabled

 

RFC 1323 Timestamps : enabled

 

** The above autotuninglevel setting is the result of Windows Scaling heuristics

 

overriding any local/policy configuration on at least one profile.
AP16
Valued Contributor III
93 Views

Please provide screenshoot of 'Advanced' properties tab of NIC properties in device manager.

JClem4
Beginner
93 Views

There are several settings available on this tab - is the one (or more) in particular to view?

JClem4
Beginner
93 Views

New info: after a few days of debugging, here's what I've learned:

  • I installed a new NIC - same make/model as previous: Intel Gigabit CT Desktop Adapter (PCI-E, 1x channel). No change in behavior - so I can at least rule this out this HW as a failure point. Curious that this NIC also fails the loopback test - but perhaps I'm not running that test correctly (i.e. I leave it connected to the router).
  • Downloading large files (>5MB) works fine with FTP - the problem appears to be with HTTP downloads only
  • Behavior is the same with IE (v11) and Firefox (40.0.3) browsers - FTP files download with no problem - HTTP downloads are either interrupted, or when they download they are corrupt (invalid signature and/or CRC error)
  • Ran a memory test (Windows Memory Diagnostic) on the desktop - no errors

Hoping these clues leads someone to a possible cause (and fix!).

Thx

 

AP16
Valued Contributor III
93 Views

Its look like trouble is in border router. Try to connect directly to provider outlet, if possible, switching off router for an hour (to cool and reboot) is also a good idea.