Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,950 Views

RSS could not be enabled on Intel 82599 under Linux 2.6.27.18, driver version 2.0.44.14-NAPI

Hi,

Has someone ever tried to install an intel 82599(driver version 2.0.44.14-NAPI) under Linux 2.6.27.18?

Intel 82599 driver's readme indicates that MultiQueue is always enabled, but we found it unable to be enabled even by "modprobe ixgbe MQ=1 RSS=1"

Linux will claim the following msgs when the ixgbe driver inserted, firstly MQ enabled automatically, then RSS disabled and finally MQ disabled too caused by ixgbe_init_interrupt_scheme().

ixgbe: Multiple Queue Support Enabled

ixgbe: 0000:05:00.0: ixgbe_check_options: RSS is not supported on this hardware. Disabling RSS.

…..

ixgbe: 0000:05:00.0: ixgbe_init_interrupt_scheme: Multiqueue Disabled: Rx Queue count = 1, Tx Queue count = 1

Related logs attached. Are there any kernel/driver building options we missed at building time?

Thanks in advance if someone can give a reply!!

Following is the log:

mailto:root@localhost root@localhost:~# uname -a

 

Linux localhost 2.6.27.18-grsec # 1 SMP PREEMPT Fri Jan 29 15:36:22 HKT 2010 x86_64 x86_64 x86_64 GNU/Linux

 

mailto:root@localhost root@localhost:~# lsmod

 

Module Size Used by

 

ixgbe 164016 0

 

x_tables 27922 2 ip_tables,ip6_tables

 

ip6_tables 24241 0

 

ip_tables 22622 0

 

sctp 196917 2

mailto:root@localhost root@localhost:~# modprobe ixgbe InterruptType=2,2 MQ=1,1 RSS=2,2

 

ixgbe: Intel(R) 10 Gigabit PCI Express Network Driver - version 2.0.44.14-NAPI

 

Copyright (c) 1999-2009 Intel Corporation.

 

ixgbe 0000:05:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16

 

ixgbe 0000:05:00.0: enabling bus mastering

 

ixgbe 0000:05:00.0: setting latency timer to 64

 

ixgbe: Interrupt Type set to 2

 

ixgbe: Multiple Queue Support Enabled

 

ixgbe: Receive-Side Scaling (RSS) set to 2

 

ixgbe: 0000:05:00.0: ixgbe_check_options: RSS is not supported on this hardware. Disabling RSS.

 

ixgbe: 0000:05:00.0: ixgbe_check_options: Flow Director hash filtering enabled

 

ixgbe: 0000:05:00.0: ixgbe_check_options: Flow Director allocated 64kB of packet buffer

 

ixgbe: 0000:05:00.0: ixgbe_check_options: ATR Tx Packet sample rate set to default of 20

 

ixgbe: 0000:05:00.0: ixgbe_init_interrupt_scheme: Multiqueue Disabled: Rx Queue count = 1, Tx Queue count = 1

 

ixgbe: eth0: ixgbe_probe: (PCI Express:5.0Gb/s:Width x8) <6>udev: renamed network interface eth0 to fabric1

 

00:01:af:2e:bf:3e

 

ixgbe: fabric1: ixgbe_probe: MAC: 2, PHY: 1, PBA No: ffffff-0ff

 

ADDRCONF(NETDEV_UP): fabric1: link is not ready

 

ixgbe: fabric1: ixgbe_watchdog_task: NIC Link is Up 10 Gbps, Flow Control: RX/TX

 

ADDRCONF(NETDEV_CHANGE): fabric1: link becomes ready

 

ixgbe: fabric1: ixgbe_probe: LRO is disabled

 

ixgbe: fabric1: ixgbe_probe: HW RSC is enabled

 

ixgbe: fabric1: ixgbe_probe: Intel(R) 10 Gigabit Network Connection

 

ixgbe 0000:05:00.1: PCI INT B -> GSI 17 (level, low) -> IRQ 17

 

ixgbe 0000:05:00.1: enabling bus mastering

 

ixgbe 0000:05:00.1: setting latency timer to 64

 

ixgbe: Interrupt Type set to 2

 

ixgbe: Multiple Queue Support Enabled

 

ixgbe: Receive-Side Scaling (RSS) set to 2

 

ixgbe: 0000:05:00.1: ixgbe_check_options: RSS is not supported on this hardware. Disabling RSS.

 

ixgbe: 0000:05:00.1: ixgbe_check_options: Flow Director hash filtering enabled

 

ixgbe: 0000:05:00.1: ixgbe_check_options: Flow Director allocated 64kB of packet buffer

 

ixgbe: 0000:05:00.1: ixgbe_check_options: ATR Tx Packet sample rate set to default of 20

 

ixgbe: 0000:05:00.1: ixgbe_init_interrupt_scheme: Multiqueue Disabled: Rx Queue count = 1, Tx Queue count = 1

 

ixgbe: eth0: ixgbe_probe: (PCI Express:5.0Gb/s:Width x8) 00:01:af:2e:bf:3f

 

ixgbe: eth0: ixgbe_probe: MAC: 2, PHY: 1, PBA No: ffffff-0ff

 

ixgbe: eth0: ixgbe_probe: LRO is disabled

 

ixgbe: eth0: ixgbe_probe: HW RSC is enabled

 

ixgbe: eth0: ixgbe_probe: Intel(R) 10 Gigabit Network Connection

 

mailto:root@localhost root@localhost:~# udev: renamed network interface eth0 to fabric2

 

ADDRCONF(NETDEV_UP): fabric2: link is not ready

 

fabric1: no IPv6 routers present

 

mailto:root@localhost root@localhost:~# modinfo ixgbe

 

filename: /lib/modules/2.6.27.18-grsec/kernel/drivers/net/ixgbe/ixgbe.ko

 

version: 2.0.44.14-NAPI

 

license: GPL

 

description: Intel(R) 10 Gigabit PCI Express Network Driver

 

author: Intel Corporation, <<a href="mailto:linux.nics@intel.com">linux.nics@intel.com<...
3 Replies
idata
Community Manager
160 Views

From the readme file of ixgbe driver

"

RSS - Receive Side Scaling (or multiple queues for receives)

------------------------------------------------------------

Valid Range: 0 - 16

0 = disables RSS

1 = enables RSS and sets the descriptor queue count to 16 or the number of

online cpus, whichever is less.

2-16 = enables RSS, with 2-16 queues

Default Value: 1

RSS also effects the number of transmit queues allocated on 2.6.23 and

newer kernels with CONFIG_NETDEVICES_MULTIQUEUE set in the kernel .config file.

CONFIG_NETDEVICES_MULTIQUEUE only exists from 2.6.23 to 2.6.26. Other options

enable multiqueue in 2.6.27 and newer kernels."

Does someone know what "Other options" should I enable to make multiqueue work in a 2.6.27.18 kernel? Thanks.

JOHN_R_Intel1
Employee
160 Views

My guess is that the preempt kernel that is being used is not using MSI-X interrupts. If you look in the trace there is an error message that things are being disabled due to the interrupt type. So pick a normal kernel and things should work for you. You can verify if MSI-X interrupts are not being used by doing a 'cat /proc/interrupts'.

idata
Community Manager
160 Views

John

Thanks so much of your quick reply!!

Maybe my issue is caused by the IRQ routing mode of my Board/Linux? If yes, there must be some kernel options I did not configure properly to enable MSI-X in tylersburg?

Best Regards,

Ocean

Reply