Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DKris4
Beginner
2,211 Views

Re: Ethernet driver ubuntu 14.04 - Ethnernet controller I219-LM on Dell Optiplex 7050

Hello Vince!

I am trying to install Intel Ethernet Connection (5) I219-LM in my Dell Optiplex 7050 with Ubuntu 14.04. I tried the ways mentioned in the above steps, and the build went through. Unfortunately, the driver was not installed properly. I couldn't find the drivers in the driver folder. Please let me know what to do further.

Thanks & Regards,

 

Dileep
Tags (1)
0 Kudos
6 Replies
idata
Community Manager
139 Views

Hi Dileep-krishnan,

Thank you for posting in Wired Communities. Have you tried contacting Dell* support for the customized driver? What is the out put of the ethtool -i command?

Thanks,

 

Sharon

 

LJin3
Beginner
139 Views

I have the same issue here. So I downloaded the driver and did make install. It compiles fine but I didn't see NIC gets detected from dmsg.

ljin@li-Tower-3620-14:~/Downloads/igb-5.3.5.4/src$ uname -a

Linux li-Tower-3620-14 3.13.0-32-generic # 57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

ljin@li-Tower-3620-14:~/Downloads/igb-5.3.5.4/src$ dmesg | tail

[36192.577111] perf samples too long (2524 > 2500), lowering kernel.perf_event_max_sample_rate to 50000

[60863.231197] Intel(R) Gigabit Ethernet Network Driver - version 5.3.5.4

[60863.231203] Copyright (c) 2007-2015 Intel Corporation.

ljin@li-Tower-3620-14:~/Downloads/igb-5.3.5.4/src$ lsmod | grep igb

igb 194328 0

ptp 18933 1 igb

dca 15130 1 igb

ljin@li-Tower-3620-14:~/Downloads/igb-5.3.5.4/src$ inxi -SNxz

System: Host: li-Tower-3620-14 Kernel: 3.13.0-32-generic x86_64 (64 bit, gcc: 4.8.2)

Desktop: Gnome Distro: Ubuntu 14.04 trusty

Network: Card-1: Intel Ethernet Connection (2) I219-LM bus-ID: 00:1f.6

Card-2: MosChip MCS7830 10/100 Mbps Ethernet adapter driver: MOSCHIP usb-ethernet driver usb-ID: 001-003

BTW since the interface doesn't show up, I can't use ethtool to dump out the information. I traced the code a bit and found the probe function is not called.

Li

idata
Community Manager
139 Views

Hi LiJin,

 

 

Thank you for sharing the information.

 

 

Regards,

 

Sharon

 

DKris4
Beginner
139 Views

Dear LiJin,

Thanks for the driver. It works now.

Thanks & Regards,

 

Dileep Krishnan
DKris4
Beginner
139 Views

I tried contacting Dell support, but, since it is Ubuntu, they told they don't support queries regarding open Source software. When I tried ethtool -i command, it is asking to install ethtool first.

Thanks & Regards,

 

Dileep
Reply