Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CSwin
Beginner
2,026 Views

Re: Intel i219-V No Internet on Wake from Sleep - The network driver has been stopped because the network adapter has been removed.

FWIW, I to have this issue, I don't want to hijack these thread but I thought it pertinent to outline issues here too. I wanted to search for "Intel(R) Ethernet Connection I219-V" and this was the second on the list

However, my setup is somewhat different:

Laptop - HP EliteBook 1040 G3

BIOS update (01.08) - latest

Windows 10 64 bit, build 14955

Tried Driver version 12.13.17.7 (13/08/2015) and the latest Version 21.1 (September 28, 2016),

With the same issue. When the laptop is completely shutdown power off), then started from cold, the Ethernet NIC will detect a link of 1Gbs immediately and connect with no issue.

As son as the laptop is put to sleep, then woken up, the NIC will only say the link is 10Mbps, but not actually connect properly and pickup and IP address.

I have tried to disconnect the Ethernet cable, disable/re-enable the adaptor, it hasn't resolved the issue. Only a full shut down will cure the problem. .

Any further thoughts beyond what you have said above.

0 Kudos
16 Replies
idata
Community Manager
500 Views

HI Swinster,

 

 

Have you tried adjust the power management setting see if this will make any difference?

 

 

rgds,

 

wb

 

CSwin
Beginner
500 Views

When you say Power Management settings, can you be more specific? Do you mean the Power Management setting of the NIC, or of the PC? In each case there are a number of possible options, which options should be adjusted specifically?

I should also note that after a reboot (with the latest driver) you get the opportunity to run different NIC tests, on the Connection, Cable and Hardware. All of these pass at all levels. After a wake from sleep however, when you run the test, you are informed that the device needs to be restarted, and the test fail. The only way I have found out how to do this is to reboot the machine.

CSwin
Beginner
500 Views

I will qualify the Diagnostic Test failures:

  • On the Connection tab, obviously the Status fails (as no IP is assigned to the NIC), but also the Cable link status has failed saying the device need to be restarted.
  • In the Hardware tab, the loop back fails.
idata
Community Manager
500 Views

Hi Swinster,

 

 

Thank you for the reply. You can try change the power settings for a network adapter by going to the Properties of the network adapter, click the Power Management tab, try to check or un-check the "Allow the computer to turn off this device to save power check box. "

 

 

If you are connecting this laptop to a wireless router, another thing you can try is to change the channel of wireless router to non-overlapping channels.

 

 

Have you contacted HP* support as well? As there was instance in which HP* provided utility and fixed a disconnection issue, I am not sure if this is applicable in your case but it is recommended to contact the HP* as this is an onboard NIC on their system. http://www.intel.com/content/www/us/en/support/network-and-i-o/ethernet-products/000006628.html?wapk...

 

 

Hope the above helps.

 

 

rgds,

 

wb

 

CSwin
Beginner
500 Views

Hi WB,

The drivers that were installed installed (12.13.17.7 - 13/08/2015, or 12.15.23.7 - 04/08/2016; the latter apparently being the version noted as 21.1 from your site : https://downloadcenter.intel.com/download/25016/Intel-Network-Adapter-Driver-for-Windows-10?product=... Download Intel® Network Adapter Driver for Windows® 10 - the 64 bit driver), do not show the normal WIndows Power Managment options. In other words there is NO "Allow the computer to turn off this device to save power check box. "

Instead, we see the following: (two screenshot show all options here):.

As mentioned, this is an Ethernet wired issue, not a Wireless issue, so changing wireless channels is irrelevant.

Contacting Intel in no my list, but sometimes is good to go straight to the source.

idata
Community Manager
500 Views

Hi Swinster,

 

 

Thank you for the reply. Version 21.1 is the PRoset software version, the driver version will still be the one appear in the driver tab of your device manager.

 

 

I understand you are using a wired connection, the reason I asked you to change the channel on the wireless router is using non-overlapping channel on the wireless will have less interference on the wired connection.

 

 

rgds,

 

wb

 

CSwin
Beginner
500 Views

Hi WB,

Thanks. Please accept my confusion over you suggestions regarding wireless interference or wired networks. This is the first time I have really ever come across such a suggestion. I personally think you are reaching and this is not an issue. Be aware that the Ethernet device will work flawlessly from boot, it is only after a sleep is there an issue with diagnostic showing that it needs to be reset.

I also wonder if you could answer the question with regard to Power Management settings given the standard Windows options are replace with Intel customer driver settings?

Cheers

idata
Community Manager
500 Views

Hi Swinster,

 

 

Thank you for the reply. I sent a private message to you.

 

 

rgds,

 

wb

 

idata
Community Manager
500 Views

Hi Swinster,

 

 

Did some testing and we did not encountered said issue on our I219-V. Tried using default driver from Microsoft or Intel driver version 12.15.23.7 (From CD_driver 21.1 on our downloadcenter), no issue.

 

 

The power Saver option in our Power Management options are all checked excepts:

 

Reduce link speed during system idle

 

 

Wake on Lan options are all checked, except for the Wake on Link Setting

 

 

You may give the above options a try, but if this does not work, please contact HP* the notebook vendor for the driver that suits the system.

 

 

thanks,

 

wb

 

CSwin
Beginner
500 Views

Thanks WB for your efforts. As you are not able to replicate the issue, what additional logging would you like me to provide this end?

idata
Community Manager
500 Views

Hi Swinster,

 

 

Thank you for the reply. Can you check with HP* if they can have any information to provide or assist. Please feel free to update me.

 

 

rgds

 

wb

 

idata
Community Manager
500 Views

HI Swinster,

 

 

Please feel free to update me.Thanks.

 

 

rgds,

 

wb

 

CSwin
Beginner
500 Views

HI WB,

Sorry for the delay. For me, I made a few changes and this has seemingly fixed the issue. Uninstalling the latest Intel drivers seemed to have helped, although I'm also running fast ring Windows Insider releases, so updating things here might have fixed the issue. FYI, I also remove the standard Intel Wi-Fi driver.

Current Driver versions:

Intel(R) Ethernet Connection I219-V: 12.13.17.7

Intel(R) Dual Band Wireless-AC 8260: 19.1.0.4

idata
Community Manager
500 Views

Hi Swinster,

 

 

Thank you for the update and good to know the issue has seemingly fixed. So any further assistance needed?

 

 

rgds,

 

wb

 

CSwin
Beginner
500 Views

I think I'm good. Cheers for your time.

idata
Community Manager
500 Views

Hi Swinster,

 

 

Appreciate your time and sharing the information as well.

 

rgds,

 

wb
Reply