Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4626 Discussions

SR-IOV Virtual function not working ( no /sys/class/net/IFNAME/device/sriov_numvfs ) , but direct pci passthrough works fine



I Have some servers with both X710 and 82599ES

I can use 82599ES perfectly, ( both pci and virtual )


But on X710 card, I can only use full pci passthrough


There is no /sys/class/net/IFNAME/device/sriov_numvfs


Here is my lspci


43:00.1 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 01)

Subsystem: Intel Corporation Ethernet Converged Network Adapter X710

Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+

Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

Latency: 0, Cache Line Size: 64 bytes

Interrupt: pin A routed to IRQ 45

Region 0: Memory at f7000000 (64-bit, prefetchable) [size=16M]

Region 3: Memory at f5ff8000 (64-bit, prefetchable) [size=32K]

Expansion ROM at fb180000 [disabled] [size=512K]

Capabilities: [40] Power Management version 3

Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)

Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=1 PME-

Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+

Address: 0000000000000000 Data: 0000

Masking: 00000000 Pending: 00000000

Capabilities: [70] MSI-X: Enable+ Count=129 Masked-

Vector table: BAR=3 offset=00000000

PBA: BAR=3 offset=00001000

Capabilities: [a0] Express (v2) Endpoint, MSI 00

DevCap: MaxPayload 2048 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us

ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset+ SlotPowerLimit 0.000W

DevCtl: Report errors: Correctable- Non-Fatal+ Fatal+ Unsupported+

RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop- FLReset-

MaxPayload 256 bytes, MaxReadReq 512 bytes

DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr- TransPend-

LnkCap: Port #0, Speed 8GT/s, Width x8, ASPM L1, Exit Latency L0s <2us, L1 <16us

ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp+

LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk+

ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-

LnkSta: Speed 5GT/s, Width x8, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-

DevCap2: Completion Timeout: Range ABCD, TimeoutDis+, LTR-, OBFF Not Supported

DevCtl2: Completion Timeout: 65ms to 210ms, TimeoutDis-, LTR-, OBFF Disabled

LnkSta2: Current De-emphasis Level: -3.5dB, EqualizationComplete-, EqualizationPhase1-

EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-

Capabilities: [e0] Vital Product Data

Product Name: X710 10GbE Controller

Read-only fields:

[V0] Vendor specific: FFV18.0.17

[PN] Part number: 5N7Y5

[MN] Manufacture ID: 31 30 32 38

[V1] Vendor specific: DSV1028VPDR.VER2.0

[V3] Vendor specific: DTINIC


[V5] Vendor specific: NPY2

[V6] Vendor specific: PMT7

[V7] Vendor specific: NMVIntel Corp

[V8] Vendor specific: L1D0

[RV] Reserved: checksum good, 1 byte(s) reserved

Read/write fields:

[Y1] System specific: CCF1


Capabilities: [100 v2] Advanced Error Reporting

UESta: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-

UEMsk: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt+ UnxCmplt+ RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-

UESvrt: DLP+ SDES+ TLP+ FCP+ CmpltTO+ CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC+ UnsupReq- ACSViol-

CESta: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-

CEMsk: RxErr+ BadTLP+ BadDLLP+ Rollover+ Timeout+ NonFatalErr+

AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-

Capabilities: [140 v1] Device Serial Number 40-5b-2d-ff-ff-fe-fd-3c

Capabilities: [150 v1] Alternative Routing-ID Interpretation (ARI)

ARICap: MFVC- ACS-, Next Function: 0

ARICtl: MFVC- ACS-, Function Group: 0

Capabilities: [1a0 v1] Transaction Processing Hints

Device specific mode supported

No steering table available

Capabilities: [1b0 v1] Access Control Services

ACSCap: SrcValid- TransBlk- ReqRedir- CmpltRedir- UpstreamFwd- EgressCtrl- DirectTrans-

ACSCtl: SrcValid- TransBlk- ReqRedir- CmpltRedir- UpstreamFwd- EgressCtrl- DirectTrans-

Kernel driver in use: i40e

Kernel modules: i40e


0 Kudos
5 Replies
Hello FYama, Thank you for posting in Intel Ethernet Communities. Please provide the markings from the product label so we can identify the adapter. Please provide "ethtool -i <interface>" and "ethtool -k <interface>". Please also provide "ethtool -i <interface>" from the VM. Let us know if you have any other questions. Best regards, Daniel D Intel Customer Support Under Contract to Intel Corporation
0 Kudos



Here it is:


# ethtool -i enp67s0f1

driver: i40e

version: 2.1.14-k

firmware-version: 5.40 0x80002d35 18.0.17


bus-info: 0000:43:00.1

supports-statistics: yes

supports-test: yes

supports-eeprom-access: yes

supports-register-dump: yes

supports-priv-flags: yes


# ethtool -k enp67s0f1

ethtool -k enp67s0f1

Features for enp67s0f1:

rx-checksumming: on

tx-checksumming: on

tx-checksum-ipv4: on

tx-checksum-ip-generic: off [fixed]

tx-checksum-ipv6: on

tx-checksum-fcoe-crc: off [fixed]

tx-checksum-sctp: on

scatter-gather: on

tx-scatter-gather: on

tx-scatter-gather-fraglist: off [fixed]

tcp-segmentation-offload: on

tx-tcp-segmentation: on

tx-tcp-ecn-segmentation: on

tx-tcp-mangleid-segmentation: off

tx-tcp6-segmentation: on

udp-fragmentation-offload: off

generic-segmentation-offload: on

generic-receive-offload: on

large-receive-offload: off [fixed]

rx-vlan-offload: on

tx-vlan-offload: on

ntuple-filters: off

receive-hashing: on

highdma: on

rx-vlan-filter: on [fixed]

vlan-challenged: off [fixed]

tx-lockless: off [fixed]

netns-local: off [fixed]

tx-gso-robust: off [fixed]

tx-fcoe-segmentation: off [fixed]

tx-gre-segmentation: on

tx-gre-csum-segmentation: on

tx-ipxip4-segmentation: off [fixed]

tx-ipxip6-segmentation: off [fixed]

tx-udp_tnl-segmentation: on

tx-udp_tnl-csum-segmentation: on

tx-gso-partial: on

tx-sctp-segmentation: off [fixed]

tx-esp-segmentation: off [fixed]

fcoe-mtu: off [fixed]

tx-nocache-copy: off

loopback: off [fixed]

rx-fcs: off [fixed]

rx-all: off [fixed]

tx-vlan-stag-hw-insert: off [fixed]

rx-vlan-stag-hw-parse: off [fixed]

rx-vlan-stag-filter: off [fixed]

l2-fwd-offload: off [fixed]

hw-tc-offload: off

esp-hw-offload: off [fixed]

esp-tx-csum-hw-offload: off [fixed]

rx-udp_tunnel-port-offload: on




0 Kudos
Hello FYama, Thank you for the reply. Have you only tried the in-kernel version of the driver, or have you tried the latest i40e? Are you using KVM, and are you using a virtual API, or hardware emulator? What does the VF do when SR-IOV is enabled? Is there a VF driver on the VM? Please check with the OEM if there is a firmware update, as this appears to be a non-retail Intel version of the adapter. Let us know if you have any questions. Best regards, Daniel D Intel Customer Support Under Contract to Intel Corporation
0 Kudos
Hello FYama, Please let us know if a firmware update from the OEM helped you solve this issue. If you have any other questions please let us know. Best regards, Daniel D Intel Customer Support Under Contract to Intel Corporation
0 Kudos
Hi FYama, Please let us know if there's other assistance needed. Best Regards, Vince T. Intel Customer Support Under Contract to Intel Corporation
0 Kudos