Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4872 Discussions

Slow NIC speeds with 82574L Gigabit on Ubuntu


I am really stuck here. I am not a extremely knowledgeable person when it comes to networking but I can usually work with Google to find my solutions. This time I have tried everything and I cannot fix my problem.

I have a SuperMicro server running BackupPC by night and file sharing by day on Ubuntu 10.04LTS 64bit. I noticed that that fastest transfer rates I get with BackupPC is 23Meg\Sec. That is BackupPC using rsync at night with no other activity on the network. This servers, MACs and Windows, are on the same vlan and they are all plugged into the same Gigabit Cisco layer 3 switch. I checked all the ports on the switch and they are at 1000 so I should be able to achieve a much higher through put then 23Meg\Sec.

In addition, I have setup a Samba file share for file sharing and it only gets 23Meg/Sec. This is file sharing between a WinXp to Ubuntu or on a MAC 10.6 to the Ubuntu server. This server is suppose to be used for our video files so I really need the full speed of Gigabit.

Now on the same network, I have a few machines that also have Gigabit cards so I plugged them into the same switch on the same vlan to verify that I can get more speed. They transfer at 78Meg/Sec which much better when I am shoveling 1.3T of data at night.

I have already updated the drivers for the NIC and I have not received any speed improvements. I an really thinking this is a hardware problem with the card because it does not matter is am using Samba or rsync. I never get any higher speeds that 23Meg\Sec.

When I watch the transfer it always goes very fast until about 700-800 Meg. Once it hits that transfer amount it halts and then when it resumes, I slows down dramatically.

Please any help would be appreciated.

Thank you!!!

3 Replies

I am also having a similar issue, except my main OS is FreeBSD 7.3. I have tried using Ubuntu 11.04, which did not rectify my situation. I was wondering if anything has changed, be it replacing your cards, upgrading your OS, or if your problem has just gone away. I also feel that it's a hardware problem and after weeks of troubleshooting, to no avail, I'm tempted to RMA it. The following is my post, located at /message/134451# 134451 134451

I purchased a PWLA8391GT NIC recently to use in a NAS to improve my performance.

My set-up is as follows: ASUS M4N68T-M VS Motherboard, AMD Athlon II X2 215 Processor and the OS is FreeNAS 0.7.2 Sabanda (revision 6567) running on FreeBSD 7.3-RELEASE-p6 (revision 199506). I installed the card and used iperf to test raw TCP speed between my clients on the network.

When using iperf, with my client computer sending data to the server, I am getting an average speed of over 850 Mbps with a total transfer of 1.02GB in 10 seconds. However when sending data from my server to my computer, it is apparently limited to only 319 Mbps transfering 382 MBps. I downloaded the kernel off the support site, removed the old one and compiled the new one with no difference in speed or performance. If I use two client computers with iperf, not going through the server, I can get full speed (meaning it's the NIC causing fault, not a switch or computer on the network). It appears to be the card's upload speed, limited by hardware, not software/drivers.

If anyone can help, it would be greatly appreciated! Thank you!

UPDATE: I comiplied the driver and found no difference in performance or speed, most likely it's a hardware issue, either caused by the card or motherboard.


- post removed because the slow network speed turned out to be caused by the switch, not the nic -

See attached screenshot. This is what I get with the "Intel EXPI9301CT PRO/1000 CT Desktop Gigabit PCI-e (82574L)" after changing the switch.

0 Kudos
Super User
0 Kudos