Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,804 Views

VF MAC is not assigned as expected

Hi,

My server is running RedHat 7.1.

ixgbe - 4.0.1-k-rh7.1

ixgbevf: 2.12.1-k

igb:5.2.13-k

igbvf: 2.0.2-k

I want to assign the fix MAC to VF, so I configure like this

# cat /etc/rc.d/rc.local

echo 1 > /sys/class/net/bi0/device/sriov_numvfs

ip link set bi0 vf 0 mac 00:6f:2a:01:b0:00

echo 1 > /sys/class/net/fi0/device/sriov_numvfs

ip link set fi0 vf 0 mac 00:6f:2a:01:f0:00

While after system reboot, the MAC of VF fi0 is not expected. (The VFs are loaded in Host OS.)

# ip link show

1: lo: mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT

link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

2: fi0: mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:24 brd ff:ff:ff:ff:ff:ff

vf 0 MAC 00:6f:2a:01:f0:00, spoof checking on, link-state auto

3: fi1: mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:25 brd ff:ff:ff:ff:ff:ff

vf 0 MAC 00:6f:2a:01:f1:00, spoof checking on, link-state auto

4: mgmt0: mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:22 brd ff:ff:ff:ff:ff:ff

5: mgmt1: mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:23 brd ff:ff:ff:ff:ff:ff

6: bi0: mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:20 brd ff:ff:ff:ff:ff:ff

vf 0 MAC 00:6f:2a:01:b0:00, spoof checking on, link-state auto

7: bi1: mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:21 brd ff:ff:ff:ff:ff:ff

vf 0 MAC 00:6f:2a:01:b1:00, spoof checking on, link-state auto

8: bi0_vf0: mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000

link/ether 00:6f:2a:01:b0:00 brd ff:ff:ff:ff:ff:ff

9: bi1_vf1: mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000

link/ether 86:56:ec:3e:7f:8f brd ff:ff:ff:ff:ff:ff

10: fi0_vf0: mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000

link/ether f2:35:76:f5:02:82 brd ff:ff:ff:ff:ff:ff

11: virbr0: mtu 1500 qdisc noqueue state DOWN mode DEFAULT

link/ether 52:54:00:45:b8:12 brd ff:ff:ff:ff:ff:ff

12: fi1_vf0: mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000

link/ether 2a:9a:2e:0b:45:88 brd ff:ff:ff:ff:ff:ff

13: virbr0-nic: mtu 1500 qdisc pfifo_fast master virbr0 state DOWN mode DEFAULT qlen 500

link/ether 52:54:00:45:b8:12 brd ff:ff:ff:ff:ff:ff

Do you have any idea?

Br, Nicole

0 Kudos
9 Replies
idata
Community Manager
36 Views

Hi,

The adapters are:

bi0 - Ethernet controller: Intel Corporation 82576 Gigabit Network Connection (rev 01)

fi0 - Ethernet controller: Intel Corporation 82599EB 10-Gigabit KX4 Network Connection (rev 01)

Br, Nicole

st4
New Contributor III
36 Views

Hi Nicole,

Thank you for the post. I will check on this.

rgds

wb

st4
New Contributor III
36 Views

Hi Nicole.Z,

Please provide Linux Host kernel log and VM (Guest) Linux kernel Log. The Linux kernel log can be found at /var/log/messages.

Looking forward to your reply.

Thanks,

wb

idata
Community Manager
36 Views

Hi,

Sorry for the late response.

Actually there is no VM is running. The VF interfaces are loaded in host OS.

Attached the /var/log/messages.

Br, Nicole

st4
New Contributor III
36 Views

Hi Nicole.Z

Thank you for the info. We will check on this.

rgds,

wb

 

SharonT_t_Intel
Employee
36 Views

Hi Nicole.Z

Further checking ,the adminstrator set VF MAC address then later on Network Manager tried to set VF MAC address that was disallowed then VF has to be reset. Since Intel PF and VF drivers has a built in security feature called administrative assignment of VF MAC address. If the server administrator assigns a VF MAC address from the HOST any subsequent changes to the VF MAC address are disallowed.

Thus please try disabling the network manager.

rgds,

wb

idata
Community Manager
36 Views

Hi,

I tried to disable NetworkManager, but after reboot the VFs never boot up, and MAC are still unexpected. Tried to restart network service, it didn't help.

# systemctl status NetworkManager ! !

NetworkManager.service - Network Manager

Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; disabled)

Active: inactive (dead)

# ip link show

1: lo: mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT

link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

2: fi0: mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:24 brd ff:ff:ff:ff:ff:ff

vf 0 MAC 00:6f:2a:01:f0:00, spoof checking on, link-state auto

3: fi1: mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:25 brd ff:ff:ff:ff:ff:ff

4: mgmt0: mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:22 brd ff:ff:ff:ff:ff:ff

5: mgmt1: mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:23 brd ff:ff:ff:ff:ff:ff

6: bi0: mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:20 brd ff:ff:ff:ff:ff:ff

vf 0 MAC 00:6f:2a:01:b0:00, spoof checking on, link-state auto

7: bi1: mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000

link/ether 00:a0:a5:68:b9:21 brd ff:ff:ff:ff:ff:ff

8: bi0_vf0: mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000

link/ether 22:e3:dc:63:90:6e brd ff:ff:ff:ff:ff:ff

9: fi0_vf0: mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000

link/ether 00:6f:2a:01:f0:00 brd ff:ff:ff:ff:ff:ff

10: virbr0: mtu 1500 qdisc noqueue state DOWN mode DEFAULT

link/ether 52:54:00:45:b8:12 brd ff:ff:ff:ff:ff:ff

11: virbr0-nic: mtu 1500 qdisc pfifo_fast master virbr0 state DOWN mode DEFAULT qlen 500

link/ether 52:54:00:45:b8:12 brd ff:ff:ff:ff:ff:ff

Br, Nicole

st4
New Contributor III
36 Views

Hi NicoleZ,

Thank you for the update. I will further check on this.

rgds,

wb

 

st4
New Contributor III
36 Views

HI Nicole.Z

You may upgrade to newer VF driver version at https://downloadcenter.intel.com/product/32609/Intel-82599-10-Gigabit-Ethernet-Controller https://downloadcenter.intel.com/product/32609/Intel-82599-10-Gigabit-Ethernet-Controller. Please contact your system vendor if you using using an onboard NIC for them to further assist on this.

rgds,

wb