Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DKang4
Beginner
917 Views

VF bus-info is null with xen4.4

Hi guys!

I installed Ubuntu 12.04 LTS(Kernel version: 3.8.1) and Xen 4.4 to make VM using VF.

I use 2 82599 10G nic.

So I made some VFs and set "iommu=1" in GRUB like these.

root@NewXebra2:/guest# lspci | grep Eth

01:00.0 Ethernet controller: Intel Corporation 82576 Gigabit Network Connection (rev 01)

01:00.1 Ethernet controller: Intel Corporation 82576 Gigabit Network Connection (rev 01)

82:00.0 Ethernet controller: Intel Corporation 82599EB 10-Gigabit SFI/SFP+ Network Connection (rev 01)

82:00.1 Ethernet controller: Intel Corporation 82599EB 10-Gigabit SFI/SFP+ Network Connection (rev 01)

82:10.0 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

82:10.1 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

82:10.2 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

82:10.3 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

82:10.4 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

82:10.5 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

82:10.6 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

82:10.7 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

84:00.0 Ethernet controller: Intel Corporation 82599EB 10-Gigabit SFI/SFP+ Network Connection (rev 01)

84:00.1 Ethernet controller: Intel Corporation 82599EB 10-Gigabit SFI/SFP+ Network Connection (rev 01)

84:10.0 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

84:10.1 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

84:10.2 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

84:10.3 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

84:10.4 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

84:10.5 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

84:10.6 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

84:10.7 Ethernet controller: Intel Corporation 82599 Ethernet Controller Virtual Function (rev 01)

And I also made VM(Paravirtualized Ubuntu 10.04 LTS) with 2 VFs. But...

it doesn't work...

Below, there are some information of Eth0(VF) by ethtool.

driver: ixgbevf

version: 2.11.3

firmware-version: N/A

bus-info: 0000:00:00.0

As you can see, bus address is null.

I also checked xen & ubuntu dmesg, but I can't find problem.

This is xen dmesg.

(XEN) Processor # 34 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x09] lapic_id[0x24] enabled)

(XEN) Processor # 36 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x0a] lapic_id[0x30] enabled)

(XEN) Processor # 48 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x0b] lapic_id[0x32] enabled)

(XEN) Processor # 50 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x0c] lapic_id[0x34] enabled)

(XEN) Processor # 52 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x0d] lapic_id[0x01] enabled)

(XEN) Processor # 1 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x0e] lapic_id[0x03] enabled)

(XEN) Processor # 3 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x0f] lapic_id[0x05] enabled)

(XEN) Processor # 5 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x10] lapic_id[0x11] enabled)

(XEN) Processor # 17 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x11] lapic_id[0x13] enabled)

(XEN) Processor # 19 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x12] lapic_id[0x15] enabled)

(XEN) Processor # 21 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x13] lapic_id[0x21] enabled)

(XEN) Processor # 33 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x14] lapic_id[0x23] enabled)

(XEN) Processor # 35 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x15] lapic_id[0x25] enabled)

(XEN) Processor # 37 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x16] lapic_id[0x31] enabled)

(XEN) Processor # 49 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x17] lapic_id[0x33] enabled)

(XEN) Processor # 51 6:12 APIC version 21

(XEN) ACPI: LAPIC (acpi_id[0x18] lapic_id[0x35] enabled)

(XEN) Processor # 53 6:12 APIC version 21

(XEN) ACPI: LAPIC_NMI (acpi_id[0xff] dfl dfl lint[0x1])

(XEN) Overriding APIC driver with bigsmp

(XEN) ACPI: IOAPIC (id[0x06] address[0xfec00000] gsi_base[0])

(XEN) IOAPIC[0]: apic_id 6, version 32, address 0xfec00000, GSI 0-23

(XEN) ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)

(XEN) ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)

(XEN) ACPI: IRQ0 used by override.

(XEN) ACPI: IRQ2 used by override.

(XEN) ACPI: IRQ9 used by override.

(XEN) Enabling APIC mode: Phys. Using 1 I/O APICs

(XEN) ACPI: HPET id: 0x8086a301 base: 0xfed00000

(XEN) Failed to get Error Log Address Range.

(XEN) Using ACPI (MADT) for SMP configuration information

(XEN) SMP: Allowing 24 CPUs (0 hotpl...

0 Kudos
0 Replies
Reply