Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RKazh
Beginner
295 Views

VF creation failure - x710 Intel adapter

HI,

I am trying new Intel controller with sr-iov functions , and there are 2 problems with VF creation once the SFPs are connected to the swich and the link is UP.

  1. During server boot there is strange message ": Non-contiguous TC "
  2. If I am truing to create VF after OS is loaded :

if the link is up - VF failed .

if the link is down VF created , but cannot get line rate .

If the server loaded without link UP - everything works perfectly.

 

log example :

 

Feb 12 17:28:22 FORTIpoc1 kernel: i40e 0000:05:00.0: couldn't add VEB, err I40E_ERR_ADMIN_QUEUE_ERROR aq_err I40E_AQ_RC_ENXIO

Feb 12 17:28:22 FORTIpoc1 kernel: i40e 0000:05:00.0: couldn't add VEB

Feb 12 17:28:22 FORTIpoc1 kernel: i40e 0000:05:00.0: add vsi failed for VF 0, aq_err 6

the " Non-contiguous TC " message during the bootloader , long before kernel .

Same issue i have on two differen HP servers G10 and G9

also Redhat 7 and Centos7.7 OS

 

Info :

# dmidecode 3.2

Getting SMBIOS data from sysfs.

SMBIOS 3.2.1 present.

# SMBIOS implementations newer than version 3.2.0 are not

# fully supported by this version of dmidecode.

 

Handle 0x0091, DMI type 3, 21 bytes

Chassis Information

    Manufacturer: HPE

    Type: Rack Mount Chassis

    Lock: Not Present

    Version: Not Specified

    Serial Number: CZJ93802PS

    Asset Tag:

    Boot-up State: Safe

    Power Supply State: Safe

    Thermal State: Safe

    Security Status: Unknown

    OEM Information: 0x00000000

    Height: 1 U

    Number Of Power Cords: 2

    Contained Elements: 0

 

11:00.0 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 02)

11:00.1 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 02)

11:02.0 Ethernet controller: Intel Corporation Ethernet Virtual Function 700 Series (rev 02)

11:0a.0 Ethernet controller: Intel Corporation Ethernet Virtual Function 700 Series (rev 02)

 

 

[root@fkvm ~]# ethtool -i ens1f0

driver: i40e

version: 2.10.19.82

firmware-version: 7.20 0x8000794b 1.2585.0

expansion-rom-version:

bus-info: 0000:11:00.0

supports-statistics: yes

supports-test: yes

supports-eeprom-access: yes

supports-register-dump: yes

supports-priv-flags: yes

 

Thank you

Ruslan

0 Kudos
20 Replies
CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Thank you for posting in Intel Ethernet Communities. 

 

We'd like to check if you have tried the steps from the link below? 

SR-IOV Configuration Guide Intel® Ethernet CNA X710 & XL710 on Red Hat* Enterprise Linux 7* 

https://www.intel.com/content/dam/www/public/us/en/documents/technology-briefs/xl710-sr-iov-config-g...

 

Please also share the links where the driver and firmware were downloaded form. 

 

We look forward to your response.

 

In case we don't hear form you, we will follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

RKazh
Beginner
141 Views

Hi Crisselle . For VF creation we are using the same guide you sent. Driver and firmware were downloaded from Intel site also https://downloadcenter.intel.com/download/24411/Intel-Network-Adapter-Driver-for-PCIe-40-Gigabit-Eth... Thank you ! Regards, Ruslan Kazhdan Network Engeneer Wired Communication Department [cid:image001.png@01D0F3C9.D3682BE0]
CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Appreciate your response.

 

Please allow us to check on your query. We will give you an update as soon as possible but no later than 3 business days.

 

Hoping for your kind patience.

 

Best regards,

Crisselle C

Intel® Customer Support

CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Good day!

 

While we are checking on this, can you share if you have already tried the latest VF driver from the link below?

https://downloadcenter.intel.com/download/24693/Intel-Network-Adapter-Virtual-Function-Driver-for-In...

 

You also mentioned that you have different HP servers G10 and G9 having the same issue, kindly provide the model of the Ethernet adapters installed on your server as well as the Physical Function (PF) and Virtual Function (VF) loaded.

 

We look forward to your response.

 

In case we don't receive a reply, we will follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

RKazh
Beginner
141 Views

Hi, The iavf drivers is also updated to last version. ( one you sent ) Regarding different servers , I used same card model x710-da2 in hpg9 and hp g10 also , and exchange between them – same results. I suspecting that the issue is related to DCB features I took it from the error output during the boot process and from your README file Data Center Bridging (DCB)
CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Thank you for the reply.

 

We will continue to check on this issue. We will give you an update once there is any findings but no later than 3 business days.

 

Hoping for your king understanding.

 

Best regards,

Crisselle C

Intel® Customer Support

CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Good day!

 

While we are checking on this, you've mentioned that you suspected that the issue is related to DCB features. With this, we'd like to confirm if you have enabled the DCB feature? If yes, have you tried disabling it to check if the issue would still persist?

 

Awaiting to hear from you.

 

Should there be no response, we will follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

How are you today?

 

We'd like to check if you have read our previous message. If you do, please share the requested additional details for us to further investigate the issue.

 

Looking forward to your reply. 

 

We will follow up after 3 business days in case we don't hear from you.

 

Best regards,

Crisselle C

Intel® Customer Support

RKazh
Beginner
141 Views

Hi, Those switches are not supporting any DCB features , on intel side I don’t know how to disable it. I addition , the cisco 9300 is not causing any problem during the server boot process ( mistake in the previous mail ) – only Juniper 4500 for now causing the problem . Thank you Regards, Ruslan Kazhdan Network Engeneer Wired Communication Department [cid:image001.png@01D0F3C9.D3682BE0]
CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Thank you for the reply.

 

Can you share the exact error message you got when using the  Juniper 4500? This would help us in further investigating the issue.

 

Just to clarify, if you tried to connect any of your servers to Cisco 9300, you don't encounter any issues on VF creation or SR-IOV functions and the problem is only specific to Juniper 4500? Kindly confirm.

 

Awaiting to hear from you.

 

Should there be no response, we will follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Good day!

 

We'd like to follow up the additional information we requested as this would help us in further checking your query.

 

Looking forward to your reply.

 

Should there be no response, we will follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

RKazh
Beginner
141 Views

Hi Right after the boot loader the error is Non-contiguous TC …. ( unfortunately I cannot reproduce this error again to have an exact message ) And in Linux log is ( dmesg) Feb 12 17:28:22 FORTIpoc1 kernel: i40e 0000:05:00.0: couldn't add VEB, err I40E_ERR_ADMIN_QUEUE_ERROR aq_err I40E_AQ_RC_ENXIO Feb 12 17:28:22 FORTIpoc1 kernel: i40e 0000:05:00.0: couldn't add VEB Feb 12 17:28:22 FORTIpoc1 kernel: i40e 0000:05:00.0: add vsi failed for VF 0, aq_err 6 Both of the logs are even befoure the VF creation. If the servers are connected to cisco 9300 I don’t encounter any issues on VF creation or SR-IOV functions. For now the problem the is only specific to Juniper 4500 Regards, Ruslan Kazhdan Network Engeneer Wired Communication Department [cid:image001.png@01D0F3C9.D3682BE0]
CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Thank you for the reply.

 

Please allow us to continue to check on this. We will give you an update as soon as there is any findings but no later than 3 business days.

 

Hoping for your patience.

 

Best regards,

Crisselle C

Intel® Customer Support

CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Good day!

 

We sincerely apologize for the delay on this matter as we are thoroughly checking on this. Please give us more time to look into this. Rest assured that we will give you an update as soon as there is any findings but not later than 3 business days.

 

Thank you for your kind understanding.

 

Best regards,

Crisselle C

Intel® Customer Support

CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Good day!

 

While we are still investigating on this, we'd like to check if you have tried the latest PF – 2.11.29 from sourceforge link below. https://sourceforge.net/projects/e1000/files/i40e%20stable/

 

Looking forward to your reply.

 

Should there be no response, we will follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

How are you today?

 

Please let us know if you have already tried the driver from the link above and share the results with us.

 

Awaiting to hear from you.

 

We will follow up after 3 business days in case we don't receive a reply.

 

Best regards,

Crisselle C

Intel® Customer Support

RKazh
Beginner
141 Views

Hi, Those servers are in production environment , I have to wait for a new srv to install and check the drivers. It will take some time. Regards, Ruslan Kazhdan Network Engeneer Wired Communication Department [cid:image001.png@01D0F3C9.D3682BE0]
CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Thank you for the reply.

 

We understand the the server is already in production. With this, we'd like to check if it is alright to temporarily close this request or would you prefer to keep this open. If the latter, please let us know on when do you expect to to test the latest PF driver from the above link.

 

We hope to hear from you soon.

 

Should there be no response, we will follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

CrisselleF_C_Intel
Moderator
141 Views

Hello Ruslan,

 

Good day!

 

We'd like to check if you have read our previous message. If you do, please share if you want to temporarily close this request or would you prefer to keep this open. If the latter, please let us know on when do you expect to to test the latest PF driver from the above link.

 

Looking forward to your reply.

 

Should there be no response, we will follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support