Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CHast1
Beginner
2,127 Views

VMQ on Intel X710-T4 and Windows Server 2016

Hello Everyone,

 

I have run into a huge problem on a new server build. I have a Dell PowerEdge R730xd and purchased an Intel X710-T4 4 port 10gbase-t NIC for use with Hyper-V running on Windows Server 2016.

When I enable VMQ (Virtual Machine Queues) on the port it drops the throughput down significantly, on a 10 gigabit port it brings it down to a around 35MB/sec. When I disable VMQ it goes back up to using the full bandwidth of the port.

I am running the latest Intel drivers off of the Intel download website for Windows Server 2016.

I know that VMQ had been a huge problem with Broadcom NICs and Hyper-V in the past. I use Intel X540-T2 NICs in some of my other servers and they work fine, so this appears to be some issue with the X710-T4.

Any help would be appreciated! Thanks!

0 Kudos
3 Replies
idata
Community Manager
357 Views

Hi Cphastings,

 

 

Thank you for posting in Wired Communities. Just to double check if this is the latest driver you downloaded? PROSet version 22.7.

 

https://downloadcenter.intel.com/download/22283/Ethernet-Intel-Ethernet-Adapter-Connections-CD?produ...

 

 

Please check if there is "Large Send Offload" in the advance setting and disable this option to see this will make any difference.

 

 

Do feel free to update me.

 

 

Thanks,

 

Sharon

 

CHast1
Beginner
357 Views

Hi Sharon,

I finally figured out the problem. There is a driver option that is hidden when you install the Intel ProSet drivers but is exposed with the built in Windows Server 2016 drivers. The option is called "VMQ VLAN Filtering". Disabling that option corrected the problem and now I am getting full bandwidth through the ports as expected.

 

Thanks,

Cliff

idata
Community Manager
357 Views

Hi Cphastings,

 

 

Thank you for the information and I am glad the issue is fixed. Please feel free to update me if you still have other inquiries.

 

 

Thanks,

 

Sharon

 

Reply