Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
5020 Discussions

Weird extremely slow speed 0.04MB after enabled jumbo frame


Hi guys,

For the life I couldn't figure this out.

I have built two server both using Intel S5520HC and NIC is Intel 1000 PT Quad LP.

All the OS is running Windows 2008 R2 SP1, newest firmware on motherboard, newest driver for NIC.

Have used the default MS driver and Intel driver as well.

Regular speed between the server and another server is around 60MBytes /sec using iPerf.

As soon as I enabled the jumbo frame on the PT nic, and I run iPerf again, the speed would drop down to 0.04Mbytes/sec.

Jumbo packet set at 9014 Bytes, Flow Control is on Rx/Tx.

I thought it's my switch, so I changed 3 different switch. Dell PowerConnect, Cisco 2960, HP Procurve.

Still the same.

Changed out all the cables.

Still the same.

Talked to Intel Tech support on PT nic card. Couldn't solve it as well. We've return 1 NIC card back and bought another brand new one.

Same thing. The RMA came back, put it back in, jumbo frame enabled, speed dropped to 0.04MB..

The PT card is plugged in under slot 3 for PCI Express Gen2x8 slot, but under Intel management page shows up at x4, and I've tried different PCI Express slot, and the result were the same.

Formatted the Windows about 3 times, still couldn't figure out.

One thing I do noticed is that under iPerf, if I specified the TCP Windows Size to be 128KB, my transmitting speed would reach 110MB/sec, but under R2, the TCP value became autotune, so there is no way for me to specified in.

Anyone knows what happened to the jumbo frame ?

This problem is driving me crazy... thanks ahead for any suggestion!

0 Kudos
0 Replies