Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jjohn101
Beginner
421 Views

What would cause my network card to keep repeatedly show discards and errors? On a regular basis if I run "netstat -e" there are discards and errors. Would an old driver cause this issue?

Jump to solution

I have changed network cable and port.

 

It happens to more than one pc running the same OS and drivers. Other pcs are on different network/VLAN.

 

 

 

OS:Windows 7 pro sp1

 

Intel I218-LM

Current Driver date: 7/26/2016

Driver version: 12.15.23.7

 

0 Kudos
1 Solution
Michael_L_Intel2
Moderator
79 Views
Hello Jjohn101, It is really hard to pinpoint the exact root cause of the issue since the NIC is on-board. When a NIC is on-board, it is using the system resources like the RAM and processor. What we can do is provide recommendations to possible fix the issue. And just to add, different board manufacturer have different implementation on how the use on-board NIC and some of them even modify the NIC cards. As for my recommendation, you may try updating the driver since our latest generic driver is version 23.5.2 https://downloadcenter.intel.com/product/71307/Intel-Ethernet-Connection-I218-LM If you have questions, please let us know. Best regards, Michael L. Intel Customer Support Under Contract to Intel Corporation

View solution in original post

4 Replies
Michael_L_Intel2
Moderator
79 Views
Hello Jjohn101, Thank you for posting in Intel Ethernet Communities. It is hard to tell the possible cause of the issue. You may need to perform further test and a lot of observation to identify the cause. For me to provide some recommendations that may prevent the issue from happening again, please provide the following details. 1. Are you using an on-board NIC? 2. Is it happening before? 3. What steps have you tried so far to fix the issue? If you have questions, please let us know. Best regards, Michael L. Intel Customer Support Under Contract to Intel Corporation
Jjohn101
Beginner
79 Views

1. Are you using an on-board NIC?

 

Yes, onboard NIC.

 

2. Is it happening before?

 

Yes, happens frequently.

 

Noticed latency on a few workstations , each time the NIC found with a large number of discards and errors.

 

3. What steps have you tried so far to fix the issue?

 

Originally rebooted workstations to resolve issue before spotting errors on NIC. Found that running the INTEL diagnostics fixes latency issue, reboot not required. Passes on all diagnostics - Connection, Cable and hardware. Will need solid proof on root cause because of rigid change control process, nothing else changed/modified.

Michael_L_Intel2
Moderator
80 Views
Hello Jjohn101, It is really hard to pinpoint the exact root cause of the issue since the NIC is on-board. When a NIC is on-board, it is using the system resources like the RAM and processor. What we can do is provide recommendations to possible fix the issue. And just to add, different board manufacturer have different implementation on how the use on-board NIC and some of them even modify the NIC cards. As for my recommendation, you may try updating the driver since our latest generic driver is version 23.5.2 https://downloadcenter.intel.com/product/71307/Intel-Ethernet-Connection-I218-LM If you have questions, please let us know. Best regards, Michael L. Intel Customer Support Under Contract to Intel Corporation

View solution in original post

Michael_L_Intel2
Moderator
79 Views
Hello Jjohn101, Just want to check if you tried updating the driver using the link that I provided. If you have questions, please let us know. Best regards, Michael L. Intel Customer Support Under Contract to Intel Corporation
Reply