Ethernet Products
Intel® Ethernet products and technologies
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
3699 Discussions

Windows 10 1809 - i219 and i211 NIC teaming not available?

ZM1
Beginner
10,919 Views

Hello, my Windows 10 was updated to 1809 today. I downloaded the latest Intel Ethernet drivers available (23.5) and am no longer seeing the Teaming option in the network adapter's properties in Device Manager. I've tried uninstalling and reinstalling the drivers which didn't fix it. Was the teaming option moved, or is it no longer available? I didn't see any mention of that in the release notes, so I'm not sure what is going on. Everything else on my comp is up to date.

0 Kudos
39 Replies
EElls
Beginner
544 Views
  • Windows 10 Pro
  • English, US
  • Multiple prompts
  • No errors
Daniel_D_Intel1
Employee
544 Views

Hello ZM1,

Please let us know if you still want to address the ANS protocol check box being unchecked in the physical adapter properties. To help reproduce this we will need additional information, as ANS protocol is checked in each of our adapters. Please let us know if you have any other questions.

 

@EElls​ 

Please let us know if you are providing information to address the topic "teaming not available", or if you are also having an issue with the checkbox for ANS protocol being unchecked. The teaming issue is being addressed in the following thread:

https://forums.intel.com/s/question/0D70P000006Bm8lSAC/

 

Best regards,

Daniel D

Intel Customer Support

Under contract to Intel Corporation

ZM1
Beginner
544 Views

Daniel,

 

I apologize, I completely forgot about this post. In regard to your question 5 days ago, I'm on Windows 10 Pro (English/US). Used individual PowerShell commands, no errors when inputting commands.

Daniel_D_Intel1
Employee
544 Views
Hello ZM1, Thank you for the information. We will check on this issue, and update you soon. Please let us know if you have any other questions. Best regards, Daniel D Intel Customer Support Under contract to Intel Corporation
VincentT_Intel
Moderator
544 Views
Hello ZM1, We're not able to replicate your issue in the lab. Sharing our configuration sequence below: 1. Fresh install of Windows 10 v1809 2. Install PROSet SW 23.5.1 3. Create Team (Adapter Fault Tolerance) using PROSet Powershell command for I219-V and another Intel network adapter. After successful creation of the team, the ANS protocol is checked in the team adapters. Please share the Team mode you've configured in your setup. Best Regards, Vince T. Intel Customer Support Under Contract to Intel Corporation
VincentT_Intel
Moderator
544 Views
Hello ZM1, We'd like to follow-up the Team mode information. Thanks. Best Regards, Vince T. Intel Customer Support Under Contract to Intel Corporation
ZM1
Beginner
544 Views

Hello Vince,

 

I'm running the team in Static Link Aggregation. If I recall correctly, it was prior to the team being created that the adapter's ANS protocol wasn't showing as checked, but was indeed checked as Windows would prompt me asking if I wanted to disable ANS once I put a check on it.

VincentT_Intel
Moderator
544 Views
Hi ZM1, Thank you for sharing the team mode, we'll try to configure Static Link Aggregation and share with you the result. Best Regards, Vince T. Intel Customer Support Under Contract to Intel Corporation
VincentT_Intel
Moderator
544 Views
Hi ZM1, We've tried Static Link Aggregation with I219-V and another Intel network adapter, the ANS protocol shows as checked in the team adapters. Best Regards, Vince T. Intel Customer Support Under Contract to Intel Corporation
VincentT_Intel
Moderator
544 Views
Hi ZM1, The issue might be isolated to your system. We'd also suggest to get in touch with your system manufacturer for further diagnostic. Did you encounter the ANS "unchecked" issue in previous version of Windows 10? Best Regards, Vince T. Intel Customer Support Under Contract to Intel Corporation
ZM1
Beginner
544 Views

Hi Vince,

 

No, I didn't have that issue in 1803. It's not hurting anything at the moment, so I'll leave it be. Thanks for checking into it for me.

VincentT_Intel
Moderator
544 Views
Hi ZM1, Thank you for the update. Normally, a clean install of Windows 10 version 1809 should resolve issues related to SW 23.5 but in you case, the teaming is working properly just the ANS is unchecked. There might be other factors contributing to your issue. We'd suggest to get in touch with your system manufacturer for further investigation since the I219 and I211 were integrated to their board. On our end, we're not able to replicate your issue. I will double check internally and get back to this thread if there's other findings. Best Regards, Vince T. Intel Customer Support Under Contract to Intel Corporation
VincentT_Intel
Moderator
544 Views
Hi ZM1, Sharing with you the latest development regarding Team and VLAN configuration issues in Windows 10 version 1809, please visit the link below for detail information: https://forums.intel.com/s/question/0D50P00004GdeWSSAZ/team-and-vlan-configuration-issues-for-micros... Best Regards, Vince T. Intel Customer Support Under Contract to Intel Corporation
JOffi
Beginner
544 Views

I have not yet tried the powershell solution to restore VLAN support, but I wanted to add a note that this also appears to affect those of us with the I210 card.

 

PS C:\WINDOWS\system32> Get-IntelNetAdapter

 

Location    Name                              ConnectionName      LinkStatus

--------    ----                              --------------      ----------

2:0:0:0     Intel(R) Ethernet I210-T1 GbE NIC               Ethernet         1.00 Gbps ...

 

I'd just updated to the latest and greatest (tongue-in-cheek) Win10 release. Post reboot, vlan support is gone. Have gone through similar steps, completely removed the software, updated to latest pro64 driver, added the ANS extension through the installer. I'll try re-adding the VLANs through powershell and report back, hopefully this will resolve the I210 cards as well.

JOffi
Beginner
544 Views

Can confirm the steps mentioned above were able to resolve my vlan issues, you need to re-run the command for each vlan interface, it might look like you can add multiple, but it does not.

 

 

  1. Get-IntelNetAdapter
  • Which I then copied "Intel(R) Ethernet I210-T1 GbE NIC" from under the name column.
  1. Add-IntelNetVLAN
  • ParentName[0]: copy/paste from the name column of previous step
  • ParentName[1]: <press enter>
  • VLANID[0]: <desired vlan ID>
  • VLANID[1]: <press enter>

 

Sorry to hijack the thread, but wanted to help out.

 

VincentT_Intel
Moderator
544 Views

Hi ZM1,

 

Please be informed the SW 24.1 is already available in Download Center, for additional details, kindly check this thread.

 

Let us know if it fixes your ANS issue.

 

 

Best Regards,

 

Vince T.

Intel Customer Support

A Contingent Worker at Intel

VincentT_Intel
Moderator
544 Views

Hi ZM1,

 

Please let us know if the SW 24.1 fixes your teaming issue. Looking forward to your response.

 

 

Best Regards,

 

Vince T.

Intel Customer Support

A Contingent Worker at Intel

ZM1
Beginner
544 Views
VincentT_Intel
Moderator
544 Views

Hi ZM1,

 

Glad to know the issue has been fixed. Feel free to create a new thread if you have other question related to Intel® Network Adapter.

 

Thank you for your patience and being our valued customer.

 

 

Best Regards,

 

Vince T.

Intel Customer Support

A Contingent Worker at Intel

Reply