Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,723 Views

Windows 7 x64 and 82577LM

Hi,

First, sorry for my english, I'm French.

I still can't test with W7 x86 if the problem is similar but with the latest drivers here, I've got a lot of bad checksum. I use Wireshark.

My bandwidth isn't so bad but I've Ubuntu 10.10 x64 on the same laptop (it's a Dell E6410 and I've made a clean install of W7, without Dell's programs) and I don't have any errors using Wireshark and doing the same test. The bandwidth is also better under Ubuntu than Windows 7.

I love the Intel drivers on Windows with an integrated cable tester but it seems there is a problem with them, or maybe with Dell. I've made a test on a E6510 and the problem is the same.

Sorry if I haven't seen the solution here!

Thank you for your help.

Best regards!

Orchal

0 Kudos
6 Replies
Mark_H_Intel
Employee
60 Views

Thank you for your report. I would like to collect some additional information to help track down the issue you have reported.

Please confirm the driver and driver version for Windows 7 that you are using? Is your driver e1k62x64.sys? Is the version 11.8.75.0, dated 09/29/2010?

Are you seeing the errors on the 32-bit, 64-bit, or both versions of Windows 7?

Are you using all default settings for Windows TCP/IP and for Network Connection? If no, what changes have you made?

Are you seeing errors with IPv4, IPv6, or both?

Mark H

idata
Community Manager
60 Views

Hi,

First thank you for your fast reply. I'm using the 11.8.75.0 dated 09/29/2010 drivers on Windows 7 x64. As I said, I can't test on a x86 version of Windows 7 because I don't have any laptop or desktop with a 82577LM network adapter under this version.

I'm using all defaut settings for Windows TCP/IP and Network Connection. I've tried on my laptop, on which I maybe made changes, but I've tried on a fresh installed Dell E6510 Laptop and the problem is the same.

I can't try with IPv6 so i'm seeing errors with IPv4.

I've tried earlier drivers and this doesn't solve my problem.

Thank you a lot !

Best regards,

Orchal

Mark_H_Intel
Employee
60 Views

Are the checksum errors you are seeing in Wireshark are IPv4 checksums? TCP checksums? UDP Checksums? All checksums?

Try disabling TCP/IP offloads in the advanced settings to see if any of the settings change what you see with Wireshark.

Mark H

idata
Community Manager
60 Views

Hi,

This seems to solve my problem. I don't see errors anymore and the bandwidth is what it should be !

Thanks a lot !

Best regards.

Mark_H_Intel
Employee
60 Views

Which offloads did you disable to resolve the issue?

Mark_H_Intel
Employee
60 Views

Disabling TCP/IP offloads will put more load on your CPU. I did not see what Wireshark checksum errors you were seeing, but I am guessing these were probably not real errors. The thread at http://ask.wireshark.org/questions/634/acc-to-wireshark-999-of-my-outgoing-packets-have-a-bad-checks... http://ask.wireshark.org/questions/634/acc-to-wireshark-999-of-my-outgoing-packets-have-a-bad-checks... has good information.

Nevertheless, enabling TCP/IP offloads gave you reduced performance in comparison to Ubuntu. I suspect that the performance issues might be able to be resolved with some network tuning in Windows. I found a number of possible tweaks listed at http://www.speedguide.net/articles/windows-7-vista-2008-tweaks-2574 http://www.speedguide.net/articles/windows-7-vista-2008-tweaks-2574. I have not experimented with these myself, but some of these tweaks might help you.

I hope this helps.

Mark H