Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CColl9
Novice
3,320 Views

Wired Ethernet 82579 fails on boot since win10 update Sept17

Jump to solution

Hi there. Hope you can Help?

Intel 82579 Network adaptor fails to start on Boot since latest Win10 update (Sept 2017 - major re-build "Creators update?").

Wifi comes on, but I have to restart the PC for the ethernet to be found. Then it works fine.

I've updated, uninstalled and reinstalled drivers

(Latest "driver updates" from Intel were last week, installed ethernet driver shown as July 2016 : 12.15.31.4 )

I've turned off "energy efficiency" mode and also RSS following a recent thread

 

I've enabled legacy switch compatibility

 

I've set Linkspeed to forced

Mobo is Asus P8Z68-V running i7-2600k chip and 16gB RAM, - getting on but plenty of life left in this - don't plan to change kit for some time.

 

BIOS, chipset and other drivers all up to date.

I really don't want to have to Boot and then Re-boot my desktop every day for the next few years!

Any help much appreciated

Chris.


Accepted Solutions
CColl9
Novice
102 Views

SOLVED !

 

SOLUTION 1

From the Win10 start menu choose > SETTINGS > Power & Sleep > Additional Power Settings> "Choose what the power buttons do" > "Change settings that are currently unavailable" > and then UNTICK the "Turn on Fast Start-up (recommended)" box

Basically what's been happening is on Fast start-up it tries to use the previous sessions 'ipconfig', Without the fast start-up, it resets the ipconfig and then loads the network driver from scratch - so it finds your adapter.

(Also... under SETTINGS>DEVICES>Device Manager>Network Adapters> intel..Gigabit Network Connection >(RightClick)Properties>Power Management> UNCLICK "Energy Efficient Ethernet", which will shut down your connection if you don't use it for a while!. )

SOLUTION 2

In the meantime, If Solution 1 isn't available on your machine for some reason, then N Scott Pearson's suggestion looks like a good workaround (repeated here for clarity)

1. Create a file named NetRenew.bat and place the following commands into it:

@echo off

ipconfig /release

ipconfig /renew

2. Place a shortcut to this file into your Startup folder (i.e. C:\Users\\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup).

3. Test whether, with this change in place, the problem is alleviated. If it is, then you have a workaround.

I used Solution 1 and all is working well.

CHEERS !

View solution in original post

10 Replies
idata
Community Manager
102 Views

Chris_UK_2017: Thank you very much for contacting the Intel® communities. I will transfer your case to the proper department, an agent in there will further assist you on this matter.

 

 

Regards,

 

Alberto R

 

n_scott_pearson
Super User Retired Employee
102 Views

Here's an experiment to try:

1. Create a file named NetRenew.bat and place the following commands into it:

@echo off

ipconfig /release

ipconfig /renew

2. Place a shortcut to this file into your Startup folder (i.e. C:\Users\\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup).

3. Test whether, with this change in place, the problem is alleviated. If it is, then you have a workaround.

Hope this helps,

...S

idata
Community Manager
102 Views

HI Chris_UK_2017,

 

 

Thank you for posting in Wired Communities. As this is an onboard NIC on Asus, have you tried contacting Asus for the customized driver for the Windows* 10 upgrade. It is recommended to use the driver from the board vendor.

 

 

Regards,

 

Sharon

 

CColl9
Novice
102 Views

Thanks N. Scott Pearson

 

I'll give that a try and report back.
CColl9
Novice
102 Views

Thanks Sharon

I have all the latest "Win 10" drivers from Asus for this motherboard.

In the meantime I've found an option in the power menu to "Disable fast start-up" which I'm hoping will be very similar to what N Scott Pearson suggests below - ie load all drivers from scratch at start. (I'm on SSD, so Boot time not a big issue)

I'll report back.

idata
Community Manager
102 Views

Hi Chris_UK_2017,

 

 

Thank you for the update. Please feel free to update me the test result.

 

 

Regards,

 

Sharon

 

CColl9
Novice
103 Views

SOLVED !

 

SOLUTION 1

From the Win10 start menu choose > SETTINGS > Power & Sleep > Additional Power Settings> "Choose what the power buttons do" > "Change settings that are currently unavailable" > and then UNTICK the "Turn on Fast Start-up (recommended)" box

Basically what's been happening is on Fast start-up it tries to use the previous sessions 'ipconfig', Without the fast start-up, it resets the ipconfig and then loads the network driver from scratch - so it finds your adapter.

(Also... under SETTINGS>DEVICES>Device Manager>Network Adapters> intel..Gigabit Network Connection >(RightClick)Properties>Power Management> UNCLICK "Energy Efficient Ethernet", which will shut down your connection if you don't use it for a while!. )

SOLUTION 2

In the meantime, If Solution 1 isn't available on your machine for some reason, then N Scott Pearson's suggestion looks like a good workaround (repeated here for clarity)

1. Create a file named NetRenew.bat and place the following commands into it:

@echo off

ipconfig /release

ipconfig /renew

2. Place a shortcut to this file into your Startup folder (i.e. C:\Users\\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup).

3. Test whether, with this change in place, the problem is alleviated. If it is, then you have a workaround.

I used Solution 1 and all is working well.

CHEERS !

View solution in original post

CColl9
Novice
102 Views

SOLVED - See Below

n_scott_pearson
Super User Retired Employee
102 Views

Thanks Chris, this is good to know - and explains an issue that I have with my laptop while travelling!

...S

idata
Community Manager
102 Views

Hi Chris_UK_2017,

 

 

Thank you for the update and sharing the helpful information. I am glad the issue is resolved.

 

 

Regards,

 

Sharon