Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
225 Views

X520 on Windows 10 and VMQ

Jump to solution

How come intel driver doesnt enable VMQ on Windows 10 when hyper-v installed??

Im investigating some terrible network performance (only 60MB on a 10G nic) and see no VMQ options in driver or Proset util. CPU0(node 0) goes to 100% whenever there is any networking going on.

 

regards

0 Kudos

Accepted Solutions
Highlighted
Moderator
101 Views

Re:X520 on Windows 10 and VMQ

Jump to solution

Hi DRigl1,

Thank you for waiting for our update.

After deliberating on your issue, as much as we would like to get the feature that you want working on your configuration, the VMDq implementation is a Server supported functionality and will not work in a client environment such as Windows 10 client. We sincerely apologize for we know the time that you spent to get this working.

If you have any feedback, please let us know. Should we not hear from you, we will follow up again after 3 business days. 




Best Regards,

Alfred S

Intel® Customer Support


View solution in original post

0 Kudos
21 Replies
Highlighted
Moderator
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hi DRigl1,

Thank you for posting in our Intel® Ethernet Communities Forum.

We need to gather information so we can provide you recommendations.

Please download and run our Intel® System Support Utility from this link,https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-. After running this program, it will create a text file. Kindly attach the text file on your reply.

Looking forward to your response. Should we not get your reply, we will follow up with you after three business days.

 

Best Regards,

Alfred S

Intel® Customer Support 

0 Kudos
Highlighted
Beginner
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

File attached as requested

 

regards

0 Kudos
Highlighted
Moderator
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hi DRigl1,

Thank you for finding time to generate and share those logs.

We performed an initial analysis on the logs and we have a couple of questions:

1. We found out that you are using the most recent version of Windows 10 Pro. Did VMQ work on a previous version of Windows or you started with the newest version?

2. Is the Enable VMQ option greyed out?

3. Have you done any initial troubleshooting and checks for this one, so we will know where to continue in case you have any?

 

Best Regards,

Alfred S

Intel® Customer Support 

 

0 Kudos
Highlighted
Beginner
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hello

 

1> This situation existed before the recent update to Windows 10 pro (i wanted to get the wsl v2)

2> Enable VMQ greyed out. ?? I just went back and had a look at 'control panel -> network connections -> Ethernet X' and also at the 'Proset Adapter Configuration Utility' and there are no options to enable VMQ anywhere. No mentionof VMQ at all.

3>As an illustration of the problem , whether from the host or a vm running on the host and using the psping.exe util (iperf and Ntttcp show similar) I get about 650MBs sending but only 70-80 MBs receiving from a server. This performance is reflected in file copies.

 

thanks

0 Kudos
Highlighted
Moderator
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hi DRigl1,

Thank you for the answering those questions.

Please allow us some time to check on your concern.

We will provide you an update no later than 3 business days from now.

Best Regards,

Alfred S

Intel® Customer Support 

 

0 Kudos
Highlighted
Moderator
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hi Drig1,

Thank you for patiently waiting.

We still need more time to check on your concern.

While we are checking, we would like to ask you if you have already tried enabling the vmq via powershell

You may refer to this page for more details::

https://docs.microsoft.com/en-us/powershell/module/netadapter/enable-netadaptervmq?view=win10-ps

We will wait for your answer, while we are investigating.

Best Regards,

Alfred S

Intel® Customer Support 

 

0 Kudos
Highlighted
Moderator
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hi Drig1,

This is just a follow up post.

We would like to ask if you were able to try our recommendation on our previous post.

Should we not hear from you, we will follow up after 3 business days.

Best Regards,

Alfred S

Intel® Customer Support 

 

0 Kudos
Highlighted
Beginner
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hello

the result is ...

 

PS C:\PS> Get-NetAdapterVmq

PS C:\PS>

PS C:\PS> Get-NetAdapter -Name "Ethernet 6"

 

Name                     InterfaceDescription                   ifIndex Status      MacAddress            LinkSpeed

----                     --------------------                   ------- ------      ----------            ---------

Ethernet 6               Intel(R) Ethernet Server Adapter X...#3     21 Up          90-E2-BA-9B-83-A5       10 Gbps

.

PS C:\PS> Get-NetAdapter -Name "Ethernet 6" | Enable-NetAdapterVmq

Enable-NetAdapterVmq : No MSFT_NetAdapterVmqSettingData objects found with property 'Name' equal to 'Ethernet 6'.

 

regards

 

0 Kudos
Highlighted
Moderator
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hi DRigl1,

We appreciate the time that you spent  to carry out the procedures listed on the link that we have provided.

Please allow us some time to further check on your concern.

We will get back to you no later than 3 business days from now.

 

Best Regards,

Alfred S

Intel® Customer Support 

 

0 Kudos
Highlighted
Moderator
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hi DRigl1,

Thank you for your patience in waiting for an update.

Our team is currently in the initial phase of our investigation about your issue, and we would like to ask for more information:

1. We would like to ask on how did you configure the SR-IOV of your system?

2.  Is your Windows 10 OS used as a guest or a host OS? 

Looking forward to hear from you. If we do not hear from you, we will reach out after 3 business days to ask if you need more time to provide the information above.

Best Regards,

Alfred S

Intel® Customer Support 

 

0 Kudos
Highlighted
Beginner
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hello

 

  1. Like vmq there is no mention of SR-IOV anywhere. Not in "control panel -> network config", not in "Proset config utility" not when creating the vm-switch. The powershell netadaptersriov cmdlets produce similar output to the vmq ones on my previous post
  2. Both host and guest are windows 10

regards

 

0 Kudos
Highlighted
Moderator
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hi DRigl1,

Thank you for the answers.

We will factor those things in our ongoing conversation.

We will try to provide you with an update on this no later than 3 business days from now.

Best Regards,

Alfred S

Intel® Customer Support 

0 Kudos
Highlighted
Moderator
170 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hi DRigl1,

We appreciate your patience in waiting for an update.

We have some questions and recommendations for you.

1. Have you tried testing with different versions of ethernet drivers on your system? If yes, just to confirm, none of them work, are we correct?

2. Please try to download and install version 25.1.1 from this link, https://downloadcenter.intel.com/download/22283/Intel-Ethernet-Adapter-Complete-Driver-Pack?product=...

3. We want to confirm the severity of the issue. How many of your systems with these cards are affected with this issue?

Looking forward to hearing from you. Should we not hear from you, we will check back after 3 business days.

Best Regards,

Alfred S

Intel® Customer Support 

 

 

 

 

0 Kudos
Highlighted
Beginner
162 Views

Re: X520 on Windows 10 and VMQ

Jump to solution

Hello

I didnt try many drivers, just what was current when i installed the adapter.  Device Manager was showing a driver "4.1.143.0" , "30/7/2019"., not sure how that translates but i think that was 25.0.

I just installed 25.1.1 and as far as i can tell its the same. None of the virtual machine functionality is enabled or visible

I work as an independent software developer / consultant, so this is just my machine.  Although now that more people are moving to 10G (media production , vm images) on the desktop I want to be in a position to understand/recommend the options.  Getting worse performance from a 10G card that i got from  the built in 1G was not what i was expecting.

Does / should this driver expose any of this functionality on Windows 10 at all ?? Im sure it works fine on Windows Server but maybe it checks the OS version on install/startup and just disables it ??

 

regards

 

0 Kudos
Highlighted
Moderator
152 Views

Re:X520 on Windows 10 and VMQ

Jump to solution

Hi David,

We are just following up.

It looks like you need more time to provide the information that we asked.

We will follow up again after 3 business days. Should we not hear from you, our system may automatically close the thread.



Best Regards,

Alfred S

Intel® Customer Support



0 Kudos
Highlighted
Moderator
150 Views

Re:X520 on Windows 10 and VMQ

Jump to solution

Hi DRigl1,

We are following up on a thread that is still open where you are having issues with enabling VMQ. We know that this is important for you to get it resolved and it is also equally important for us to give you the right solution. Since we have not heard from you for several days, the thread will automatically close after one business day.


Thank you for posting in our Intel® Ethernet Communities forum.


Best Regards,

Alfred S

Intel® Customer Support


0 Kudos
Highlighted
Beginner
145 Views

Re: Re:X520 on Windows 10 and VMQ

Jump to solution

Hello

I did reply on the 25th, you don't seem to have noticed

regards

 

0 Kudos
Highlighted
Moderator
141 Views

Re:X520 on Windows 10 and VMQ

Jump to solution

Hi DRigl1,

Thank you for your reply.

There was a system upgrade going on when you posted the message, and this could be the reason why we were not able to see it.

We appreciate your response. We will continue investigating keeping in mind the new set of questions that you have asked, and we will get back to you no later than 3 business days from now.



Best Regards,

Alfred S

Intel® Customer Support 


0 Kudos
Highlighted
Moderator
102 Views

Re:X520 on Windows 10 and VMQ

Jump to solution

Hi DRigl1,

Thank you for waiting for our update.

After deliberating on your issue, as much as we would like to get the feature that you want working on your configuration, the VMDq implementation is a Server supported functionality and will not work in a client environment such as Windows 10 client. We sincerely apologize for we know the time that you spent to get this working.

If you have any feedback, please let us know. Should we not hear from you, we will follow up again after 3 business days. 




Best Regards,

Alfred S

Intel® Customer Support


View solution in original post

0 Kudos