Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4931 Discussions

XL710 EEPROM checksum failed


* We are using a NIC that uses an XL710 chip. In some products, EEPROM checksum error occurs as shown below and Rx and Tx functions do not work.

* I want to know what the problem is and how to solve it. (For example, how to update NVM again, etc.)


[ 11.305530] i40e 0000:18:00.0: fw 7.0.50775 api 1.8 nvm 7.00 0x80008964 0.0.0
[ 11.305533] i40e 0000:18:00.0: The driver for the device detected a newer version of the NVM image than expected. Please install the most recent version of the network driver.
[ 11.777840] i40e 0000:18:00.0: eeprom check failed (-2), Tx/Rx traffic disabled
[ 11.793898] i40e 0000:18:00.0: MAC address: 00:0d:48:73:42:9f
[ 11.801932] i40e 0000:18:00.0: DCBX offload is not supported or is disabled for this PF.
[ 11.801996] i40e 0000:18:00.0: irq 240 for MSI/MSI-X
[ 11.802015] i40e 0000:18:00.0: irq 241 for MSI/MSI-X
[ 11.802035] i40e 0000:18:00.0: irq 242 for MSI/MSI-X

0 Kudos
2 Replies

Hello tggam,

Thank you for posting in Intel Ethernet Communities. 

Kindly provide the following information that would help in checking the issue. 

1. Exact model of your XL710. You may share the PBA of the adapter. Refer to the link below on where to find the PBA number. It consist of 6-3 digit number located at the last part of the serial number. This would also help us identify if you are using an Original Equipment Manufacturer(OEM) or retail version of Intel Ethernet Adapter.

Identify Your Intel® Network Adapter Model Using PBA Number

2. How many adapters are affected/involved on this issue?

3. Operating system used

4. When was the issue first encountered? 

5. Is this newly purchased adapter? If no, for how long did the adapter worked fine?

6. Is there any changes prior to the issue?

7. Kindly share output of ethtool -i ethx (where ethx is the Ethernet port) from one of the adapters having the issue and working without any problem.

8. Does the error occurs without doing anything with the adapter? Can you share more details on how and when does the error appears?

Looking forward to hear from you. 

Should there be no reply, we will follow up after 3 business days. 

Best regards,

Crisselle C.

Intel® Customer Support

0 Kudos

Hi CrisselleF


Thank you for answer 


Reinstalling the NIC's EEPROM image in DOS solved it.



0 Kudos