Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CPrei1
Beginner
245 Views

XXV710-V2 NVM won't update. Why?

I just purchased two new 25Gb XXV710 NICs. They're installed in Ubuntu 18.04 machines. They link and transfer data fine, but when I try to read DMI from installed SFP+ transceivers using ethtool's "-m" option, it doesn't work.

 

This gets displayed in dmesg, whenever I try use "sudo ethtool -m enp4s0" so I assume the i40e driver recognizes that the NIC's NVM is not at a current version.

[67157.193369] i40e 0000:04:00.0 enp4s0f0: Module EEPROM memory read not supported. Please update the NVM image.

I downloaded the latest NVM from here:

https://downloadcenter.intel.com/download/24769/Non-Volatile-Memory-NVM-Update-Utility-for-Intel-Eth...

 

And tried updating the XXV710's NVM, but it doesn't update. This is the result I get:

tech1@E11:~/700Series/Linux_x64$ sudo ./nvmupdate64e Intel(R) Ethernet NVM Update Tool NVMUpdate version 1.34.17.7 Copyright (C) 2013 - 2019 Intel Corporation. WARNING: To avoid damage to your device, do not stop the update or reboot or power off the system during this update. Inventory in progress. Please wait [.........-] Num Description Ver.(hex) DevId S:B Status === ================================== ============ ===== ====== ============== 01) Intel(R) Ethernet Connection (7) n/a(n/a) 15BC 00:000 Not supported I219-V 02) Intel(R) Ethernet Converged 7.16(7.10) 1572 00:002 Up to date Network Adapter X710-2 03) Intel(R) Ethernet Network Adapter 5.81(5.51) 158B 00:004 Update not XXV710-2 available Tool execution completed with the following status: All operations completed successfully. Press any key to exit. tech1@E11:~/700Series/Linux_x64$

The first time I ran the NVM update utility, it updated my X710's NVM, but not the XXV710's NVM. Now when I run the utility, I see there is a subtle wording difference between the status of the X710 "Up to date" vs the XXV710 "Update not available", but I'm not sure what the difference is supposed to convey.

 

Is the latest NVM version for the XXV710 really v5.51? Or should I be able to update it to v7.something?

 

Thanks in advance!!

 

 

0 Kudos
0 Replies